WD 540 caviar with linux? write-read partition?

WD 540 caviar with linux? write-read partition?

Post by Jay On » Fri, 06 Jan 1995 02:03:52



Hi, I have a WD Caviar 540 meg hard drive.  I am planning on putting a
DOS partition on it, using up the whole hard drive.  I want to know if
it is possible to make that 540 megs available to Linux, as a dos
mounted partition.

The reason I ask is that to use 540 megs in DOS, they have to make
their own partition type and load a DOS device driver.  Would the 540 megs
be available to Linux,or must I make a DOS partition on the drive
instead?

How good is Linux's support for 540 meg hard drives?
Thanks,
Jay

 
 
 

WD 540 caviar with linux? write-read partition?

Post by Cavem » Fri, 06 Jan 1995 02:35:26


: Hi, I have a WD Caviar 540 meg hard drive.  I am planning on putting a
: DOS partition on it, using up the whole hard drive.  I want to know if
: it is possible to make that 540 megs available to Linux, as a dos
: mounted partition.

: The reason I ask is that to use 540 megs in DOS, they have to make
: their own partition type and load a DOS device driver.  Would the 540 megs
: be available to Linux,or must I make a DOS partition on the drive
: instead?

: How good is Linux's support for 540 meg hard drives?
: Thanks,
: Jay

--
I have this type of hard drive and have a Linux, DOS, and Linux swap
partition on it.  It works well.  Had some concern initially about the
warning messages concerning the drive having over 1024 cylinders that I
kept getting during the Slackware installation.  Never had any problems
with it.

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++


| http://www.netaxs.com/~bam/      |                    F. Zappa           |
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

 
 
 

1. hdparm, multiple mode, and WD Caviar 540

Two questions/problems:

1.  MULTIMODE?

I compiled and installed hdparm 1.6 about a week ago, and read in the
man page that enabling multiple mode on some drives ("most notably the
WD Caviar series") actually makes them run slower.

I just got a brand new (only a few weeks old) WD Caviar 540 to replace
my ancient Maxtor SCSI drive which finally died.  Does anyone know
whether enabling multimode will benefit me or not?

I'm using a VL-300 AHA1522-based scsi/ide/serial/parallel controller card
at the moment, so just plain IDE not EIDE.

here's what hdparm reports about the drive:

$ hdparm -i /dev/hda

/dev/hda:

 Model=WDC AC2540H, FwRev=12.08R30WDC AC2540H, SerialNo=WD-WT261
 Config={ HardSect NotMFM HdSw>15uSec SpinMotCtl Fixed DTR>5Mbs FmtGapReq }
 Physical CHS=1048/16/63, TrkSize=57600, SectSize=600, ECCbytes=4
 BuffType=DualPortCache, BuffSize=128KB, MaxMultSect=16
 Features: DblWordIO=no, LBA=yes, DMA=yes, tPIO=1(medium), tDMA=2(fast)
 Current CHS=1048/16/63, TotSect=1056384, MaxLBAsect=1056384
 MultSect=off, DMA-1w=0001, DMA-mw=0003
 EIDE: IORDY=switchable, mode3, tDMA={min:150,rec:150}, tPIO={min:330,iordy:180}

$ hdparm /dev/hda
/dev/hda:
 readahead = 8
 multcount = 0
 readonly  = 0
 unmaskirq = 0
 geometry  = 1048/16/63, offset = 0
 sectors   = 1056384

2.  hdparm -t crashes?

When I first installed hdparm, I enabled 16 sector multimode, then ran
"hdparm -t" whilst compiling a new version of the kernel in another VC.
I didn't expect any meaningful results (because of the disk thrashing
caused by the compile) but I also certainly didn't expect the system to
lock up.  All disk activity ceased, but I was still able to switch
consoles.  Couldn't do anything so eventually had to press the reset
button.

When I get time I'll reboot my machine into single user mode and test it
more thoroughly.  In the meantime, has anyone else noticed anything like
this?

--

    "Organise a strike in your school or workplace on the grounds that it
     does not satisfy your need for indolence & spiritual beauty."
                              -- Hakim Bey, The Temporary Autonomous Zone

2. hard drive copying

3. Using WD Caviar 540 on second IDE interface

4. apache-ssl problem !!!

5. 540 WD HD partition ???

6. Sendmail 8.6.9 in Solaris 2.3: Make fails with undefined symbol

7. Linux and WD 540 mg disk

8. samba and win2000 - beta 3

9. WD 220 MB and Maxtor 540 MB

10. need help with WD 540 meg HD and lilo...

11. WD Caviar w/Linux

12. WD Caviar 2850 (No Linux 32 head support??)

13. WD-Caviar-drive is too slow under Linux.