ifconfig, route, and socket: invalid argument (need help)

ifconfig, route, and socket: invalid argument (need help)

Post by Don Benne » Fri, 07 Oct 1994 06:51:24



Yesterday I accidently reset my linux box.  Now, when the ifconfig and
route programs are run, they return 'socket: invalid agrument'.  SLIP
won't connect either for the same reason.  Would someone who knows about
this please enlighten me on a ssolution to the problem??  Thanks

Don
--
"The human race is a remarkable creature, one with great potential, and I
hope that Star Trek has helped to show us what we can be if we believe
in ourself and our abilities."             -Gene Roddenberry (1921-1991)

 
 
 

ifconfig, route, and socket: invalid argument (need help)

Post by Matthew S. Crock » Sat, 08 Oct 1994 11:27:18


: Yesterday I accidently reset my linux box.  Now, when the ifconfig and
: route programs are run, they return 'socket: invalid agrument'.  SLIP
: won't connect either for the same reason.  Would someone who knows about
: this please enlighten me on a ssolution to the problem??  Thanks

Hmmm,  did you re-compile a new kernel?  sounds like you booted a
kernel without the SLIP or ethernet drivers compiled in...

-Matt

--
-Matthew S Crocker               "The mask, given time, comes

*OS/2*OS/2*OS/2*OS/2*OS/2*OS/2*OS/2*OS/2*OS/2*OS/2*OS/2*OS/2*OS/2*OS/2*OS/2*
 *linux*linux*linux*linux*linux*linux*linux*linux*linux*linux*linux*linux*

 
 
 

1. IFCONFIG gives socket: invalid argument

Hello,

When I boot Linux 1.1.59, and the rc.inet1 runs, I get

        socket: invalid argument
        socket: invalid argument

I have narrowed the problem down to the two lines:

/sbin/ifconfig lo 127.0.0.1
/sbin/route add -net 127.0.0.0

When I manually type these two commands at the prompt, I get the socket:
invalid argument error. It seems that when I make a slip connection using
dip, I can't telnet or ftp. I get the same error coming up.

What's going on here? How do I check the /dev/socket to make sure
everything is ok?

I appreciate any help.

Ujjal Bansel


2. 2nd SCSI Drive Howto?

3. netscape and visigenic(Caffeine and VisiBroker)

4. HELP !: "Socket(): Invalid argument" error with 2.2.8

5. FrameMaker Port , Need Encouragement

6. HELP! socket: invalid argument

7. Solaris x86

8. RTNETLINK answers: Invalid argument when adding route... help!

9. IP_ALIAS not working: ifconfig returns "SIOCAIFADDR: Invalid argument"

10. ifconfig ->socket: invalid arg

11. Problem with TCPDUMP ( it says : "tcpdump: socket: Invalid argument" ??!!

12. dhcpcd: dhcpStart: socket: Invalid argument