Zlib & libc-4.6.27 & gcc-2.6.2

Zlib & libc-4.6.27 & gcc-2.6.2

Post by Kevin Zup » Tue, 14 Feb 1995 09:07:33



I was just wondering if there was ever a solution found to this combination.
I saw two posts on the problem of getting segmentation faults when using this
combo, but never any answers. I have applied the current patches but no luck I  still get segmentation faults. Any help is welcome.

                                     Thanx Very Much
                                      Kevin Zupan

 
 
 

1. libc4.6.27, gcc2.6.2 & ZMAGIC

Yesterday I tried to upgrade my libc to 4.6.27 and gcc to 2.6.2.
After installing the files from sunsite.unc.edu:/pub/Linux/GCC,
I ran ldconfig -v so that ld.so can use the new libraries.  For
every library that I installed I received:

ldconfig: warning: /usr/lib/libdb.so.1.85.1 is not a ZMAGIC file, skipping
ldconfig: warning: /lib/libc.so.4.6.27 is not a ZMAGIC file, skipping
ldconfig: warning: /lib/libm.so.4.6.27 is not a ZMAGIC file, skipping
ldconfig: warning: /lib/libcurses.so.0.1.2 is not a ZMAGIC file, skipping
ldconfig: warning: /lib/libc-lite.so.4.6.27 is not a ZMAGIC file, skipping
ldconfig: warning: /usr/lib/libdb.so.1.85.1 is not a ZMAGIC file, skipping
ldconfig: warning: /lib/libc.so.4.6.27 is not a ZMAGIC file, skipping
ldconfig: warning: /lib/libm.so.4.6.27 is not a ZMAGIC file, skipping
ldconfig: warning: /lib/libcurses.so.0.1.2 is not a ZMAGIC file, skipping
ldconfig: warning: /lib/libc-lite.so.4.6.27 is not a ZMAGIC

What does this mean, and how can I fix it?  

I am using an 486 running kernel 1.1.52.

Thanks,
Mark Kidder
--
          Mark Stephen Kidder       | All my insticts, they return
    Mail: Public Affairs VA, Purdue | And the grand facade, so soon will burn

    ICBM: 40 25'11" N  86 55'02" W  | I reach out from the inside

2. Unix - Frequently Asked Questions (Contents) [Frequent posting]

3. Printf bug in libc-4.6.27 -- libc-4.7.5

4. Apache: Running on 2 different ports??

5. status of GCC 2.6.3 + libc-4.6.27 vs. kernel

6. Where do I...

7. cannot compile libc-4.6.27 !

8. Screensaver images with xset s noblank??

9. building libc-4.6.27

10. REQ: libc-4.6.27 a.out with nyx-0.27 support needed

11. Help W/ libc-4.6.27 Install

12. undefined: "__uflow" after libc-4.6.27

13. libc-4.6.27 + NYS -> Does it ever compile???