uugetty - won't init or answer modem

uugetty - won't init or answer modem

Post by Peter Berg » Tue, 11 Oct 1994 04:20:04



 > I've just upgraded from an old SLS release up to the June InfoMagic CD
 > and the Slackware distribution. Sadly, uugetty doesn't seem to be
 > working.
 > [...]

 > /etc/default/uugetty.ttyS1:

I'm pretty sure, that's your problem. Try again after you did:

ln -s /etc/default/uugetty.ttyS1 /etc/conf.uugetty.ttyS1

(appropriate changes are necessary for the other files in /etc/default OR you
recompile (uu)getty to suit your needs..).

bye,
    Peter


 
 
 

1. uugetty - won't init or answer modem

I've just upgraded from an old SLS release up to the June InfoMagic CD
and the Slackware distribution. Sadly, uugetty doesn't seem to be working.

I'm using getty_ps-2.0.7e with a 1.0.9 kernel. Slackware 2.0, anyway.

cu works fine. so does uucico. uugetty doesn't send the modem init
string. I can see teh 'receive' light flicker when an inbound call
comes along (the joys of external modems!), but the modem doesn't
get the answer string from uugetty. I know uugetty is 'talking' to
the right port, 'cuz the DTR light goes on when it starts. The logs
{/usr/adm/auth.log and /usr/adm/getty.debug.log} contain no useful
info, even at debuglevel 777.

The system is at runlevel 5. Here're the appripriate config snippets:

/etc/inittab:

  # Dialup lines
  d1:45:respawn:/sbin/uugetty ttyS1 19200 vt100

/etc/gettydefs:

  #  Modem locked at 19200:
  #

/etc/default/uugetty.ttyS1:

  CLEAR = NO
  HANGUP=YES
  #DEBUG=777
  DEBUG=010
  INIT="" ATZ\r OK ATS0=0\r OK
  ALTLOCK=cua1
  ALTLINE=cua1
  WAITFOR=RING
  CONNECT="" ATA\r CONNECT
  TIMEOUT=60

I'm open to suggestions ...

Replies via e-mail preferred, and a summary will be posted.
Thanks in advance,

glen

--
-------------------------------------------------------------------------

     "In between lies there lies the truth of what is just" - Juluka
-------------------------------------------------------------------------

2. FreeBSD & Linux viruses

3. Uugetty won't answer the phone ?

4. ksh: grep and variable with "$" in them???

5. modem won't pick up call with uugetty

6. X11 and Cirrus CL-GD/610-620. Help

7. Why won't uugetty work with null-modem?

8. Linux setup - as easy as you say?

9. uugetty won't reset modem

10. MODEM: share modem between 'uugetty' and a perl prog that pages

11. Dial in problem: Modem won't answer

12. dial-up with callback, modem won't answer

13. modem won't answer at slow speeds