wireless pci network card problem

wireless pci network card problem

Post by som » Mon, 14 Oct 2002 01:33:13



hey all.  i just went wireless at home and i'm having a problem
getting the belkin wireless pci network card (not the pcmcia card) to
work.  I tried downloading the newest linux-wlan driver but when I
install it, i got this error message:


find . -name .depend -exec rm {} \;
set -e; for d in src doc man etc; do make -C $d install ; done
make[1]: Entering directory `/home/matt/linux-wlan-ng-0.1.14-pre1/src'
set -e; for d in p80211 prism2 shared wlanctl wland nwepgen mkmeta
wlancfg; do make -C $d install ; done
make[2]: Entering directory
`/home/matt/linux-wlan-ng-0.1.14-pre1/src/p80211'
gcc -O2 -Wall -Wstrict-prototypes -fomit-frame-pointer -pipe
-D__LINUX_WLAN__ -D__KERNEL__ -DMODULE=1 -I../include
-I/usr/src/linux-2.4.18-14/include  "-DCONFIG_NETLINK=1 "
"-DCONFIG_PACKET=1 "  -c -o p80211conv.o p80211conv.c
p80211conv.c: In function `p80211pb_ether_to_p80211':
p80211conv.c:250: warning: concatenation of string literals with
__FUNCTION__ is deprecated
p80211conv.c: In function `p80211pb_p80211_to_ether':
p80211conv.c:320: warning: concatenation of string literals with
__FUNCTION__ is deprecated
gcc -O2 -Wall -Wstrict-prototypes -fomit-frame-pointer -pipe
-D__LINUX_WLAN__ -D__KERNEL__ -DMODULE=1 -I../include
-I/usr/src/linux-2.4.18-14/include  "-DCONFIG_NETLINK=1 "
"-DCONFIG_PACKET=1 "  -c -o p80211req.o p80211req.c
p80211req.c:84:32: wlan/p80211metadef.h: No such file or directory
p80211req.c: In function `p80211req_dorequest':
p80211req.c:147: `DIDmsg_lnxreq_ifstate' undeclared (first use in this
function)p80211req.c:147: (Each undeclared identifier is reported only
once
p80211req.c:147: for each function it appears in.)
make[2]: *** [p80211req.o] Error 1
make[2]: Leaving directory
`/home/matt/linux-wlan-ng-0.1.14-pre1/src/p80211'
make[1]: *** [install] Error 2
make[1]: Leaving directory `/home/matt/linux-wlan-ng-0.1.14-pre1/src'
make: *** [install] Error 2

If you have any ideas of what I can do to fix this problem please let
me know!!

THANKS!!