Can't get Sony CDU-31A-GD to mount

Can't get Sony CDU-31A-GD to mount

Post by Ray Kam » Wed, 15 Dec 1993 23:33:59



I have linux pl14 running under the slackware 1.1 distribution.
I cannot get my Sony CDU-31A-GD (gateway, 2x) cdrom drive to mount.
The drive works fine under windows :-(, but will not mount under linux.
I have rebuilt the kernel with the iso drivers and tried:

mount -t iso9660 /dev/sr0 /cdrom

It gives me some block error.  Has anyone had luck with this drive?

Thanks!

Ray Kamin

 
 
 

Can't get Sony CDU-31A-GD to mount

Post by Michael. » Thu, 16 Dec 1993 02:23:23



>I have linux pl14 running under the slackware 1.1 distribution.
>I cannot get my Sony CDU-31A-GD (gateway, 2x) cdrom drive to mount.
>The drive works fine under windows :-(, but will not mount under linux.
>I have rebuilt the kernel with the iso drivers and tried:
>mount -t iso9660 /dev/sr0 /cdrom
>It gives me some block error.  Has anyone had luck with this drive?
>Thanks!
>Ray Kamin

I haven't been able to get it to work either, I have a Gateway too.  Please
e-mail me if you get it to work, ok?

thanks,

Michael C. Chen

Computer Science Dept.
University of Illinios

 
 
 

Can't get Sony CDU-31A-GD to mount

Post by Adam J. Richt » Thu, 16 Dec 1993 11:20:55





>>I have linux pl14 running under the slackware 1.1 distribution.
>>I cannot get my Sony CDU-31A-GD (gateway, 2x) cdrom drive to mount.
>>The drive works fine under windows :-(, but will not mount under linux.
>>I have rebuilt the kernel with the iso drivers and tried:

>>mount -t iso9660 /dev/sr0 /cdrom

>>It gives me some block error.  Has anyone had luck with this drive?

        /dev/sr0 is for a SCSI CD-ROM.  Sony cdu31a CD-ROM drives
are accessed through a separate device.  In LGX, the device is
/dev/sonycd_31a.  I have no idea what is in other distributions.

--
Adam J. Richter                             Yggdrasil Computing, Incorporated
409 Evelyn Ave., Apt. 312, Albany CA 94706  4880 Stevens Creek Blvd., Suite 205
(510) 528-3209                              (408) 261-6630, fax: (408) 261-6631

 
 
 

Can't get Sony CDU-31A-GD to mount

Post by Corey Minya » Thu, 16 Dec 1993 13:41:59


: I have linux pl14 running under the slackware 1.1 distribution.
: I cannot get my Sony CDU-31A-GD (gateway, 2x) cdrom drive to mount.
: The drive works fine under windows :-(, but will not mount under linux.
: I have rebuilt the kernel with the iso drivers and tried:

: mount -t iso9660 /dev/sr0 /cdrom

This is the SCSI CDROM device.  You need to create a new device with
the command:

        mknod /dev/cdu31a b 15 0

Then use that for the mount.

Corey

 
 
 

Can't get Sony CDU-31A-GD to mount

Post by Robert E Mitche » Fri, 17 Dec 1993 15:34:57


        I have a Sony with my Gateway and had the same problem.  If you
are sure you specifically compiled support into the kernel for CDU-31A,
then this should help.  You are going to have to make a block device,
which is quite simple.  Go to the /dev directory.

Then , you can do...

a)delete the old sr0 (won't hurt if you aren't planning on adding another
SCSI cd-rom)

b)  mknod /dev/sr0 b 15 0

This will effectively create a new sr0 device, but it will be a block
device.  15 and 0 are "Major" and Minor" numbers which I believe are
specific to the device.  I had someone tell me this, but I belive I saw
them in the source for the driver.

Note that as far as I know, you don't need to delete sr0.  I belive that
you can call it whatever (scd0, sonycd, etc...) I chose sr0 because that
was consistent with the Sun I used to use at work.  Note that I could be
wrong here, but I think the name is more or less arbitrary (anyone care to
confirm?)

Hope this helps, and please don't hammer me to hard if I'm off base.  

Sex, *, and Yule...

Stump.

 
 
 

1. Sony CDU-33A = =CDU-31A?

I ordered a CDU31A (knowing that there are OS/2 and linux
drivers for it). I recieved a CDU33A instead. I am glad, it is a
double speed drive, but...

I tried OS/2 with the 31A drivers and it seems to run without
any noticable problems till now.

I don't yet have linux installed, but I am wondering...will it work
with the 31A drivers, or have 33A drivers been written?
I checked the hardware faq (version 0.6 dated Aug 93) and
that mentions drivers for the 31A but not 33A. I looked in the
LSM of December 13, and it mentions neither the 31A nor the
33A. (Why is the 31A driver not mentioned?)

I have not yet used linux, so I am just feeling my way around
the FAQ's and the HOWTO's. If anybody can help I could use
it. I do not subscribe to the comp.os.linux.* groups, so
please copy all replies to email as well. Thanx

2. "shutdown -r now" doesn't reboot anymore

3. Getting Fusion CD-16/Sony cdu-31a to work

4. Samba/smbfs, ncpfs -- works, but can't figure out how to mount

5. Yggdrasil Fall'93 w/ PAS16 and SONY CDU-31A.

6. HELP - Informix SE under Linux

7. Is Sony CDU-31A worth it with Linux?

8. Redhat 5 and TAR files

9. Sony CDU 31A-02 CD-ROM installation

10. Driver for SONY CDU-31A ???

11. Sony CDU-31A version 0.2 and patch1 available

12. Sony CDU-31a - driver for SMS 31083 controller?

13. PAS16 Sony Cdu 31a problem