cd-rom won't read audio cds

cd-rom won't read audio cds

Post by Broderick J. O'Conn » Thu, 20 Dec 2001 06:39:28



Hello. I'm a Linux newbie, and I'm having a problem with my cd-rom. I
used to be able to play audio cds in my cd-rom. Then, I had to do some
SCSI emulation so Redhat 7.0 would recognize my burner. Ever since
then, my cd-rom will only recognize data cds...not audio cds. When I
put the audio cd in and try to mount or open /mnt/cdrom, an error
message comes up saying "wrong media type". What can I do to fix the
situation? All my links to the device are correct, and the read-write
permissions on the device are correct.
 
 
 

cd-rom won't read audio cds

Post by -*harmonix* » Mon, 31 Dec 2001 08:31:32


On 18 Dec 2001 13:39:28 -0800

<Hello. I'm a Linux newbie, and I'm having a problem with my cd-rom. I
<used to be able to play audio cds in my cd-rom. Then, I had to do some
<SCSI emulation so Redhat 7.0 would recognize my burner. Ever since
<then, my cd-rom will only recognize data cds...not audio cds. When I
<put the audio cd in and try to mount or open /mnt/cdrom, an error
<message comes up saying "wrong media type". What can I do to fix the
<situation? All my links to the device are correct, and the read-write
<permissions on the device are correct.

have you tried just using `xplaycd` without mounting ?
if i try to mount an audio cd i get:

$ mount /dev/cdrom
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
       or too many mounted file systems

if i just use a cd playing app it works fine..
also using the buttons on the drive make it work aswell..independently of using an app to play it / mounting it.

--
-*harmonix*-
-Brigadier General agvngc-
-agvngc FAQ: <http://www.pequennino.clara.net>-
 11:28pm  up 55 min,  5 users,  load average: 0.03, 0.08, 0.11

 
 
 

cd-rom won't read audio cds

Post by Matthew Clin » Mon, 31 Dec 2001 11:28:20


Broderick J. O'Connor was touched by the minds of the terrible Old Ones,
and imparted unto us these blasphemous ravings:

Quote:> Hello. I'm a Linux newbie, and I'm having a problem with my cd-rom. I
> used to be able to play audio cds in my cd-rom. Then, I had to do some
> SCSI emulation so Redhat 7.0 would recognize my burner. Ever since
> then, my cd-rom will only recognize data cds...not audio cds. When I
> put the audio cd in and try to mount or open /mnt/cdrom, an error
> message comes up saying "wrong media type". What can I do to fix the
> situation? All my links to the device are correct, and the read-write
> permissions on the device are correct.

Try adding:

    append = "hdc=ide-scsi"

To your /etc/lilo.conf file

 
 
 

cd-rom won't read audio cds

Post by Pau » Tue, 01 Jan 2002 02:43:13



Quote:> Hello. I'm a Linux newbie, and I'm having a problem with my cd-rom. I
> used to be able to play audio cds in my cd-rom. Then, I had to do some
> SCSI emulation so Redhat 7.0 would recognize my burner. Ever since
> then, my cd-rom will only recognize data cds...not audio cds. When I
> put the audio cd in and try to mount or open /mnt/cdrom, an error
> message comes up saying "wrong media type". What can I do to fix the
> situation? All my links to the device are correct, and the read-write
> permissions on the device are correct.

If you are wanting to play or even burn a cd you do not need to mount
the cd.  Linux doesnt read audio media and will not mount it like
other file types.  Just bring up your favourite cdplayer toss your cd
in and enjoy.  IF you have a back up cd or some other cd with files on
it they you do use the mount command with the file type ie.  mount -t
vfat /dev/sr0 /dev/cdrom

Hope this helps and have a happy new year
Paul

 
 
 

cd-rom won't read audio cds

Post by -*harmonix* » Tue, 01 Jan 2002 03:26:33


On 30 Dec 2001 09:43:13 -0800


<> Hello. I'm a Linux newbie, and I'm having a problem with my cd-rom. I
<> used to be able to play audio cds in my cd-rom. Then, I had to do some
<> SCSI emulation so Redhat 7.0 would recognize my burner. Ever since
<> then, my cd-rom will only recognize data cds...not audio cds. When I
<> put the audio cd in and try to mount or open /mnt/cdrom, an error
<> message comes up saying "wrong media type". What can I do to fix the
<> situation? All my links to the device are correct, and the read-write
<> permissions on the device are correct.
<
<If you are wanting to play or even burn a cd you do not need to mount
<the cd.  Linux doesnt read audio media and will not mount it like
<other file types.  Just bring up your favourite cdplayer toss your cd
<in and enjoy.  IF you have a back up cd or some other cd with files on
<it they you do use the mount command with the file type ie.  mount -t
<vfat /dev/sr0 /dev/cdrom
<
<Hope this helps and have a happy new year
<Paul

i agree with this post !!

--
-*harmonix*-
-Brigadier General agvngc-
-agvngc FAQ: <http://www.pequennino.clara.net>-
  6:26pm  up 19:53,  5 users,  load average: 0.13, 0.14, 0.09

 
 
 

cd-rom won't read audio cds

Post by radi » Fri, 04 Jan 2002 08:06:01



Quote:> Hello. I'm a Linux newbie, and I'm having a problem with my cd-rom. I
> used to be able to play audio cds in my cd-rom. Then, I had to do some
> SCSI emulation so Redhat 7.0 would recognize my burner. Ever since
> then, my cd-rom will only recognize data cds...not audio cds. When I
> put the audio cd in and try to mount or open /mnt/cdrom, an error
> message comes up saying "wrong media type". What can I do to fix the
> situation? All my links to the device are correct, and the read-write
> permissions on the device are correct.

I have the exact same problem on my machine. I have already put a
modprobe line in rc.local, i already have put the options line in
modules.conf, i have created new symlinks to both of my cd-rom drives
in /dev.
When I open a cd player, it does not recognize an audio disc in either
my cd-rw or my dvd-rom drives.

can we just tell the cd player to look at /dev/scd0 instead of
/dev/cdrom??

Anybody have any other ideas about this issue?

 
 
 

cd-rom won't read audio cds

Post by radi » Fri, 04 Jan 2002 08:23:26



Quote:> Hello. I'm a Linux newbie, and I'm having a problem with my cd-rom. I
> used to be able to play audio cds in my cd-rom. Then, I had to do some
> SCSI emulation so Redhat 7.0 would recognize my burner. Ever since
> then, my cd-rom will only recognize data cds...not audio cds. When I
> put the audio cd in and try to mount or open /mnt/cdrom, an error
> message comes up saying "wrong media type". What can I do to fix the
> situation? All my links to the device are correct, and the read-write
> permissions on the device are correct.

well, I found that if I informed the cd player that my cd drive is at
/dev/scd0 then everything works fine. I wonder if the link /dev/cdrom
to /dev/scd0 should be a hard link rather than a symlink??
 
 
 

cd-rom won't read audio cds

Post by Broderick J. O'Conn » Wed, 16 Jan 2002 13:30:48



> Broderick J. O'Connor was touched by the minds of the terrible Old Ones,
> and imparted unto us these blasphemous ravings:

> > Hello. I'm a Linux newbie, and I'm having a problem with my cd-rom. I
> > used to be able to play audio cds in my cd-rom. Then, I had to do some
> > SCSI emulation so Redhat 7.0 would recognize my burner. Ever since
> > then, my cd-rom will only recognize data cds...not audio cds. When I
> > put the audio cd in and try to mount or open /mnt/cdrom, an error
> > message comes up saying "wrong media type". What can I do to fix the
> > situation? All my links to the device are correct, and the read-write
> > permissions on the device are correct.

> Try adding:

>     append = "hdc=ide-scsi"

> To your /etc/lilo.conf file

Yep...I just tried this command and everything works great. I didn't
add it to my /etc/lilo.conf file, I just typed it in on the command
line and hit enter. Thanks!!!
 
 
 

1. Help - CD-ROM won't play audio CDs.

Hello,

I am having trouble getting Audio CDs working on my machine (K6-2 500,
running Mandrake 7.0). I can use CD-ROMs without a problem, and I can
play mp3 files without any problem either (so, yes, the sound is
conencted up). When I insert an audio CD the machine cannot find any
tracks on the CD, and so therefore cannot play the CD.

Using Win98 I can play audio CDs without any problem, so it must be a
software problem, right?

Any help appreciated.

Cheers,
Anthony.

2. something that i don't understand

3. CD-ROM drive won't read Linux-Mandrake 6.0 cd

4. Great Help Page for Newbies and Power Users

5. Linux from Nascent CD-ROM won't mount my panasonic cd-rom drive

6. Middle mouse button

7. Help playing audio CD's on my CD-ROM drive

8. C run time libraries for Solaris 2.6

9. Audio CD's on a CD-ROM Drive

10. Won't read music CD, will read data cd?

11. Won't detect and mount CD-ROM (Yggdrasil, cd-dependent)

12. Can't install Yggdrasil summer 94 CD-ROM with SCSI-1 CD-ROM

13. 2.5 won't read ATAPI CD-ROM