Middle mouse button on "CompuKit" mouse

Middle mouse button on "CompuKit" mouse

Post by Troy D Hans » Mon, 20 Feb 1995 10:05:58



I have a CompuKit mouse.  The middle button doesn't work under XFree
3.1.1. (nor any previous XFree I've tried).  The mouse itself works when
I specify either "Microsoft" or "Mouseman" protocol, but not the middle
button.

I tried holding down the middle mouse button when I booted, but it didn't
seem to do any good.  I can't use the "Logitech" protocol.  The ClearDTR
and ClearRTS (or whatever it is) doesn't work with non-MouseSystems mice.

I'd appreciate any suggestions.

Troy Hanson

 
 
 

Middle mouse button on "CompuKit" mouse

Post by Ron Watki » Sun, 26 Feb 1995 12:46:12


Can someone point me to the information on dealing with disks which have more
than 1024 cylinders? I grabbed all the HOWTO's from sunsite and grepped for
1024, but didn't turn up anything helpfull. Where should I be looking?
--

------------------------------------------   /            /____/     /
"Who is General Failure -                   /            /          /
 and why is he reading my hard disk ?"     (____ unar & / lanetary (____ ab.

 
 
 

Middle mouse button on "CompuKit" mouse

Post by Panu J Matilain » Thu, 02 Mar 1995 19:30:15



: I have a CompuKit mouse.  The middle button doesn't work under XFree
: 3.1.1. (nor any previous XFree I've tried).  The mouse itself works when
: I specify either "Microsoft" or "Mouseman" protocol, but not the middle
: button.

: I tried holding down the middle mouse button when I booted, but it didn't
                           ^^^^^^
It's usually the left button that initiates the mouse to MouseSystems
protocol, but - while this may work fine in Dos, it causes a little
problems with X. You have to hold down the button every time you start X
and when you switch VCs and it's somewhat impractical.

I suggest you try opening your mouse, if you're lucky, there is a switch
or a jumper (mine hasn't :( ) to change the default mode to which the mouse will
initialize itself. Otherwise, I guess you'll have to do some soldering
to make it permanently 3-button mouse.

        Panu

: seem to do any good.  I can't use the "Logitech" protocol.  The ClearDTR
: and ClearRTS (or whatever it is) doesn't work with non-MouseSystems mice.

: I'd appreciate any suggestions.

: Troy Hanson

 
 
 

1. Mouse Systems 3-button "PS/2 Mouse" - Will it Work?

I just purchased a Mouse Systems 3-button PS/2 Mouse to replace a 2-button
mouse (the user couldn't stand using chorded middle).

Unfortunately, I can't get it to work with either gpm or Xree86.  The
mouse will move up and to the right, but simply jumps when you attempt to
move left or down.  I mostly tried /dev/mouse -> /dev/psaux, but the other
options (/dev/inportbm, etc. don't seem to work, either).

It's not a hardware problem, as the mouse works fine under Win95.  I'm
beginning to suspect and incompatibility with the linux PS/2 mouse driver.

Does anyone have any ideas/experience?

Also, I can't get test-mouse to work with ANY mouse I have, most of which
work fine with gpm and XFree86.  Anyone else?

2. Netscape Error

3. middle mouse button on three button mice

4. Linux NFS killed by MSQL Database Server!?!

5. CDE & MOUSE: *must* disable "pasting" via-mouse (GD MFing ShEing MOUSE!)

6. X11R6.3 and Solaris 2.4

7. Middle mouse button on Digital Research Tech's mouse

8. RE Using Function Keys

9. middle mouse button + Logitech pilot mouse

10. Middle mouse button acts wierd! Using Logitech mouse

11. GETSERVBYNAME()????????????????????"""""""""""""

12. need help with 3 button "dual protocol" mouse...

13. Imsi 3-button "Pet" Mouse