telnet problem on localhost

telnet problem on localhost

Post by Belanger Mart » Thu, 29 Dec 1994 11:51:27



I have a problem when using telnet

ex:
# telnet localhost
Trying 127.0.0.1...
telnet: Unable to connect to remote host: Connection refused

--
 Martin Belanger, coord. mtl pour APIIQ  

 Res : 514-278-9880   Fax : 514-278-4595  

 
 
 

1. Problem: cannot telnet to localhost

  Hello,

My problem is quite strange:
 If I telnet to my computer I get the following output:


    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.

 and stops here for about 60 seconds and them:

    Red Hat Linux release 3.0.3 (Picasso)
    Kernel 2.0.20 on a i586

    duarte.casa login:

 And if I try to telnet to duarte.casa:    


    Trying 192.168.2.102...
    Connected to duarte.casa.
    Escape character is '^]'.

    Red Hat Linux release 3.0.3 (Picasso)
    Kernel 2.0.20 on a i586
    Login timed out after 60 seconds
    Connection closed by foreign host.

  but all the other computers can connet here with telnet duarte.casa.

    my /etc/hosts:

127.0.0.1       localhost
192.168.2.102   duarte.casa
192.168.2.100   barrocas.casa        barrocas
192.168.2.101   nuno.casa            nuno                  

   my /etc/resolv.conf

nameserver 193.136.128.1
nameserver 192.190.174.1
nameserver 192.136.132.2
nameserver 192.190.174.91
search rnl.ist.ult.pt ist.utl.pt

    route outputs:

Destination     Gateway         Genmask         Flags MSS    Window Use Iface
localnet        *               255.255.255.0   U     1500   0        5 eth0
loopback        *               255.0.0.0       U     3584   0        8 lo
default         nuno.casa       *               UG    1500   0       28 eth0

  some other hints:

  rsh -l root duarte.casa /usr/X11R6/bin/rxvt -display localhost:0 &
  works perfectelly !!!

  I have a MUD running on port 2000 and
  telnet localhost (or duarte.casa) 2000 works perfectelly too.

   I don't know what's the problem !!!!

  Please help.

   Thanks in advance,

          Duarte Cordeiro

2. Should mount --bind not follow symlinks?

3. telnet Problem to localhost under SUSE 7.2

4. 7.1 to 7.2

5. sendmail problem (?) : telnet localhost 25 --> connection refused

6. Belkin 2-Port KVM Switch Kills Mouse in X

7. New Redhat installation - cannot telnet to localhost.

8. Combining 2-button trackball with 3-button mouse

9. telnet localhost --> Network is unreachable?

10. How can I telnet to localhost?

11. telnet localhost ???

12. Can't use telnet in FreeBSD (except to localhost).

13. no telnet connection to localhost