ftptool with term support - problems

ftptool with term support - problems

Post by Hans-Joachim Ko » Tue, 05 Jul 1994 18:01:49



I tried to use ftptool from Ftptool 4.6Beta 3 with term
support. The prelinked executable gives the errors message:

ftptool: can't load library '//usr/openwin/lib/libxv3.so.2'
        No such library.

Ok, I tried to build new from source. I applied the changes mentioned in
the ftptool.README to the Imakefile (only the references to the term
directory, I did not add "-lclient to the SUNOSLIBS macro", because I
could not find any such macro)

All compiles well under Linux, only the link fails:

gcc -ansi -DTERM -DTERM -L/usr/local/src/term117
-I/usr/local/src/term117 -o ftptool batch.o button_funcs.o change_dir.o
create_main.o create_other.o   dircache.o dirlist.o dofuncs.o dnd.o
event.o ftp.o host_list.o  lex.o main.o menu_funcs.o misc.o readdir.o
schedule.o tar_view.o        transfer.o view_file.o   -L/usr/openwin/lib
-lxview -lolgx -lXext -lX11   -lm -lfl
ftp.o: Undefined symbol _connect_server referenced from text segment
ftp.o: Undefined symbol _send_command referenced from text segment
ftp.o: Undefined symbol _send_command referenced from text segment
ftp.o: Undefined symbol _connect_server referenced from text segment
ftp.o: Undefined symbol _send_command referenced from text segment
ftp.o: Undefined symbol _send_command referenced from text segment
ftp.o: Undefined symbol _send_command referenced from text segment
make: *** [ftptool] Error 1

Does anyone have an idea about this? Any hint is welcome.
Thank you.
Hans.
--
Hans-Joachim Koch, Computer department of Lahmeyer International
Lyoner Strasse 22, D-60528 Frankfurt, Germany
Phone: +49 (69) 6677-642, Fax: +49 (69) 6677-571, Tx: 413478 li d

 
 
 

ftptool with term support - problems

Post by Tim Cut » Thu, 07 Jul 1994 01:37:01



>I tried to use ftptool from Ftptool 4.6Beta 3 with term
>support. The prelinked executable gives the errors message:
>ftptool: can't load library '//usr/openwin/lib/libxv3.so.2'
>        No such library.
>Ok, I tried to build new from source. I applied the changes mentioned in
>the ftptool.README to the Imakefile (only the references to the term
>directory, I did not add "-lclient to the SUNOSLIBS macro", because I
>could not find any such macro)
>All compiles well under Linux, only the link fails:

The term library used to be called client.a.  It is now called libtermnet.a,
so with your libtermnet somewhere visible to gcc, use -ltermnet.

Tim.

 
 
 

ftptool with term support - problems

Post by Tim Cut » Thu, 07 Jul 1994 17:29:10




>>I tried to use ftptool from Ftptool 4.6Beta 3 with term
>>support. The prelinked executable gives the errors message:
>>ftptool: can't load library '//usr/openwin/lib/libxv3.so.2'
>>        No such library.
>>Ok, I tried to build new from source. I applied the changes mentioned in
>>the ftptool.README to the Imakefile (only the references to the term
>>directory, I did not add "-lclient to the SUNOSLIBS macro", because I
>>could not find any such macro)
>>All compiles well under Linux, only the link fails:
>The term library used to be called client.a.  It is now called libtermnet.a,
>so with your libtermnet somewhere visible to gcc, use -ltermnet.

I tried compiling ftptool after making these suggestions.  It compiled
reasonably cleanly.  You then get the can't load library error again, so you
need to put the library in your LD_LIBRARY_PATH variable:

export LD_LIBRARY_PATH=/lib:/usr/openwin/lib

worked for me.

ftptool then seg faulted and wouldn't run though... :-(

Tim.

 
 
 

ftptool with term support - problems

Post by Hans-Joachim Ko » Fri, 08 Jul 1994 17:28:11


: gcc -ansi -DTERM -DTERM -L/usr/local/src/term117
: -I/usr/local/src/term117 -o ftptool batch.o button_funcs.o change_dir.o
: create_main.o create_other.o   dircache.o dirlist.o dofuncs.o dnd.o
: event.o ftp.o host_list.o  lex.o main.o menu_funcs.o misc.o readdir.o
: schedule.o tar_view.o        transfer.o view_file.o   -L/usr/openwin/lib
: -lxview -lolgx -lXext -lX11   -lm -lfl
: ftp.o: Undefined symbol _connect_server referenced from text segment
: ftp.o: Undefined symbol _send_command referenced from text segment
: ftp.o: Undefined symbol _send_command referenced from text segment
: ftp.o: Undefined symbol _connect_server referenced from text segment
: ftp.o: Undefined symbol _send_command referenced from text segment
: ftp.o: Undefined symbol _send_command referenced from text segment
: ftp.o: Undefined symbol _send_command referenced from text segment
: make: *** [ftptool] Error 1


I had to add   -L/full/path/to/term117 -ltermnet  to the above
gcc command. Thats all. It links well, runs well. Thanks, Bill.

Hans.

P.S. Someone send me a mail and asked for the source of ftptool.
My answer played ping-pong between misconfigured hosts, than came
back to me. The second try with the usual "postmaster" address
failed with unknown user... Sorry.
--
Hans-Joachim Koch, Computer department of Lahmeyer International
Lyoner Strasse 22, D-60528 Frankfurt, Germany
Phone: +49 (69) 6677-642, Fax: +49 (69) 6677-571, Tx: 413478 li d

 
 
 

ftptool with term support - problems

Post by bob hen » Sat, 09 Jul 1994 03:15:29




>>>I tried to use ftptool from Ftptool 4.6Beta 3 with term
>>>support. The prelinked executable gives the errors message:
>>>ftptool: can't load library '//usr/openwin/lib/libxv3.so.2'
>>>        No such library.
>>>Ok, I tried to build new from source. I applied the changes mentioned in
>>>the ftptool.README to the Imakefile (only the references to the term
>>>directory, I did not add "-lclient to the SUNOSLIBS macro", because I
>>>could not find any such macro)
>>>All compiles well under Linux, only the link fails:
>>The term library used to be called client.a.  It is now called
>>libtermnet.a,
>>so with your libtermnet somewhere visible to gcc, use -ltermnet.
>I tried compiling ftptool after making these suggestions.  It compiled
>reasonably cleanly.  You then get the can't load library error again, so you
>need to put the library in your LD_LIBRARY_PATH variable:

>export LD_LIBRARY_PATH=/lib:/usr/openwin/lib
>worked for me.

>ftptool then seg faulted and wouldn't run though... :-(

Ok.. I have basically the same problem here.. it compiled nice and clean,
but I get a segmentation fault on run.  I had no problems with
LD_LIBRARY_PATH, just made the changes to the original Makefile included
in the src to point to the proper term118 src:

CC=gcc -ansi -DTERM -I/usr/src/term118 -L/usr/src/term118

And swapped out -lclient for -ltermnet in :

LOCAL_LIBRARIES = -lxview -lolgx $(XLIB) $(LIBSUNOS5) -ltermnet

With only those changes, had no problems on compiling.  Anyone have any
idea why I am getting a segmentation fault?

++bob