Problem w/PAS16 and 1.1pl38+ (new sound driver)

Problem w/PAS16 and 1.1pl38+ (new sound driver)

Post by Thomas Pf » Wed, 10 Aug 1994 09:38:34



I just tried upgrading to a newer kernel.  I was previously using
V1.1pl18 which worked fine.  Now I've tried pl38, pl39 and pl41 and I
can't get my PAS16 to work with any of them.

My PAS16 which works fine with kernel pl18 just repeats the first buffer
that gets sent to it with the newer kernels.  I've tried various IRQ/DMA
combinations and t* back which options I select from the sound
driver to the bare minimum to get tracker to work.

Can anyone provide any hints on how I might get this thing working?

--
tom_p                           | I could get a new lease on life

compuserve: 73303,1136          | and last month in advance.

 
 
 

1. Can't compile new sound driver with 1.2.11 and PAS16 8^(

Ive tried to recompile a kernel (1.2.11) with the newest VoxWare driver (3.0)
and have had no success.  I get the following error message:

         In file included from sound_config.h:190,
                 from dev_table.c:31:
dev_table.h:357: `PAS_BASE' undeclared here (not in a function)
dev_table.h:357: initializer element for `snd_installed_cards.config.io_base'
is not constant
make[2]: *** [dev_table.o] Error 1
make[2]: Leaving directory `/usr/src/linux-1.2.11/drivers/sound'
make[1]: *** [driversubdirs] Error 127
make[1]: Leaving directory `/usr/src/linux-1.2.11/drivers'
make: *** [linuxsubdirs] Error 127

Anyone with an answer or patch, please post a followup message.

                        Thanks

--
           _/_/_/       Salt Lake Linux Users Group     _/_/_/
          _/_/*/_/_/|    _ http://www.sllug.org __     _/_/*/_/_/|
         _/_/_/_/_/|/   / __/ /  / /  / / / / ___/    _/_/_/_/_/|/
        _/_/_/_/_/|/   _\ \/ /__/ /__/ /_/ / (_ /    _/_/_/_/_/|/
       _/_/_/_/_/|/   /___/____/____/\____/\___/    _/_/_/_/_/|/

          Marc Christensen - Director of Public Relations

2. A few problems with pf firewall ruleset

3. New VoxWare Driver and PAS16

4. HELP: avanti installation failure

5. Sound problems (PAS16). Need help

6. AFPS 3.5.2n on OpenServer 5.0.4

7. PAS16 Sound Config Problem

8. pppd and user permissions

9. Sound problems (PAS16)

10. PAS16 sound card and SONY CDU-561 SCSI CD-ROM problems...

11. Soundblaster 16 PNP and Linux - problems with the new sound.o driver

12. Problem with pas16 scsi-driver and AppleCD 300 drive.

13. Matrox Mystique ands X.