SB16 Recording

SB16 Recording

Post by J.Haml » Sun, 26 Mar 1995 14:48:30



Hi, again

I just patched kernel 1.2.0 to 1.2.1 and some things have changed.

dd bs=8000 count=4 </dev/audio >sample.au
4+0 records in
4+0 records out

"sample.au" is now created:
-rw-r--r--   1 jhamlin  users       32000 Mar 24 21:08 sample.au
It contains:
ookkooooooookkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkk
kkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkk
kkkkkkkkkkkkkkkkkkkkk......  filled with 32000-x k's
kkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkk

So something changed between 1.2.0 and 1.2.1 but ' cat sample.au >/dev/audio"
does not produce any sound. I have tried both the "SpeakerOut" and "LineOut"
and "Mic" and "LineIn" jacks without success.
---------------------------------------------------------------

cat /dev/sndstat


Config options: 35c02

Installed drivers:
Type 1: OPL-2/OPL-3 FM
Type 2: SoundBlaster
Type 6: SoundBlaster16
Type 7: SB16 MIDI

Card config:
SoundBlaster at 0x220 irq 5 drq 1
SoundBlaster16 at 0x220 irq 5 drq 5
(SB16 MIDI at 0x330 irq 5 drq 0)
OPL-2/OPL-3 FM at 0x388 irq 0 drq 0

PCM devices:
0: SoundBlaster 16 4.11

Synth devices:
0: Yamaha OPL-3

Midi devices:

MIDI Timers:
0: System Timer

1 mixer(s) installed
---------------------------------------------------------------


Thanks in advance.

Jim

 
 
 

1. SB16 record on Linux box.

Hello,

        I'm running linux 1.1.51 with v3.0 of the sound drivers.  I have
a soundblaster 16 that will play files just fine, but when I try to
input files from the microphone ("cat /dev/dsp > sample" or "cat < /dev/audio
that are not size 0 but it reports that there are no records going in.
        All of this works fine from DOS (heaven forbid) (input and output).
        Configuration:
                I/O address:  220
                IRQ:            5
                Low DMA:        1
                High DMA:       5
                MIDI address: 330
        When I configured the sound driver I included support only for the
SB with digitized voice, SB 16, MIDI interface and FM synthesizer.
        Like I said, output works just fine but I can't get input to work
at all.  This is for a presentation at a conference next week so I'm
desperate for help.  Any would be appreciated.


2. Writing client for LDAP server on internet

3. SB16 Recording Problem

4. Playing midi files

5. Can't record with SB16 PCI

6. Mouse Systems Corp Hand Scanner

7. Recording from SB16 under Linux?

8. pppd problems on 1.3.3/sparc

9. Recording with SB16

10. Can't Record with SB16

11. real-time recording & playback on SB16?

12. I can't record by SB16 through /dev/audio

13. SB16 not recording under Linux ?