Can't get Term to run on Decstation 5000 w/ AFS, Ultrix 4.2A

Can't get Term to run on Decstation 5000 w/ AFS, Ultrix 4.2A

Post by R L HUFFM » Sat, 21 Aug 1993 10:09:13



I am trying to get Term to work between a Decstation 5000/25 (Ultrix 4.2A)
and my linux box at home (APR 486DX/33).  The linux end checks out fine
with 'test' and 'linecheck'.   'linecheck' seemed to work okay from the 5000,
using kermit for communications.

I am compiling with gcc 2.2.2 on the 5000.  When I start 'test' on the
5000, the following pops up on the console:

        afs_makenode: not supporting mode=49152 in AFS
        afs_makenode: not supporting mode=49152 in AFS

Then if I try to run any of the other programs, they don't seem to have
anything to connect to.  For example,

(after starting 'test' from another xterm...)
% trsh
Connect: No such file or directory
% txconn
Xconn bound to screen 9
:9
Connect: No such file or directory

Is there any hope for term 1.07 with Ultrix/AFS, or should I try barking
up another tree?

Thanks for any help you can give.

The top of the Makefile I am using is:
#
# Term program makefile.
# valids targets are:
#       all term linecheck test tags clean install realclean ${PROGS}
PROG=term
SHELL=/bin/sh
CC=gcc
# AIX: replace CC with this line...
# CC=xlc -D_ALL_SOURCE
# if use a NeXT machine, then replace CC with this line...
# CC=cc -DNeXT
CPP=$(CC) -E
# if useing a NeXT then use..
# CPP=cc -E -DNeXT
DEBUGFLAGS= $(DEBUG) -O
CFLAGS= $(DEBUGFLAGS) -Wall -funsigned-char
#CFLAGS= $(DEBUGFLAGS)
LINKFLAGS=-O
# Hpux. -Aa for lib.c

RM=/bin/rm -f
LN=ln
# If the following fails to work, the change it to be
# ar rc
# and uncomment the ranlib below.
# on a sun you can use /usr/5bin/ar.
AR=ar rcs
RANLIB= ranlib
INSTALL= install
INSTPGMFLAGS = -s
MKDIR= mkdir
BINDIR=/local/bin
MANDIR=/local/man/man1
#
# Change this if yours is different.
#
CURSES= -ltermcap


Bio & Agr Eng Dept, NC State Univ, Raleigh NC
Mail:   PO Box 7625, Raleigh NC 27695-7625
Phone:  919-515-6740    Fax:    919-515-7760

 
 
 

Can't get Term to run on Decstation 5000 w/ AFS, Ultrix 4.2A

Post by Alan Ve-Ming L » Sat, 21 Aug 1993 12:12:37



Quote:>I am trying to get Term to work between a Decstation 5000/25 (Ultrix 4.2A)

>I am compiling with gcc 2.2.2 on the 5000.  When I start 'test' on the
>5000, the following pops up on the console:

>    afs_makenode: not supporting mode=49152 in AFS
>    afs_makenode: not supporting mode=49152 in AFS

>Then if I try to run any of the other programs, they don't seem to have
>anything to connect to.  For example,

Hi, we're running AFS here too and I had a similar problem.  One
possible reason could be that AFS partitions have problems creating a
socket.  The default location for term's socket is ~/.term.  Try
changing the directory where the socket is created.  To do this, type

        setenv TERMDIR <non-afs directory>

/tmp is a good bet and has worked for me.  I'm writing this from
home using term and trsh.

Finally, you might want to change the permissions on the socket file
from 777 to 770 (not sure if this will do anything, but just in
case....)

Good luck,
Al

 
 
 

Can't get Term to run on Decstation 5000 w/ AFS, Ultrix 4.2A

Post by Steve Sheld » Sat, 21 Aug 1993 12:49:59



Quote:>I am trying to get Term to work between a Decstation 5000/25 (Ultrix 4.2A)
>and my linux box at home (APR 486DX/33).  The linux end checks out fine
>with 'test' and 'linecheck'.   'linecheck' seemed to work okay from the 5000,
>using kermit for communications.
>I am compiling with gcc 2.2.2 on the 5000.  When I start 'test' on the
>5000, the following pops up on the console:
>    afs_makenode: not supporting mode=49152 in AFS
>    afs_makenode: not supporting mode=49152 in AFS
>Then if I try to run any of the other programs, they don't seem to have
>anything to connect to.  For example,

.....

Quote:>Is there any hope for term 1.07 with Ultrix/AFS, or should I try barking
>up another tree?

 No there is no hope.  AFS does not allow you to do what you want to do.
AFS has all kinds of little security features.

 You'll need to run this off an NFS mounted disk, or local drive of some
sort.  You might try using /tmp to make it work.
--

#insert "standard disclaimer"                      Iowa State University

 
 
 

Can't get Term to run on Decstation 5000 w/ AFS, Ultrix 4.2A

Post by JASON POWELL RHO » Sat, 21 Aug 1993 22:05:10


Quote:> >I am trying to get Term to work between a Decstation 5000/25 (Ultrix 4.2A)
> >and my linux box at home (APR 486DX/33).  The linux end checks out fine
> >with 'test' and 'linecheck'.   'linecheck' seemed to work okay from the 5000,
> >using kermit for communications.

> >I am compiling with gcc 2.2.2 on the 5000.  When I start 'test' on the
> >5000, the following pops up on the console:

> >       afs_makenode: not supporting mode=49152 in AFS
> >       afs_makenode: not supporting mode=49152 in AFS
[snip]
> >Is there any hope for term 1.07 with Ultrix/AFS, or should I try barking
> >up another tree?

>  No there is no hope.  AFS does not allow you to do what you want to do.
> AFS has all kinds of little security features.

[snip]

I have run TERM from a DECstation with AFS (I am in fact at the same university
as the original poster).  Initially I had problems with sockets in the AFS file
system, however, I found that if you set the env. variable TERMDIR to
/tmp, then everything works fine.

 
 
 

1. Decstation 5000/125 running ultrix4.2a - need help

Hello All !
I'd like to know if there us y2k problem with my machine (i guess there is
problem)..
and how can i solve it.
if i'll change the date to 1970, will it solve my problem (i dont care if
the year in my
machine will be 1970 ...)
someone told me that there is another hidden clock in my machine that cannot
be changed, is he right?
what will happen if the date comes to 31/12/99 ...? will it continue to work
after that day?
I also have another problem , and i'd like to know if antone can help me :
my original cdrom (RRD42) has gone - (the time is doing his job, i guess..),
and i wanna
change it . i have another scsi cdrom of Toshiba 5301 or something like
that.
how can i config it to the scsi, i tried to config it to scsi-id 4 and the
machine identified it to RD4 ( i checked it by using the command >>CNFG 3 ),
but i tried to boot from a disk. i saw the light on the cdrom turning on but
after 30 sec the light has turned off and nothing happened.(th cd was a
Supp/UnSupp Ultrix4.2a boot and install disk).
How can i config it on my xwindows of ultrix4.2a ?
what commands should i use. i have all the original literature of Digital
but i couldnt understand how to do it..
can i config it to another scsi-id? like 6?
i wanna be sure that in case of a crash i'll be able to restore all my H.D
(contains 3 partitions - on 2 HardDisks- all=800MB). - i have also another
scsi H.D - 1.2GB - how can i make exact copy of my H.Ds? is there any
software that can duplicate a H.D?
or maybe i can just copy the files and it'll work?? (is it like windows that
a copy command won't be good enough to make an exact copy of th H.D?)

T H A N K S !!!
Hope u'll help me !!
Uzi

2. Is there a locale problem with CDE and Solaris 2.6?

3. DECStation 5000/25 as X terminal, openBSD or Ultrix?

4. how to tell when children processes die

5. Problems with su/csh on Ultrix 4.0/DECstation 5000

6. help: NCSA httpd + htpasswd + user change password ...

7. IBM L-12 disk with DECstation 5000/Ultrix?

8. Swap on?

9. Networking DECStation 5000/20 running OpenBSD 2.4 and i586 running Redhat Linux 5.2 & Win95

10. DecStation 5000/125 Netbooting getting "a.out" error

11. simpleroot22.fs on a DECstation 5000/25 doesn't boot

12. 4 mm boot tape for DECstation (Ultrix 4.2a)

13. WANTED: a.out.h header for DEC 5000/240 running Ultrix and/or Mach