Logitec Lost my Logitec Busmouse with PL12

Logitec Lost my Logitec Busmouse with PL12

Post by Clayton Haapa » Sat, 14 Aug 1993 13:00:03



My logitec busmouse has stopped working upon installation of Alpha-PL12 of
7 Aug.  Major 10, minor 0, /dev/mouse is linked to /dev/bmouselogitec.

I can still boot PL11 and it works fine with my X server, but with PL12, it
gets sucked down to the lower right-hand corner of the screen and stays there.
At least some Button presses still work -- just motion is hosed.

I believe this was just answered recently, but the news has expired from
my machine.

The mouse is a Logitech MouseMan Bus M/N: M-PD13-9MD.

Email welcome.
--
Clay Haapala                    "Well, there was the process of sitting around

                                        -- Dilbert

 
 
 

Logitec Lost my Logitec Busmouse with PL12

Post by Ed H. C » Wed, 18 Aug 1993 04:24:30



>My logitec busmouse has stopped working upon installation of Alpha-PL12 of
>7 Aug.  Major 10, minor 0, /dev/mouse is linked to /dev/bmouselogitec.

>I can still boot PL11 and it works fine with my X server, but with PL12, it
>gets sucked down to the lower right-hand corner of the screen and stays there.
>At least some Button presses still work -- just motion is hosed.

>I believe this was just answered recently, but the news has expired from
>my machine.

>The mouse is a Logitech MouseMan Bus M/N: M-PD13-9MD.

I believe a lot of people are having this problem with the aug 7 kernel
0.99.12.

Just use the 0.99.11's busmouse.h and busmouse.c, and recompile the kernel
to fix the problem.

Basically, some of the signed char's got changed to unsigned char's in the
new pl12 kernel.  Some of the offending lines are declarations of "dx",
and "dy" variables to unsigned char's, which prevented negative direction
motions.  (Specifically, up and left are disabled, because those are the
negative direction.)

Read my post in comp.os.linux.development about it. [about 4 to 5 days old
article.]

>Email welcome.
>--
>Clay Haapala                        "Well, there was the process of sitting around

>                                    -- Dilbert

--

 /#      ##o     #     o##      #\
 / \    /  \    /o\    / |\    / \

 
 
 

1. Logitec Busmouse X11 woes

        I'm trying to get a Logitec MouseMan Bus mouse to work with
xfree86.  X goes through the startup procedures and then dies with the
complaint that it can't find the mouse.  Everything is configured for X
properly except for the mouse as evidenced by my being able to sucessfully
run XF86Setup. I have been able to get it to work by borrowing a friend's
PS/2 mouse (Compaq).
                                                                   Later,
                                                         Paul D. Carlucci
                                        http://www.csee.usf.edu/~carlucci

"This calls for a very special blend of psychology and extreme violence."
                                                                  -Vyvian
And if I'm not telling the truth, may lightning from the heavens above

NO CARRIER

2. Avance Logic Linux Sound Drivers

3. HELP: Logitec Busmouse problem

4. Redhat debuggin problem with gdb

5. Help with Logitec busmouse

6. Is there a 'make' utility on VMS?

7. Logitec Busmouse w/ Xfree

8. Need .logout replacement for CDE environment

9. Logitec Busmouse problems

10. Logitec busmouse problems

11. Logitec Busmouse

12. logitec busmouse help..

13. Logitec Busmice and X