Failed to connect to term socket '/home/sjw/.term/socket

Failed to connect to term socket '/home/sjw/.term/socket

Post by Steve Whi » Wed, 08 Feb 1995 06:33:20



Term problem: The subject says it... when I run

tupload /usr/bin/term /usr/temp

As the HOWTO suggests on both my single user Linux system as well as
the network Suns over the phone line at my internet site I get (again)

Term: Failed to connect to term socket '/home/sjw/.term/socket'

I used the standard install from AP sets for my linus system and
the term-2.2.4 package install (./configure --user; make install)
on the Sun end.

both ends have .term directories with

darkstar:~> ls -l .term
total 3
srwxr-xr-x   1 sjw      users           0 Jan 28 20:08 socket=
-rwxr-xr-x   1 sjw      users        2730 May 29  1993 termrc*

So I'd guess there's a socket there. What obviousness am I missing?

Thanks for any help
Steve

(P.S. Based on the new HOWTO, I also installed the /usr/src/term-2.2.4
as shared under root - trying to do the 'chgrp term <term_client>;
chmod g+s <term_client>' stuff guessing what <term-client> files were
intended - and run termtest. All I got was

bash# termtest &
[1] 898
bash# tupload .xinitrc /tmp
Term: Failed to connect to term socket '/usr/local/lib/term/tmp/private/socket'
bash#
)

 
 
 

Failed to connect to term socket '/home/sjw/.term/socket

Post by Socrates Guerre » Fri, 10 Feb 1995 17:14:00


: Term problem: The subject says it... when I run
: tupload /usr/bin/term /usr/temp
: Term: Failed to connect to term socket '/home/sjw/.term/socket'

        I'm getting the same error! Does anyone have a (how 'bout "a few")
        suggestion(s)?

        Thanks in advance.

--
*** Socrates Guerrero      



 
 
 

Failed to connect to term socket '/home/sjw/.term/socket

Post by Victor the Clean » Sat, 11 Feb 1995 04:30:43



Article: 74475 of comp.os.linux.help

Newsgroups: comp.os.linux.help
Subject: Re: Failed to connect to term socket '/home/sjw/.term/socket
Date: 9 Feb 1995 08:14:00 GMT
Organization: San Diego State University, College of Sciences
Lines: 15


NNTP-Posting-Host: rohan.sdsu.edu
X-Newsreader: TIN [version 1.2 PL0]

: Term problem: The subject says it... when I run
: tupload /usr/bin/term /usr/temp
: Term: Failed to connect to term socket '/home/sjw/.term/socket'

        I'm getting the same error! Does anyone have a (how 'bout "a few")
        suggestion(s)?

> I am also getting this same type of error.  If there are any Term experts
> out there I would sincerely appreciate any assistance anyone could offer.


 
 
 

Failed to connect to term socket '/home/sjw/.term/socket

Post by Ian H. Worthingt » Sat, 11 Feb 1995 06:57:40




: Article: 74475 of comp.os.linux.help


: : Term problem: The subject says it... when I run
: : tupload /usr/bin/term /usr/temp
: : Term: Failed to connect to term socket '/home/sjw/.term/socket'

:       I'm getting the same error! Does anyone have a (how 'bout "a few")
:       suggestion(s)?

: > I am also getting this same type of error.  If there are any Term experts
: > out there I would sincerely appreciate any assistance anyone could offer.

I get the same problems. I believe it has to do with the connection
from the dial-up system to the host you are connecting to. I have
never been able to connect my Linux box at home to my Linux box at
school due to the use of 8-bit connections, term seems to fall short
here.

As an alternative, try running 'tia'. It is a SLIP emulator
which has proven successful when term has not.

Andrew Cowan
--
_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
_/_/_/_/_/_/_/    The Radiation Zone    _/_/_/_/_/_/_/_/
_/_/_/_/_/ Where the fish glow in the dark! _/_/_/_/_/_/
_/_/_/ http://www.magicnet.net/rz/rad_home.html  /_/_/_/
_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

 
 
 

Failed to connect to term socket '/home/sjw/.term/socket

Post by Axel Bol » Sat, 11 Feb 1995 12:18:13




Steve> Term problem: The subject says it... when I run
Steve> tupload /usr/bin/term /usr/temp
Steve> Term: Failed to connect to term socket '/home/sjw/.term/socket'

Ian> I get the same problems. I believe it has to do with the connection
Ian> from the dial-up system to the host you are connecting to. I have
Ian> never been able to connect my Linux box at home to my Linux box at
Ian> school due to the use of 8-bit connections, term seems to fall short
Ian> here.

Are you guys really running term on both ends of the connection and
have you tested it locally with the test program that comes with the
term package? It's all described in the Term-HOWTO in
sunsite.unc.edu:/pub/Linux/docs/HOWTO.

Ian> As an alternative, try running 'tia'. It is a SLIP emulator
Ian> which has proven successful when term has not.

Heresy! As far as I know, tia connot even handle connections that are not
8-bit clean.
--

 
 
 

Failed to connect to term socket '/home/sjw/.term/socket

Post by chou chen-y » Sat, 11 Feb 1995 13:47:39





: : Article: 74475 of comp.os.linux.help


: : : Term problem: The subject says it... when I run
: : : tupload /usr/bin/term /usr/temp
: : : Term: Failed to connect to term socket '/home/sjw/.term/socket'

: :     I'm getting the same error! Does anyone have a (how 'bout "a few")
: :     suggestion(s)?

: : > I am also getting this same type of error.  If there are any Term experts
: : > out there I would sincerely appreciate any assistance anyone could offer.

: I get the same problems. I believe it has to do with the connection
: from the dial-up system to the host you are connecting to. I have
: never been able to connect my Linux box at home to my Linux box at
: school due to the use of 8-bit connections, term seems to fall short
: here.

: As an alternative, try running 'tia'. It is a SLIP emulator
: which has proven successful when term has not.

        Please refer to trouble-shooting section in Term_HOWTO, I believe
it has the details to solve your problem (it solved mine). BTW, term does
support 7-bit line, you can specify it in your termrc file.

                                        Chou,

 
 
 

Failed to connect to term socket '/home/sjw/.term/socket

Post by Steve Whi » Sat, 11 Feb 1995 23:36:30




|>

|>Steve> Term problem: The subject says it... when I run
|>Steve> tupload /usr/bin/term /usr/temp
|>Steve> Term: Failed to connect to term socket '/home/sjw/.term/socket'
|>
|>Ian> I get the same problems. I believe it has to do with the connection
|>Ian> from the dial-up system to the host you are connecting to. I have
|>Ian> never been able to connect my Linux box at home to my Linux box at
|>Ian> school due to the use of 8-bit connections, term seems to fall short
|>Ian> here.
|>
|>Are you guys really running term on both ends of the connection and
|>have you tested it locally with the test program that comes with the
|>term package? It's all described in the Term-HOWTO in
|>sunsite.unc.edu:/pub/Linux/docs/HOWTO.
|>

I was tunning the term test as recommended in the term-HOWTO (i.e. two
terms setup by the test program on the same machine and they try to
transfer some data - in this case putting /usr/bin/term to /usr/tmp).
I don't think 8-bit dial-up connections are the problem here.

Personally, I've moved on to ppp (and I have another outstanding question
that almost certainly *is* modem related out on the net for anyone interested)
but from the public and private traffic I've seen on this term socket
problem, it would be appreciated by a lot of folks if some term-wizzard
could RTFM to us out loud.

Thanks!

Steve

 
 
 

1. Failed to connect to term socket '/home2/irvine/.term/socket'

The remote host that I log into isn't the one I want to run
on. Therefore, the first thing I do is rlogin to another
host. However, if I attempt to run txconn on this machine, it fails
with the error message "Failed to connect to term socket
'/home2/irvine/.term/socket'". However, I have no problem as long as I
run txconn on the host the I originally log onto. I can't find a
solution reading through the various docs, so I if someone could shed a
little light on my problem, it would centainly be appreciated. Thanks.

--
Chuck Irvine
--------------------------------------------------------------------------
Cadence Design Systems, Inc./Alta Group                 FAX (913) 841-1345

1310 Wakarusa Dr.                                       (913) 841-1283
Lawrence, KS 66049
--------------------------------------------------------------------------

--
Chuck Irvine
--------------------------------------------------------------------------
Cadence Design Systems, Inc./Alta Group                 FAX (913) 841-1345

1310 Wakarusa Dr.                                       (913) 841-1283
Lawrence, KS 66049
--------------------------------------------------------------------------

2. Someone got sendfax to work on a Winbook?

3. Term: Failed to connect to term socket... HELP!

4. TUTORING AND COURSE NOTES

5. Fail to connect to term socket

6. ACCOUNTS/DEFAULTS/LOGINS

7. TERM 2.0.4 can't connect to socket?

8. Virtual domains in Qmail

9. Can't connect to ftp URLs using Mosaic+term with SOCKSified term

10. Term problem: cannot connect to socket!

11. term: cannot connect to socket

12. term 1.17: cannot connect to socket..

13. Term problems : 'gethostbyname' and no socket