Help: having problem compile kernel v1.1.18

Help: having problem compile kernel v1.1.18

Post by Thomas Tr » Mon, 10 Oct 1994 21:34:48



Hi netters,

        I have been using Slackware 1.0 for awhile now and finally have the
change to update it to version 2.01.  I am very impress with the IMPROVEMENT
of version 2.01.  However, I am having a bit of problem compiling the kernel.
When I try to recompile the kernel, it gave me this error message:

...
sync
make[1]: Leaving directory `/usr/src/linux-1.1.18/lib'
ld  -Ttext 100000 boot/head.o init/main.o tools/version.o \
        kernel/kernel.o mm/mm.o fs/fs.o net/net.o ipc/ipc.o \
        fs/filesystems.a \
        drivers/block/block.a drivers/char/char.a drivers/net/net.a ibcs/ibcs.o
drivers/sound/sound.a drivers/FPU-emu/math.a \
        lib/lib.a \
        -o tools/zSystem
net/net.o: Undefined symbol _dev_init referenced from text segment
net/net.o: Undefined symbol _net_bh referenced from text segment
make: *** [tools/zSystem] Error 1                                          

        The kernel is the one that come with slackware 2.01 and patched with
quota 1.33.  I'll be really appreciated for any help on this.  Many thanks
in advance.

Tomas

 
 
 

1. >1024 cyl, v1.1.18, boot problems

        Okay, The install went okay, now to the fun part:

        Using the boot disk that it made AFTER the install, it does'nt recognize the drive, I have a 1Gig (2099cyl,16hd,63sec)
and the error that comes up,

        [st506] unable to access drive /dev/hda
                (506 cyl, 64 hd, 16 sec]

        and some other errors that lead to the big extended registers display and halting.

        If I use the sbpcd boot disk, and enter

        boot: mount root=/dev/hda2 hd=2099,16,63

        It does go in, but gives me errors referencing that "hda2" is an unknown parameter. No big deal, I get in, but it tells me
the version of UMSDOS is v0.2, and the FTAPE is for UMSDOS v0.3.  Soooo, I recompile the whole kernel, and make a boot disk
according to the howto's and faqs, it gets to the point where I get the drive geometry errors.

        I've been told to add      append="hd=2099,16,63"   to the lilo stanza somewhere, but when I try to use the liloconfig
utility, it gives me an error when it tries to write to the floppy.

        Where exactly on the boot floppy can I tell it that the drive is   hd=2099,16,63   and have lilo work properly???

        Everything else works fine once I get in, this is the only problem I'm having now.  The docs, faqs, howto's have been
great, but I've yet to get this boot thing taken care of.

        Thanks

2. Can IRQ's be multiplexed?

3. Apache 1.3.4 + mod_perl 1.18 + redhat 5.2 (kernel 2.2.2) problems

4. Multithreaded logging algorithm

5. Compiling tin 1.18 on SLS 1.01

6. add a second modem

7. Newbie: Netfilter-0.1.18 won't compile on 2.3.46

8. rivafb

9. Compiling cups-1.1.18 "cannot exec 'cc1plus': No such file or directory

10. 2.2.5-15 kernel and isapnp 1.18-2

11. Help: K1.1.18 Need documentation mmap(2) implementation

12. Problem autoprobing NE2000 w/Linux 1.18 & greater?

13. Help:Having trouble compiling Kernel with redhat 4.1