Getty & serial.c problem

Getty & serial.c problem

Post by Laurent C » Sat, 02 Oct 1993 19:12:38



Hi,

I am running Linux SLS v1.02 with kernel 0.99 pl9 on a 486 DX 50 Mhz
with 16 Mo RAM and getty from poeigl (the last in date).

I am having troubles with getty answer. Every user have to call twice
my system to get an answer as the first time, the modem answer but
we get a black screen and nothing happens ; 5 seconds later the linux
hangup. The user call again and this time all works fine. And every
time linux plays the same game. We have to call twice. Somebody told
me that the problem didn't came from getty, but came from serial.c
and that there were a patch to apply and to recompile kernel. I would
like to do some but i don't know what i serial.c to correct.

Could somebody explain me what to do to correct problem, or send me
via Email a patch, or whatever solution you have, but please answer.

Please, reply by Email as i have very big problems. I will summerize
and post here solutions. Thanks in advance.

                Cheers, Laurent.

 
 
 

1. help with getty, respawn & serial stuff

Hi,

I have two problems that need help

1)

getty is respawning too fast for my VC's, here is the error messages
created in /usr/adm/messages

Feb  3 09:20:10 pc-ieee1 init[1]: Id "c5" respawning too fast: disabled for 5 minutes
Feb  3 09:20:11 pc-ieee1 init[1]: Id "c6" respawning too fast: disabled for 5 minutes
Feb  3 09:20:12 pc-ieee1 init[1]: Id "S1" respawning too fast: disabled for 5 minutes

my inittab looks like this...

c1:12345:respawn:/sbin/agetty 38400 tty1
c2:12345:respawn:/sbin/agetty 38400 tty2
c3:45:respawn:/sbin/agetty 38400 tty3
c4:45:respawn:/sbin/agetty 38400 tty4
c5:45:respawn:/sbin/agetty 38400 tty5
c6:456:respawn:/sbin/agetty 38400 tty6

2)
I have hooked up an older, but working terminal on one of the serial
ports, when I boot up for the first time the terminal has a login prompt
and works fine, until the individual logs out. Then the terminal does not
do anything, just hangs, no login prompt. The only way I could fix it was
to reboot. Also just leaving someone logged in for a long time causes an
auto logout.

here is my inittab lines for the serial terminal

# Serial lines
S0:45:respawn:/sbin/agetty 19200 ttyS0

the terminal is on com1

I sure could use your expertise!!!

Thanks bruce,


2. Please help on permision problem (hard)

3. Getty problems/Serial problem

4. unresolved symbol error - updating module dependencies

5. Dial-in linux server- PPP & serial getty?

6. keyboard: unknown e1 escape sequence

7. Newbie and problems with getty and serial ports

8. PPP version 2.2.0d uploaded to sunsite.unc.edu

9. Serial Problems with getty, setserial, etc... (please help)

10. Serial GETTY problem

11. Getty/Serial problems

12. Getty serial port terminal problem

13. Getty Problem!.. Corrupt Getty File