Pls Help Newbie - PHP4/glibc2.2 rpm install woes

Pls Help Newbie - PHP4/glibc2.2 rpm install woes

Post by matt » Tue, 23 Apr 2002 11:57:52



Hi,

I am trying to install an rpm of PHP4 but running into dependencies
issues. Most of these seem to stem from a requirement for GLIBC_2.2 lib
files etc (specifically libc.so.6(GLIBC_2.2)).

I have downloaded and queried the various packages required by the PHP
rpm (and in turn the packages they require) but end up in an infinite
loop of requirements (i.e one install requires another and vice versa).
I managed to trash my system by switching off dependencies and
overwriting important files last time round so I'm loathe to start
mucking around with rpm's dependency checking again.

I'm running YellowDog Linux Champion Server 1.2 (Built on Redhat 6.x?)
using a 2.2.17 kernel.

On my past install I did have an earlier version of PHP running which I
built from source but I'd really like to get over this glib2.2 issue as
there's other software (e.g mol-0.9.62 mac-on-linux) I'd like to run
which requires it.

I've scanned the web and can't find any specific info mentioning
glibc2.2 as incompatible with my configuration.

Below is the collected output from rpm, listing the various
dependencies. Many thanks,

Matt

Package dependencies for php install

Quote:>>php-4.0.4pl1-4

error: failed dependencies:
   libdb-3.1.so   is needed by php-4.0.4pl1-4
   libgd.so.1.8   is needed by php-4.0.4pl1-4
   libc.so.6(GLIBC_2.2)   is needed by php-4.0.4pl1-4
   libresolv.so.2(GLIBC_2.2)   is needed by php-4.0.4pl1-4

Quote:>>cpp-2.95.4-4j

error: failed dependencies:
   libc.so.6(GLIBC_2.2)   is needed by cpp-2.95.4-4j

Quote:>>gcc-2.95.4-4j

error: failed dependencies:
   cpp = 2.95.4-4j is needed by gcc-2.95.4-4j
   binutils >= 2.11.92.0.12 is needed by gcc-2.95.4-4j
   libc.so.6(GLIBC_2.2)   is needed by gcc-2.95.4-4j

Quote:>>rpm-4.0.2-1c

error: failed dependencies:
   glibc >= 2.1.92 is needed by rpm-4.0.2-1c
   db1 = 1.85 is needed by rpm-4.0.2-1c
   libbz2.so.1   is needed by rpm-4.0.2-1c
   libdb-3.1.so   is needed by rpm-4.0.2-1c
   libc.so.6(GLIBC_2.2)   is needed by rpm-4.0.2-1c

Quote:>>glibc-2.2.5-0.19a    (Note: Provides libc.so.6(GLIBC_2.2))

error: failed dependencies:
   glibc-common = 2.2.5-0.19a is needed by glibc-2.2.5-0.19a
   rpm <= 4.0-0.65 conflicts with glibc-2.2.5-0.19a
   glibc-devel < 2.2.3 conflicts with glibc-2.2.5-0.19a
   binutils < 2.11.92.0.12 conflicts with glibc-2.2.5-0.19a
   gcc < 2.95.4-4a conflicts with glibc-2.2.5-0.19a

Quote:>>glibc-common-2.2.5-0.19a

error: failed dependencies:
   glibc < 2.2.5 conflicts with glibc-common-2.2.5-0.19a

Quote:>>glibc-devel-2.2.5-0.19a

error: failed dependencies:
   glibc = 2.2.5 is needed by glibc-devel-2.2.5-0.19a

--
Indignant man:  "Do you know who I am?!"
Peter Cook:        "Excuse me ladies and gentlemen, there's a man here
                               who doesn't know who he is..."

Post all replies to the group please :)

 
 
 

1. newbie: partition woes. pls help

hullo,

here's the problem:
i've successfully installed solaris 7 (x86) on one partition of my hard
disk. i need more disk space, so on the same disk, i've created another
solaris partition. however, i cant seem to create a filesystem on this
new partition. I get the error: "incorrect field in VTOC"  when i
execute the command "newfs /dev/rdsk/c0d0p4". (c0d1p4 was the partition
i created with fdisk).

I'm not sure if i need to run the "format" tool as well to divide the
partition up into 10 slices. i've tried doing that, but "format" only
recognizes the partition with the solaris OS on it. it does not
recognize the newly created solaris partition and i dont know how to
make it recognize the new partition.

the documentation only deals with one solaris partition per disk. i've
read the system administrators guide, but it hasn't helped.

here's some other information that may be of help:

1.)     the disk is an ide 8GB. it's the slave disk on channel 0.
2.)  the 3rd partition on the disk has solaris on it. The first
partition is a linux partition. the second is for windows95.
3.)     i had some free disk space between my windows partition and the
solaris partition, so the new partition (partition 4) is actually
created between the partition 2 and partition 3.

could sumone pls help....i really need the extra space urgently

thanks
ali

2. Can't get SSI running on FreeBSD

3. PHP4 on Debian woody (won't run) (newbie)

4. good SCSI card for Linux?

5. Pls help : Installing a new SCSI Adapter, Unix newbie

6. SLIP howto?

7. Pls help newbie to install printer

8. Capturing Keystrokes

9. Newbie in installing FreeBsd in an AMD comp. Pls help.

10. PHP4 not working on new RedHat 7.2 install

11. Installed PHP3 and PHP4, but can't restart httpd

12. easy to install PHP4 & Ghostscript binaries for OSR5.0.x ??

13. Install of PHP4