probs w/ libc-4.4.1

probs w/ libc-4.4.1

Post by M.BE.. » Sat, 04 Sep 1993 01:59:00



Hi!

I'm trying to compile the libraries v4.4.1 I got from

When I invoke "make dep", make somewhere (when making misc, I think) includes
<if.h> (=/usr/include/net/if.h) and then searches for <linux/if.h>, which is
needed by <if.h>.
This makes "make dep" fail, since there is no such file on my system (I think
the file should be in /usr/src/linux/include/linux, it's not there...)

Where can I get <linux/if.h> (preferably without too much other stuff) ?

How should I go on after doing "make dep"?
Is it sufficient to type "make SHARED=true"?

Are there patches for upgrading to 4.4.2, and should I use them right now?

By now, I've got a pl9 kernel, the 4.3.3 libs and gcc 2.3.3.

Thanks,
  Michael

 - Be a loyal plastic robot for a world that doesn't care - (Frank Zappa)

Michael
-------------------------------------------------------------------------------
       Below

## CrossPoint v2.1 ##

 
 
 

probs w/ libc-4.4.1

Post by M.BE.. » Wed, 15 Sep 1993 00:28:00



> I'm trying to compile the libraries v4.4.1 I got from

> When I invoke "make dep", make somewhere (when making misc, I think) includes
> <if.h> (=/usr/include/net/if.h) and then searches for <linux/if.h>, which is
> needed by <if.h>.
> This makes "make dep" fail, since there is no such file on my system (I think
> the file should be in /usr/src/linux/include/linux, it's not there...)

> Where can I get <linux/if.h> (preferably without too much other stuff) ?

> How should I go on after doing "make dep"?
> Is it sufficient to type "make SHARED=true"?

> Are there patches for upgrading to 4.4.2, and should I use them right now?

> By now, I've got a pl9 kernel, the 4.3.3 libs and gcc 2.3.3.

Since nobody seems to know an answer, I thought I probably could solve
my problem by downloading new kernel sources, which might contain
<linux/if.h>.
Do you know whether this could work?
Will there be problems caused by the different versions of the kernel sources
(I'll get pl12 or pl13, I think) and the kernel itself (still pl9)?

Thanks,
   Michael

 - Be a loyal plastic robot for a world that doesn't care - (Frank Zappa)

## CrossPoint v2.1 ##

 
 
 

1. Libc-4.4.1 -> forced net-src recompile?

Since I just caught a glimse of a posting about this, I'd like to get a little
more information.

I too have run into the situation where I can't issue loopback connects, and
I get messages from my system telling me it can't find named.hosts, named.local,
and named.rev files.  Do I now have to go into the net-src area and
recompile all of the files to use the latest libraries?

Likewise, do I have to move any other files around?

thanks

2. System installation problems

3. libc-4.4.1 problems

4. need help communicating with a modem mgetty.config

5. compiling libc-4.4.1

6. Success writing to IDE zip drive

7. Error makeing libc-4.4.1 shared libraries

8. cvsup problem

9. 4.1 4.1 4.1 HELP!

10. Printf bug in libc-4.6.27 -- libc-4.7.5

11. 4.1.3U1 libc patch and PCNFS 5.0

12. old libc on 4.1.3C

13. kaio_rdrw in libc.a on AIX 4.1