SLS 1.03 problem making usable boot disk...

SLS 1.03 problem making usable boot disk...

Post by Terrance M. Darcey, P » Fri, 03 Sep 1993 03:27:49



Despite making a serious effort to RTFM and experiment quite a bit, I am
unable to make a bootable floppy for SLS 1.03...The floppy is made w/o
complaint at the end of the install, but when I attempt boot it, I get
messages something like:

loading....
uncompressing linux....
invalid compressed format...
-system halted

The SLS distribution came from tsx-11.mit.edu and was installed from c:\
install w/o complaint...The disk has 3 partitions:

/dev/hda1 100MB dos
/dev/hda2 ~200MB root
/dev/hda3 16MB swap

mke2fs and mkswap showed a few bad block/pages, but no complaints otherwise

I then ran doinstall /dev/hda2 and specified harddisk /dev/hda1 to install
from...At the end, when I insert the pre-formatted floppy, answered
questions about preset video, modem, mouse, etc...When I was done, neither
the new floppy nor the harddisk were bootable...The only thing I could boot
was the install boot diskette (a1.5)...

Any help/suggestions would be greatly appreciated...E-mail replies
preferred...

Terrance M. Darcey, PhD

 
 
 

1. SLS 1.03: Problems making boot disk

This is driving me absolutely crazy, mostly because I'm not very good with
linux or with trackign down bugs.

--------

Yesterday I deleted out my old SLS and installed 1.03. It went pretty much
ok.  

The problem is, when I then configured the kernel and recompiled, the disk
produced with the 'make disk' command doesn't work.  All it will do is
boot up, print out the dots and then reboot the computer (a hard reboot;
doing the memory check).

Yes, the Makefile is set up to /dev/hdb2 (root).

I was having this problem last night and it was recommended to do a 'cp
Image /dev/fd0' and it did apparently work, but subsequent compiles using
that command to write the disk have been unsuccessful.

I have been using the a1 disk from thee SLS to boot, but that's getting
pretty old.

In any case, here's the system stats.  Nothing too excitng, but it might
be important.  I'd appreciate any help anyone could provide.  THanks.

------

386-25 w/ 8megs RAM, 512k generic VGA
105mb IDE (/dev/hda) formated DOS
120mb IDE (/dev/hdb1) 12mb swap, (/dev/hdb2) Linux ext2 partiton
Colorado 250mb Tape Drive
Sound Blaster
Microsoft Mouse (COM1)
14.4k Internal Modem (COM2)

--
{[> Robert A. Hayden               ____    #include <std_disclaimer.h>     <]}
{[>                                \  /__  ------------------------------- <]}


-=-=-

                        n-(---) h+(*) f+ g+ w++ t++ r++ y+(*)

2. chpass.c

3. Making a SLS 1.03 boot disk

4. SHELL-LOCK - was shell scripts.

5. Boot disks a1.3 and a1.5 missing in new SLS version 1.03

6. IP Masquerade - HELP!!!

7. Unable to make Boot disk with SLS 1.03

8. Linux cannot boot on MSI 694D PRO-AIR Board

9. Fail to boot SLS 1.03 (99pl12) installed on SCSI disk

10. Hmmm can anyone get SLS 1.03 to make boot disk?

11. SLS 1.03 a1.3 boot disk error

12. SLS 1.03 Problem: /proc not mounted at boot time?

13. SLS 1.03 boot problem