Slackware 2.0.1 Mail Problem

Slackware 2.0.1 Mail Problem

Post by brian hartsfie » Thu, 06 Oct 1994 04:52:32



I just installed slackware 2.0.1 and the mail system does not work.
If I send a message to a user, it just disapperars.  Does not go to
the mqueue, does not go to a dead.letter - just disappears.  If I
send mail to a user not on the system, I get the bounce message from
by system.  If I send to a valid user, it just bounced.

I am using sendmail 8.6.9 and have mailx and deliver installed.  I am
using smtp and using a nameserver.

Any advice would be appreciated.

73 Brian
KD4AEJ

(Do not mail to this account - since mail is not working I won't get it).

 
 
 

Slackware 2.0.1 Mail Problem

Post by nega.. » Fri, 07 Oct 1994 10:51:52


Brian> I just installed slackware 2.0.1 and the mail system does not
Brian> work.  If I send a message to a user, it just disapperars.
Brian> Does not go to the mqueue, does not go to a dead.letter - just
Brian> disappears.  If I send mail to a user not on the system, I get
Brian> the bounce message from by system.  If I send to a valid user,
Brian> it just bounced.

We had a similar problem with mail, and we got some of it ironed out:
Check out your /etc/sendmail.cf file, preferably with a reference like
the NutShell book on Sendmail.

We still have a problem, however:

E-mail works fine going off the machine, and it works fine locally,
but sendmail seems to be having enormous difficulty when running in
daemon mode.  It only answers the 'smtp' socket occasionally, and when
it does it typically locks up after a brief interval.  Since it is
apparently far superior to smail, we are frustrated that we can't get
this one little thing working.  Any suggestions?

Brian> I am using sendmail 8.6.9 and have mailx and deliver installed.
Brian> I am using smtp and using a nameserver.

We have the same setup.

Brian> Any advice would be appreciated.

Likewise...
--
)\,__,/(     __ \    _ \    __ \    _ \    _ \  o David Negaard

 \(~~)/    __/    \___/  _/      \__ /  \___/   o 700 College Avenue

--
)\,__,/(     __ \    _ \    __ \    _ \    _ \  o David Negaard

 \(~~)/    __/    \___/  _/      \__ /  \___/   o 700 College Avenue


 
 
 

Slackware 2.0.1 Mail Problem

Post by Jason Ha » Fri, 07 Oct 1994 16:51:08


: I just installed slackware 2.0.1 and the mail system does not work.
: If I send a message to a user, it just disapperars.  Does not go to
: the mqueue, does not go to a dead.letter - just disappears.  If I
: send mail to a user not on the system, I get the bounce message from
: by system.  If I send to a valid user, it just bounced.

: I am using sendmail 8.6.9 and have mailx and deliver installed.  I am
: using smtp and using a nameserver.

Is this a "pure" Slackware setup - or have you upgraded to sendmail
8.6.9/etc? If the former - hopefully Slackware will sort it out. If the
latter, it sounds like you haven't installed a local mailer (correctly).
You _cannot_ use mailx as a local mailer - but deliver would be fine
(assuming it comes with instructions on how to use as a local mailer - I
use procmail instead). The local mailer (that defined in sendmail.cf as
"Mlocal") must be setuid root/[setgid mail probably too] in order to work
at all - and you have to ensure it is called with the appropriate flags.
This requires you to read the appropriate man pages to see what
options should be set.

I'd installed mail.local (included in sendmail-8.6.9/contrib) as a
starter - that is known to work under Linux.

--

Cheers,

Jason
+------------------------------+------------------------------------------+
| Jason Haar, European SysAdmin   Phone: + 44 (256) 790111                |
| Motorola Cellular Subscriber      Fax: + 44 (256) 790519                |
| Basingstoke, Hampshire                                                  |

+------------------------------+------------------------------------------+

 
 
 

Slackware 2.0.1 Mail Problem

Post by Hitesh J. Jasa » Mon, 10 Oct 1994 16:05:56


: I just installed slackware 2.0.1 and the mail system does not work.
: If I send a message to a user, it just disapperars.  Does not go to
: the mqueue, does not go to a dead.letter - just disappears.  If I
: send mail to a user not on the system, I get the bounce message from
: by system.  If I send to a valid user, it just bounced.

: I am using sendmail 8.6.9 and have mailx and deliver installed.  I am
: using smtp and using a nameserver.

First try checking the file /root/Undel.mail.  This is where deliver should
be putting any of your locally undeliverable mail.

Second, you may have to modify the deliver line in your sendmail.cf file.
With the default line, deliver had to have 'delivery files'.  Since I didn't
have these files, I modified the line to just deliver the mail to the user's
mailboxes.

Mlocal, P=/usr/bin/deliver, F=SlsmFDMP, S=10, R=25/10, A=deliver -n $u

: Any advice would be appreciated.

: 73 Brian
: KD4AEJ

: (Do not mail to this account - since mail is not working I won't get it).

--
x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x=x

 * consultant                           (513) 528-9291
 Linux Inside

 Key fingerprint = 5A CF B1 75 FA 55 EF 84  51 42 2B 61 7E 87 9E 8F

 
 
 

1. Mail problems with Slackware

I have a single machine running slackware 1.2.3 release that is serving
email at Longview Community College.  The problem that I am having is
that when users log into the system it tells them that they have new mail
but when they run pine they have 0 messages in the inbox.  I have checked
/var/spool/mail/ file permissions,  I have checked the .pinerc files for
the users, and I have even look at the spooled incoming mail.  It is
there.  I am using sendmail to send it out and to receive it.  Mail to
deliver it locally and pine to read it.  The weird thing is that it works
for a few users but not the others.  Any ideas?

                                Thanks,
                                Brian Stewart


2. Xmanagers under Linux X

3. Mail problems in Slackware 2.2.0

4. ppp! Hotjava, ftp or telnet will not work.

5. Mail problems with Slackware 1.2.0 ?

6. New Kernel, No Mitsumi 2X CD; Help

7. smail/Mail problem in slackware 1.1.0?

8. patch 111713 needed

9. Slackware: sz doesn't work (rz does), also minor mail problem

10. Mail problems with Slackware 1.2.0

11. How do I delete mail from mail file /var/mail/su after reading mails

12. Problem with Slackware 2.1.0 installation (v/s Slackware 2.0)