init: can't find library 'libc.so.4'

init: can't find library 'libc.so.4'

Post by The Blue Ade » Sat, 01 Oct 1994 21:52:44



Subject: init: can't find library 'libc.so.4' :: any advice appreciated
Newsgroups: comp.os.linux.help
Summary:
Keywords:

i just installed the slackerware version of Linux on my toshiba 4400c
notebook the installation went great and i even set up LILO to boot
an msdos partition *i was so happy it worked* but when i tried to load
linux from lilo i get this error message

...
Partition check:
  hda: hda1 hda2 hda3
VFS: Mounted root (ext2 filesystem) readonly.
init: can't find library 'libc.so.4'
...

so i load linux from the boot and ramdisks, logged in as root and
checked to see if i could find this file, it was in the lib directory
as a shortcut (?) to another file ....... is this a problem ...
if you have any ideas or know what i should try i'd love some help
i'm really e*d about getting linux up and running so thanks in
advance!!


        otherwise, i will try to sift through and find them in news

                thanks again!

 
 
 

init: can't find library 'libc.so.4'

Post by Patrick Reijn » Sun, 09 Oct 1994 20:59:25



Quote:>Subject: init: can't find library 'libc.so.4' :: any advice appreciated
>Newsgroups: comp.os.linux.help
>Summary:
>Keywords:
>i just installed the slackerware version of Linux on my toshiba 4400c
>notebook the installation went great and i even set up LILO to boot
>an msdos partition *i was so happy it worked* but when i tried to load
>linux from lilo i get this error message
>...
>Partition check:
>  hda: hda1 hda2 hda3
>VFS: Mounted root (ext2 filesystem) readonly.
>init: can't find library 'libc.so.4'
>...
>so i load linux from the boot and ramdisks, logged in as root and
>checked to see if i could find this file, it was in the lib directory
>as a shortcut (?) to another file ....... is this a problem ...
>if you have any ideas or know what i should try i'd love some help
>i'm really e*d about getting linux up and running so thanks in
>advance!!

libc.so.4 is a dynamic c library which most probably resides in /lib.
furthermore it will be a link to a file called libc.so.4.x.x which is
normal and something you don't need to worry about. The fact that it cannot
be found means that /etc/ldconfig has not been executed. This has to be
executed to make dynamic libraries available to all programs on your system
which need them.

So boot up by disk. Go to the /etc directory on your linux root partition
and do ./ldconfig. If I'm not wrong everything should be ok the next time
you boot up via your harddisk.


>    otherwise, i will try to sift through and find them in news
>            thanks again!

Patrick REijnen

--
************************* Patrick Reijnen *************************
* Department of Computer Science, Catholic University of Nijmegen *

* WWW:    http://{atlas,zeus}.cs.kun.nl:4080/homepage.html        *

 
 
 

1. Slackware 2.1.0: init: can't find library 'libc.so.4' - Help

Hi all,

The end of my wits. Please tell me I'm doing something wrong. I'm
installing Slackware 2.1.0, disksets a, ap, d, e, x, xap, all very
fine. I reboot after installation, LILO comes up (Uncompressing
Linux... memory is tight, got 16 Mb memory and 16 Mb swap??) I use the
`scsi' bootdisk, a bit overdone maybe but what the hell. It looks like
all components are recognized correctly. The last messages are:


Partition check:
  sda: sda1 sda2
VFS: Mounted root (ext2 filesystem) readonly.
init: can't find library 'libc.so.4'

This is the same whether I boot up with floppy or from the disk. The
hardware is:

486DX2 on a ASUS PCI board (PCI rev. 2.0)
16 Mb memory
On-board PCI SCSI controller (NCR 53c810) 1G SCSI disk, both appear
with type numbers & all during startup

The system ran fine with dos and windows, but you'll appreciate that
that's not an option ;^) I do hope that I have given enough info, but
more is available.

thanks for your help

Marc
--
    + =========================================== +

   || IWTS, Nijmegen University   Wundtlaan 1     ||
   || 6525 XD Nijmegen            the Netherlands ||
    + =========================================== +

2. Help setting up RH7 on multiple drives

3. Can't find library 'libc.so.4' ???

4. Where did Nt-explorer for LInux go?

5. Compiler Error -- doesn't find shred library 'libc.so.4'

6. License Manager Help

7. dip: can't find library 'libc.so.4'

8. redhat linux6.0 : how to configure x-windows with graphics blaster rivatnt2(32mb agp card)

9. "Can't find shared library 'libc.so.3.0'"

10. ``Output file requires shared library `libc.so.4' ''

11. Help: "tcsh: can't load library 'libc.so.5'" ??

12. what does 'ld: Output file requires shared library `libc.so.4'' mean?

13. U R G E N T: CAN'T LOAD LIBRARY 'libc.so.5'