SOLVED: Re: XF86Setup: Can't load library 'libXaw.so.6'

SOLVED: Re: XF86Setup: Can't load library 'libXaw.so.6'

Post by Victor Wagn » Sat, 18 Apr 1998 04:00:00



:       Still have the problem where the x332bin.tgz, x332f100.tgz,
: x332fscl.tgz, and x332set.tgz files reported "Broken Pipe" when I
: untarred them using:

:       gzip -cdv x332bin.tgz | tar xvfB -

it means that tar halts before gzip finishes to send data.
It may or may not be a problem. May be you need to redownload them,
using command-line ftp client preferrable, becouse silly Netscape
can try to download tgz files in ASCII mode. (Do not forget
to say "binary" before saying "get" or "mget"). Alternatively
you can check hex dump of those tgz files and if you'll see all
0As prefixed with 0Ds, it is ASCII mode download. Several times I was
able to fix such a files using short C program, which reads file
byte by byte, and if encounters 0x0d, omits it, if next char is 0x0a.

Sorry, I don't have source handy. You can also try to write such a
program on Perl. Or, if if you have MS-DOS machine handy, download files
to it in BINARY mode and upload back to Linux in ASCII mode.
:       but that is another story.

:       Thankx to all who helped out.

: +-----------------------------+-----------------------------------+
: |Winnipeg MB Canada           | Send e-mail with Subject:         |
: |Team OS/2                    | PGP key for my PGP Public         |

: |           http://www.winnipeg.freenet.mb.ca/~soo696/            |
: +-----------------------------+-----------------------------------+

--
--------------------------------------------------

Institute for Commerce          Office:7-(095)-333-2022
Engineering                     Home: 7-(095)-135-46-61
Programmer                      http://www.fe.msk.ru/~vitus

 
 
 

SOLVED: Re: XF86Setup: Can't load library 'libXaw.so.6'

Post by Clifford Ki » Sun, 19 Apr 1998 04:00:00


If the gzip command below is actually what you used and not a typo, then
try swapping the "f" and "B".  Actually I think the "B" may be unnecessary.
There is a good chance that your tar supports gzip archives in which case

tar xzvf x332bin.tgz

works.


>    Still have the problem where the x332bin.tgz, x332f100.tgz,
>x332fscl.tgz, and x332set.tgz files reported "Broken Pipe" when I
>untarred them using:
>    gzip -cdv x332bin.tgz | tar xvfB -
>    but that is another story.

--
Clifford Kite                                                 Not a guru. (tm)


 
 
 

SOLVED: Re: XF86Setup: Can't load library 'libXaw.so.6'

Post by Kevin D. Knerr, Sr » Tue, 21 Apr 1998 04:00:00



>         Still have the problem where the x332bin.tgz, x332f100.tgz,
> x332fscl.tgz, and x332set.tgz files reported "Broken Pipe" when I
> untarred them using:

>         gzip -cdv x332bin.tgz | tar xvfB -

>         but that is another story.

Jim, whenever you're using an option which requires an argument (like
"-f" in tar, it needs to be the last option in the group.

Try this:

#!/bin/sh
# guntar a q&d script to unzip and untar a distribution
cat $1 | gunzip | tar xpf -

Using guntar filename, I can quickly unarchive a distribution to the
current directory, while leaving the original intact. (I did the same
thing for bzip2, naturally calling it buntar.)

HTH

Barthel
----------------------------------------------------------------

   PGP Public Key available at: http://home.ptd.net/~kknerrsr

ASCII stupid question...get a stupid ANSI!

 
 
 

1. XF86Setup: Can't load library 'libXaw.so.6'

Try following command. It may cure your problem.

   /sbin/ldconfig

--
----------------------------------------------------------------------
Yon Han Chong                     |
Flow Control and Prediction Group | Tel: + 44 1234 750 111 ext. 5420

Cranfield University              | Fax: + 44 1234 752 149
United Kingdom                    | Mobile: + 44 958 381 395
----------------------------------------------------------------------

2. What is the AF_LINK family in BSD scokets?

3. Error-> xterm: can't load library '//libXaw.so.3'

4. problem with ide-scsi and cdparanoia

5. can't load library 'libXaw.so.6'

6. SGML Templates

7. Troubles with ' libXaw3d ', can't load libXaw.so.6 ERROR - Please help!

8. Where can I acquire libbsd.a?

9. 'can't load libXaw.so.6'

10. Troubles with ' libXaw3d ', can't load libXaw.so.6 ERROR - Please help!

11. Problem: "can't find library 'libXaw.so.6' ..

12. can't find library 'libXaw.so.6

13. where is 'libXaw.so.6'? - help