Seyon vs. Minicom (strange modem permissions!?!?)

Seyon vs. Minicom (strange modem permissions!?!?)

Post by Mark Grime » Fri, 22 Mar 1996 04:00:00



This is very strange, and I'm not sure how to fix it.

Root can (of course run everything)
Regular users can run minicom fine...
HOWEVER, if my regular users run X, and they run SEYON under X,
it says that it can't access /dev/modem: no permissions.

If the regular user can't access the modem under Seyon (for a reason
not known to me) why can they use the modem under Minicom???

Please help, users are relying on this, and no HOWTOs or FAQs are seeming
to help.

 
 
 

Seyon vs. Minicom (strange modem permissions!?!?)

Post by Gerald E. Butl » Fri, 22 Mar 1996 04:00:00


: This is very strange, and I'm not sure how to fix it.

: Root can (of course run everything)
: Regular users can run minicom fine...
: HOWEVER, if my regular users run X, and they run SEYON under X,
: it says that it can't access /dev/modem: no permissions.

: If the regular user can't access the modem under Seyon (for a reason
: not known to me) why can they use the modem under Minicom???

: Please help, users are relying on this, and no HOWTOs or FAQs are seeming
: to help.

        Check to see if you have minicom set up as suid root.  If the
permission for owner-execute is 'S' instead of 'X' this is the case.  If so,
then you don't have user permissions enabled for the modem, and the only
reason minicom can access it is because it runs as root.  In you /dev
directory do an "ls -l" and see where you modem is pointing to ( likely
/dev/cua1 ).  Then make sure /dev/cua1 permissions are appropriate.

        Have A Nice Day!


 
 
 

1. modem responds slowly to seyon & minicom

I am having difficulties using minicom or seyon communications software my
modem responds very slowly to "at&" commands.
        For example "at&v"  does eventually return a message but it is missing
letters and information ie/ "PRFIL::" instead of "PROFILE".
        The modem will dial out and I can hear the remote host picking up and
answering me back but I do not get anything being displayed on my terminal.
        I have recompiled my kernel and it gives me no error messages.
        I have recompiled my minicom & seyon packages with no error messages.
        I have a internal 33.6k modem(ISAbus 33Mhz) and I'm running on a AMD5x86
(486 at 133Mhz).
        What/where should I do next?

2. Help: Domain not bound

3. Seyon or minicom and modems attached to remote devices?

4. 2.4.19, USB_HID only works compiled in, not as module

5. uugetty: does not reset modem after seyon/minicom

6. groff help

7. Strange Modem/Minicom Problem - Any Ideas!!

8. ME Entry in newsfeeds for innd in Linux ARGH !!!!!

9. Hot to set up minicom and seyon to append when dl w/zmodem

10. Documentation for minicom, Seyon ..

11. Slow minicom and seyon?

12. getties & minicom,seyon,pppd etc.: ARGH !

13. cua0 only works with seyon/minicom