X11 locks up on exit or swithcing to text mode

X11 locks up on exit or swithcing to text mode

Post by Csaba Kis » Fri, 26 Oct 2001 18:20:02



Hi!
I installed SuSE 7.3 on my machine. I use the new 4.1.0 X with a GEFORCE/2
card. X starts up fine but when I want to restart the machine or want to
switch to another virtual termnal (Alt-Fx), which is in text mode, the
computer locks up. It shows a strange garbage on the screen and the computer
does not repond to anything, I have to push the reset, which is not a nice
way to restart a machine. Can someone help with this?

Csaba

 
 
 

X11 locks up on exit or swithcing to text mode

Post by Rouben Rostami » Fri, 26 Oct 2001 23:19:56



>I installed SuSE 7.3 on my machine. I use the new 4.1.0 X with a GEFORCE/2
>card. X starts up fine but when I want to restart the machine or want to
>switch to another virtual terminal (Alt-Fx), which is in text mode, the
>computer locks up. It shows a strange garbage on the screen and the computer
>does not repond to anything, I have to push the reset, which is not a nice
>way to restart a machine. Can someone help with this?

I had that problem on my laptop that uses a Savage card and has a
1400x1050 resolution screen.  Similar laptops with 1024x786 screen
don't have that problem.  It appears that the problem occurs when
after switching from X to console, the console driver wants to stretch
the 80x25 character terminal to fit a 1400x1050 resolution display.

The "stretching" can be disabled by a setting in the display section of
the BIOS setup.  If you can do that, it may solve your problem.

Another solution which I picked on the net, is to add the lines

  append="video=vesa:mtrr,ywrap"
  vga=0x314

in the section of lilo.conf corresponding to kernel that causes
the problem.  I don't know what these lines do, by the solve the
problem too.

--


 
 
 

X11 locks up on exit or swithcing to text mode

Post by Csaba Kis » Fri, 26 Oct 2001 23:48:15


I solved my problem by inserting the
    Option "NvAGP" "1"
line in my XF86 Config file. Now it works like a charm.

Csaba

 
 
 

1. Hercules text mode not restored exiting from X11

I am running X11 on a system with a Hercules Monochrome Graphics card.
Unfortunately when exiting X text mode is not restored resulting in a blank
screen. I have to reboot to get the proper mode. I recall seeing something
on this a couple of months back but I wasn't running X11 at that time and
didn't save it. Does anyone know how to solve this problem. BTW I am running
Xfree386 mono from the Feb SLS release.


------

The Cellar BBS - (215) 539-3043

2. Application Monitoring Software

3. X11 mach32 server screws up text video on exit from X11

4. System Accounting

5. Text mode doesn't restore properly when exiting X.

6. linux problem

7. XF86 2.0 Mono/Hercules does not restore text mode on exit

8. Sending mail behind my back?

9. How to restore text mode after exiting X??

10. Text mode timing prob. on X exit...

11. XF86-4 fails to restore text mode at exit

12. --- text mode restore on X windows exit ??? ---

13. Exiting from X back to text mode