Linux 2.0.34/RedHat 5.1/XFree86 3.3.2/Fvwm2 2.0.46/Netscape 4.04: Recurring problems require X server reset

Linux 2.0.34/RedHat 5.1/XFree86 3.3.2/Fvwm2 2.0.46/Netscape 4.04: Recurring problems require X server reset

Post by Adam Neali » Thu, 13 Aug 1998 04:00:00



This is an annoying one.

After some use (and it might be linked to opening lots of Netscape
windows under Fvwm2), I start to get error message windows popping up.
This is usually when I try to open a window by, say,  replying to an
e-mail, or spawning a new Navigator window.

Once this starts to happen, I lose a lot of the functionality of the
left mouse button (!). e.g. Can't click on the widgets in window frames
to minimise/expand, etc, though the top title bar is OK. Also, can't
click on some of the window tabs in the NS config submenus - e.g. the
"search for a new group" tab under the "new discussion" option in the
Message Center window.

The fix I have found is to log out and then do an X server reset, which
seems to work (until the next time).

Error window is always titled:

Netscape: subprocess diagnostics (stdout/stderr)

and the contents go something like this:

Warning:
Name: subject
Class: XmTextField
Character 'R' not supported in font. Discarded.

Warning:
Name: subject
Class: XmTextField
Character 'e' not supported in font. Discarded.

Warning:
Name: subject
Class: XmTextField
Character ':' not supported in font. Discarded.

etc., etc. ad nauseum.

Smart people will notice that I am slowly being told that Netscape is
having a problem with putting the text of the subject in the box. i.e.
it's spelling out, letter by letter, in error messages "Re: mail blah
blah"

Is there a _simple_ solution to this one (I'm pretty ignorant of X's
inner workings and its interactions with fonts, so please be gentle with
me ;-) ).