Intellimouse won't work.

Intellimouse won't work.

Post by OoHOSE » Mon, 20 Jul 1998 04:00:00



Hi, I can't manage to get my intellimouse working in the XF86Setup. It just
sits in the center of the screen.  For those who don't know, the intellimouse
uses a 9 pin port, not the round PS/2 port.  Here's the funny part, in
Windows95, when I plug in the intellimouse and then an additional mouse into
the PS/2 port, I can use them both.  I guess both ports are mapped to COM1
(which is what MSD said my intellimouse was on) If anyone knows how I can make
the intellimouse work in X, or has had this problem before, please help.

Thank,


 
 
 

Intellimouse won't work.

Post by Mark » Mon, 20 Jul 1998 04:00:00


I could never get a serial intellilouse to work either. I pulled an old two
button serial out of the bin and it works fine. If you figure it out, let me
know.
Mark.


Quote:>Hi, I can't manage to get my intellimouse working in the XF86Setup. It just
>sits in the center of the screen


 
 
 

Intellimouse won't work.

Post by Perry Moutzouro » Tue, 21 Jul 1998 04:00:00


I have an intellimouse as well at work and at home. Both on Dell's
Dimension desktop. I run Debian Linux, and have been trying to get the
mouse to work with X, but to no avail. Until last night.

I set the thing to PS/2(it is in the ps/2 port, 6-pin right?)
and it worked fine. Except the roller ball thing.
Right mouse button and left mouse button worked fine.

Any ideas why this rollerball wont work?

PM


> Hi, I can't manage to get my intellimouse working in the XF86Setup. It just
> sits in the center of the screen.  For those who don't know, the intellimouse
> uses a 9 pin port, not the round PS/2 port.  Here's the funny part, in
> Windows95, when I plug in the intellimouse and then an additional mouse into
> the PS/2 port, I can use them both.  I guess both ports are mapped to COM1
> (which is what MSD said my intellimouse was on) If anyone knows how I can make
> the intellimouse work in X, or has had this problem before, please help.

> Thank,



 
 
 

Intellimouse won't work.

Post by Evan Griffin » Tue, 28 Jul 1998 04:00:00



> I have an intellimouse as well at work and at home. Both on Dell's
> Dimension desktop. I run Debian Linux, and have been trying to get the
> mouse to work with X, but to no avail. Until last night.

> I set the thing to PS/2(it is in the ps/2 port, 6-pin right?)
> and it worked fine. Except the roller ball thing.
> Right mouse button and left mouse button worked fine.

> Any ideas why this rollerball wont work?

> PM


> > Hi, I can't manage to get my intellimouse working in the XF86Setup. It just
> > sits in the center of the screen.  For those who don't know, the intellimouse
> > uses a 9 pin port, not the round PS/2 port.  Here's the funny part, in
> > Windows95, when I plug in the intellimouse and then an additional mouse into
> > the PS/2 port, I can use them both.  I guess both ports are mapped to COM1
> > (which is what MSD said my intellimouse was on) If anyone knows how I can make
> > the intellimouse work in X, or has had this problem before, please help.

> > Thank,



  Hi,

The PS/2 port worked for me as well.  I've read that the roller ball is not
supported,
so wouldn't waste much time on it.  In fact it isn't supported by most non-ms apps
in Windows.

Evan

 
 
 

Intellimouse won't work.

Post by Al » Tue, 28 Jul 1998 04:00:00




> > I have an intellimouse as well at work and at home. Both on Dell's
> > Dimension desktop. I run Debian Linux, and have been trying to get the
> > mouse to work with X, but to no avail. Until last night.

> > I set the thing to PS/2(it is in the ps/2 port, 6-pin right?)
> > and it worked fine. Except the roller ball thing.
> > Right mouse button and left mouse button worked fine.

> > Any ideas why this rollerball wont work?

> > PM


> > > Hi, I can't manage to get my intellimouse working in the XF86Setup. It just
> > > sits in the center of the screen.  For those who don't know, the intellimouse
> > > uses a 9 pin port, not the round PS/2 port.  Here's the funny part, in
> > > Windows95, when I plug in the intellimouse and then an additional mouse into
> > > the PS/2 port, I can use them both.  I guess both ports are mapped to COM1
> > > (which is what MSD said my intellimouse was on) If anyone knows how I can make
> > > the intellimouse work in X, or has had this problem before, please help.

> > > Thank,


>   Hi,

> The PS/2 port worked for me as well.  I've read that the roller ball is not
> supported,
> so wouldn't waste much time on it.  In fact it isn't supported by most non-ms apps
> in Windows.

> Evan

All,

Go to the XFree86 web page and look at the mouse documentation for
XFree86 Release 3.3.2....

http://www.xfree86.org/XFree86/

The info is all there. My Microsoft Intellimouse 1.1A PS/2 mouse works
fine.  There is
also another online web page dealing with this issue:

http://www.inria.fr/koala/colas/mouse-wheel-scroll/

                Al
--
----
Al Jarvi
Computer Specialist (Systems Analyst)
NOAA, National Weather Service
Office: 301.713.0386 Ext: 118

 
 
 

Intellimouse won't work.

Post by Mark » Tue, 28 Jul 1998 04:00:00


Yes, but will a SERIAL Intelli-louse work? I couldn't get mine to work..went
with a standard serial mouse..works fine..
 
 
 

Intellimouse won't work.

Post by Al Jarv » Wed, 29 Jul 1998 04:00:00



> Yes, but will a SERIAL Intelli-louse work? I couldn't get mine to work..went
> with a standard serial mouse..works fine..

Does your "SERIAL Intelli-louse" work in text mode?

If not read the 3-Button Mouse
HOW-TO:http://www.ssc.com/linux/LDP/HOWTO/mini/3-Button-Mouse-7.html

If it does and it still does not work in X then, have you read the XFree86
Mouse documentation?

http://www.xfree86.org/XFree86/3.3.2/mouse20.html#20

and

http://www.inria.fr/koala/colas/mouse-wheel-scroll/

It looks like all the information you need is at these sites.  You probably
have the wrong protocol
set or the mouse is inop...Does it work under Windows 95/98?

                                    Al

--
----
Al Jarvi
Computer Specialist (Systems Analyst)
NOAA, National Weather Service
Office: 301.713.0386 Ext: 118

 
 
 

Intellimouse won't work.

Post by Mark » Wed, 29 Jul 1998 04:00:00


Thanks Al.
I was using Redhat 5.1 During setup, and with subsequent attempts using
xf86config I selected the "Intellimouse" entry. It would never work. Either
in textmode or X. Fact is it never got to X. Just  a frozen screen. Mouse
worked fine with w95 and NT.
It's no big deal, I just hate when things don't work! I'll check out the
sites you suggest.
Thanks again.


>Does your "SERIAL Intelli-louse" work in text mode?

<--snipped-->
 
 
 

1. Intellimouse/Dell won't work

I'm at the end of my rope.  My bloody PS/2 Intellimouse won't work with
Red Hat 6.2 on my Dell XPS 350.  I've tried setting the protocol in
XF86Config to ps2, imps2, microsoft, etc. without luck.  All that
happens is my serial mouse (an old logitech 2-button that I can't wait
to toss) freaks out.  This led me to believe that the device was set
incorrectly (the signals from the serial mouse shouldn't be reaching the
PS/2 port).  So I tried changing the device from /dev/ttyS0 to
/dev/psaux, which did nothing for my mouse and disabled my keyboard.

If anybody can help, please CC me a copy of your response by e-mail.  I
will be forever grateful.

Thanks,
+--+
Nathaniel Gray
California Institute of Technology
Computation and Neural Systems
+--+

2. vi editor FAQ (Frequently Asked Question List), Part 2/2

3. IntelliMouse PS/2 compat won't work with X Windows

4. ORACLE and SCO OS5.0.4

5. intellimouse won't work in XF86Setup

6. disc performance

7. Intellimouse won't work in XF86Setup, or Linux.

8. how to re-IP the machine without reboot in Linux 7.2

9. CD won't work, system won't reboot...please help

10. help needed: AWE32 PNP won't work - kernel won't compile - gurus read this!

11. After linux's network works, win XP's network cannot work ?

12. X and MS Intellimouse problem (mouse won't move from center)