Anyone compiled Motif 2.0 with linux, XFree3.1, gcc 2.6.3?

Anyone compiled Motif 2.0 with linux, XFree3.1, gcc 2.6.3?

Post by Kai O'Ya » Wed, 01 Mar 1995 20:45:06



Hi,

Has anyone compiled Motif2.0 with linux, XFree3.1 and gcc 2.6.3?
Are there any gotchas? From first look it seems there are heaps of
hackings ... :-( So, if someone has done, pls give me some tips :)

Thanks in advance,
Kai

--

Kai O'Yang, SCIT, Peninsula Campus, Monash Uni, Frankston, VIC 3199, Australia.

-------------------------------------------------------------------------------

 
 
 

Anyone compiled Motif 2.0 with linux, XFree3.1, gcc 2.6.3?

Post by Kai O'Ya » Sun, 05 Mar 1995 16:52:19


A while ago I asked the following.

Quote:>Has anyone compiled Motif2.0 with linux, XFree3.1 and gcc 2.6.3?
>Are there any gotchas? From first look it seems there are heaps of
>hackings ... :-( So, if someone has done, pls give me some tips :)

So far I've successfully compiled the static libraries, mwm, the demos
etc. Now I'm trying to do the shared libs libXm.so, (Following "Using DLL
Tools with Linux", thanks for pointer from Enrico) and run into the following
problem in mkimage.
The command:
mkimage -l /usr/local/X11R6/lib/libXm -v 2.0 -a 0x67000000 -d 0x67300000 \
-g 8192 -j 0x8000 -- libXm.a -lX11 -lXt -lSM -lICE

and I got the following errors:

write.c:1216: failed assertion `fragP->fr_offset >= 0'
IOT trap/Abort

mkimage: error running 'as -o /src/motif/lib/Xm/jump/__jump.o
        /src/motif/lib/jump__jump.s'

It seems to me gas has failed. The __jump.s file has around 47k lines and
is ~750k big.

Has anyone encountered this problem before? How could it be fixed?

Thanks in advance,
Kai
--

Kai O'Yang, SCIT, Peninsula Campus, Monash Uni, Frankston, VIC 3199, Australia.

-------------------------------------------------------------------------------

 
 
 

1. Anyone get xmcd-1.4 to compile/run under linux, X11R6, Motif 2.0??

Title pretty much asks it all.

I downloaded the xmcd-1.4.tar.gz file from sunsite.unc.edu and tried to
install it.  I run into a couple of problems...

   1) cda fails to compile because visual.c can't #include <term.h>

   2) xmcd simply seg. faults. I traced it down and this is being caused by
      the XtVaSetValues() command that tries to assign the pixmaps to the
      four upper left check box toggle button gadgets.  It seems that after
      the call to XtCreateSimpleCheckBox() the following four calls to get
      the widgets for button_0, button_1, button_2 and button_3 do not
      return valid widgets.  anybody know how to fix this?

   3) I can get around 2) by simply not trying to set the XmNlabelPixmap
      values for those toggle buttons but then when I run xmcd the
      controller pops up followed by a dialog box that states
      "Device /dev/scd0 is not a CD-ROM!"
      and /dev/scd0 darn well is too a CD-ROM.

I'm running Linux v1.2.10, Slackware 2.3.0, gcc 2.6.3 and Infomagic's
Moo-Tif 2.0.

Would somebody please tell me how to correctly repair these faults so that
I can fix the distribution and replace the buggy version currently on
Sunsite?

Thanks,


2. Wine project status update

3. Motif 2.0 compiled on Solaris 2.3 using gcc 2.6.3?

4. RedHAT4.0 POP SERVER

5. compiling Motif 2.0 with a recent linux distro

6. First two chars dropped from filenames in xv, Solaris2.3

7. Compiling OSF/Motif 2.0 under Linux?

8. Win98 can not see Linux DHCP/Samba Server (WinNT/2000 can)

9. MOTIF 2.0, XFree386.3.1.1, and Mosaic....anyone?

10. Upgrading 1.3.x/Motif 2.0 system to 2.0.33/Motif 2.1 -- any problems/gotchas?

11. Tips on Compiling Motif 2.0

12. Compiling Motif 2.0

13. Help. Porting from Motif 1.2 to Motif 2.0