X 4.01, mga, opengl, dri and Soldier of Fortune

X 4.01, mga, opengl, dri and Soldier of Fortune

Post by Moritz Moeller-Herrma » Tue, 29 Aug 2000 04:00:00



Hello, I have recently set up X4.01 which runs quite well now after a little
tweaking.Nice. Even the 3D acceleration works fine with my Matrox G400 and
Linux 2.4.0t7 (agpgart and mga modules). That is it works fine with Quake3.

I have great problems to get soldier of fortune (the demo from lokigames) to
run properly. X always locks up after a few seconds of playing with stuck
(repeating) sound. The magic keys will still let me unmount and reboot linux
cleanly, but this is disappoining, as I had it running flawlessly with
utah-glx under X 3.3.6.

Does anyone have got any hints or experiences what might cause
the problems? Is a new release planned any time soon? Where is the problem,
with X, with Linux?

Thanks for any answers.

--

Get my public pgp / gpg key from                      
http://webrum.uni-mannheim.de/jura/moritz/pubkeymoritz
MS Windows ist Playmobil, Linux ist Lego.

 
 
 

X 4.01, mga, opengl, dri and Soldier of Fortune

Post by Fabrice Coli » Fri, 01 Sep 2000 20:08:01



> Hello, I have recently set up X4.01 which runs quite well now after a little
> tweaking.Nice. Even the 3D acceleration works fine with my Matrox G400 and
> Linux 2.4.0t7 (agpgart and mga modules). That is it works fine with Quake3.

> I have great problems to get soldier of fortune (the demo from lokigames) to
> run properly. X always locks up after a few seconds of playing with stuck
> (repeating) sound. The magic keys will still let me unmount and reboot linux
> cleanly, but this is disappoining, as I had it running flawlessly with
> utah-glx under X 3.3.6.

> Does anyone have got any hints or experiences what might cause
> the problems? Is a new release planned any time soon? Where is the problem,
> with X, with Linux?

You may want to check out the official Linux SoF newsgroup. I think I
read something about this problem. Go to www.lokigames.com/products/sof.

 
 
 

1. DRM & DRI for XFree 4.01

I'm using XFree86 4.01 and have compiled my kernel with the appropriate DRM
r128 module for 3D acceleration.

The Quake II demo runs great and OpenGL apps are very accelerated. Some
OpenGL apps do have some problems. ( gamma wrong, screwed up colors.)

I have read that the 3D modules provided in even the latest kernels are out
of date and that the ones included with XFree are better.

Should I get the latest CVS of XFree86 and compile and what kind of perform
difference can there be? Are they really that more up-to-date?

Any help appreciated,
Scott

2. ATI Mach 64, continued...

3. X 4.01 DRI problems/Voodoo3 PCI

4. Gtk widget update

5. DRI crash with 2.5.69, mga, Red Hat 9

6. how compatible is freebsd with linux?

7. X/DRI/AGP/MGA/crash problems

8. XF86Setup and Mouse...

9. mga-dri with highmem broken

10. XF86 4.0.1, MGA G200, and DRI questions...

11. installed XFree 4.1 from cooker- now no DRI (mga)

12. GLU and GLUT libs for XFree86 4.1 OpenGL/DRI?

13. XFree86 4.0.x, DRI and Mesa/OpenGL