KDE-apps fail to compile

KDE-apps fail to compile

Post by Alexander Topolane » Fri, 25 Dec 1998 04:00:00



Hi!

I have a somehow working KDE-environment under SuSE 5.2. If I try to
configure other apps (imon for instance). it claims a missing qt-1.33
library. The config.log says:

nfigure:2703: g++ -o
conftest -O2 -Wall -INO  -L/usr/lib/qt/lib -L/usr/X11R6/l
ib conftest.C -lqt -lXext -lX11  1>&5
conftest.C:2: qmovie.h: No such file or directory

I was searching my system for a qmovie.h, but didn't find it.

qt library is installed, the error appeared under version 1.33, now I
installed 1.4?, with the same results.

Anyone has an idea.

Thx, alexander

 
 
 

KDE-apps fail to compile

Post by Randa » Sun, 27 Dec 1998 04:00:00


I had a similar error trying to compile the latest snapshots of kdeadmin. It
was unable to find a file in it's own directory. I assume this is a transient
error in the particular snapshot since I had no trouble with previous snapshots.

Try downloading the lastest and greatest. May work.

Randy


>Hi!

>I have a somehow working KDE-environment under SuSE 5.2. If I try to
>configure other apps (imon for instance). it claims a missing qt-1.33
>library. The config.log says:

>nfigure:2703: g++ -o
>conftest -O2 -Wall -INO  -L/usr/lib/qt/lib -L/usr/X11R6/l
>ib conftest.C -lqt -lXext -lX11  1>&5
>conftest.C:2: qmovie.h: No such file or directory

>I was searching my system for a qmovie.h, but didn't find it.

>qt library is installed, the error appeared under version 1.33, now I
>installed 1.4?, with the same results.

>Anyone has an idea.

>Thx, alexander


 
 
 

KDE-apps fail to compile

Post by Nguyen The Toa » Wed, 30 Dec 1998 04:00:00



> Hi!

> I have a somehow working KDE-environment under SuSE 5.2. If I try to
> configure other apps (imon for instance). it claims a missing qt-1.33
> library. The config.log says:

> nfigure:2703: g++ -o
> conftest -O2 -Wall -INO  -L/usr/lib/qt/lib -L/usr/X11R6/l
> ib conftest.C -lqt -lXext -lX11  1>&5
> conftest.C:2: qmovie.h: No such file or directory

> I was searching my system for a qmovie.h, but didn't find it.

I compiled qt from source and it has qmovie.h in /usr/local/qt/include.
In
fact, that file is a symbolic link to /usr/local/qt/src/kernel/qmovie.h

Hope that can help.

Toan

 
 
 

1. ./configure for KDE apps fails on KDE

I am trying to compile some KDE apps on my box. When I run the configure
script I get to

checking for kde libraries installed...

and get a failure, something that says that my system fails at linking a
small KDE application. I have all of the KDE rpm's for my computer
installed, and I have Qt 2.02 installed and configured on my computer.
What else could it be?

Thanks
Lucas Vogel

2. Nashuatec D422

3. System Fails @ Linking KDE App

4. Strange problem with Apache 1.3.4 FTP proxy under OS/2

5. Certain X apps fail on KDE

6. FreeBSD boot configuration

7. Error compiling KDE apps in ports

8. Mail, MIME and Linux

9. How to compile older KDE apps on RH7/KDE2/QT2.2.1

10. Compiling KDE apps; Linker error

11. Can't compile KDE apps on RH6.1 Machine

12. Compiling KDE apps help ?

13. KDE App Compile Problem