ldconfig

ldconfig

Post by Eh Jye Lue » Sun, 24 Jan 1999 04:00:00



I'm having trouble with installing gtk+-1.1.12 because I can't seem to
run ld.config to update the ld.so.config files for glib-1.1.2.

How do I run ld.config and what parameters to use inorder to update the
newly installed glib library?

Thanks in advance.

 
 
 

ldconfig

Post by Bj?rn Elwhage » Sun, 24 Jan 1999 04:00:00



Quote:> I'm having trouble with installing gtk+-1.1.12 because I can't seem to
> run ld.config to update the ld.so.config files for glib-1.1.2.
> How do I run ld.config and what parameters to use inorder to update the
> newly installed glib library?
> Thanks in advance.

Just run "ldconfig" without any options as root and you will be done.
You could possible check to see that the path is included in
/etc/ld.so.conf. Shouldn't be no problem tho.

Good luck!

//Marwin

--

| Student at Wexio University           for PGP public key.          |
| Sweden                                ICQ: 356095                  |

 
 
 

ldconfig

Post by Eh Jye Lue » Mon, 25 Jan 1999 04:00:00




> > I'm having trouble with installing gtk+-1.1.12 because I can't seem to
> > run ld.config to update the ld.so.config files for glib-1.1.2.

> > How do I run ld.config and what parameters to use inorder to update the
> > newly installed glib library?

> > Thanks in advance.

> Just run "ldconfig" without any options as root and you will be done.
> You could possible check to see that the path is included in
> /etc/ld.so.conf. Shouldn't be no problem tho.

> Good luck!

> //Marwin

> --

> | Student at Wexio University           for PGP public key.          |
> | Sweden                                ICQ: 356095                  |

The problem is I can't seem to run ldconfig as root!! pls help!!
 
 
 

1. ldconfig inconsistent soname errors

Well, I've just upgraded all my libraries, compiler, everything.
The tests of ld (dynamic linker) all run fine.  But, when I installed
by running "sh shinstldso.sh" (or whatever the name of the script is),
it went through the normal stuff, saying it installed this, and that,
but when ldconfig was run, it gave (and still gives) me the following
(note, output was formatted to fit post better) :
----------------------------------------------------------------------
ldconfig: warning: /usr/lib/libpanel.1.9.9e has inconsistent soname
                  (libpanel.so.3.0), skipping
ldconfig: warning: /usr/lib/libform.1.9.9e has inconsistent soname
                  (libform.so.3.0), skipping
ldconfig: warning: /usr/lib/libmenu.1.9.9e has inconsistent soname
                  (libform.so.3.0), skipping
ldconfig: warning: /lib/libncurses.so.1.9.9e has inconsistent soname
                  (libncurses.so.3.0), skipping
----------------------------------------------------------------------

And, after installing, I just went ahead, and tried to recompile my
kernel (I wanted to put sound into it, until then I hadn't bothered).
All previous compilations went fine, no problems at all.  But now, my
kernel doesn't work (gdb says that it runs into a Segmentation Fault at
function startup_32() ).  And, basically what happens if I try to boot
with lilo in the MBR, is that the computer restarts.  So, right now I'm
using a boot disk, with kernel 2.0.0 (I'm running 2.0.27).  I was
wondering if anyone would be able to help (PLEASE!!).  Thank you for
your time.

Deleoi...still no sig, but thinking about something having to do with
         problems compiling...hehe.  See ya guys.  Congrats to everyone
         who's helped make Linux what it is today, my thanks go out to
         you all.

2. Please help before I kill another tree! old ps printer

3. ldconfig won't work with kernel 2.0.5

4. 2.8 on a cube?

5. Strange ldconfig behaviour

6. Trap within a function

7. RedHat 4.0-4.1 ldconfig problem

8. Network Printing Utilities?

9. ldconfig: libdl.so appears to be for multiple libc's error

10. HELP: glibc.2.04 rpm can't find /sbin/ldconfig

11. ldconfig: warning: /lib/libc.so.4.6.27 is not a ZMAGIC file, skipping

12. problem with ldconfig (and netscape)

13. ldconfig can't unlink ?