xv says "can't find libX11.so.6"

xv says "can't find libX11.so.6"

Post by George Frad » Wed, 27 May 1998 04:00:00



I' m trying to install xview3.2p1-X11R6-LinuxELF.2.bin.tar.gz on my
Debian 1.3 system.  When I attempt to execute xv I get the errors
saying:

xv: can't load library '/usr/lib/libX11.so.6'
        Unknown error
xv: can't load library '/lib/libX11.so.6'
        Unknown error
xv: can't find library 'libX11.so.6'

These files are not on my system, where can I get them?  I've done some
searching.

Help please I really liked that program on my slackware system and would
like to use it on my new set-up.

 
 
 

xv says "can't find libX11.so.6"

Post by Fragg » Wed, 27 May 1998 04:00:00



>I' m trying to install xview3.2p1-X11R6-LinuxELF.2.bin.tar.gz on my
>Debian 1.3 system.  When I attempt to execute xv I get the errors
>saying:

>xv: can't load library '/usr/lib/libX11.so.6'
>        Unknown error
>xv: can't load library '/lib/libX11.so.6'
>        Unknown error
>xv: can't find library 'libX11.so.6'

The program was compiled to use the glibc6 compiled versions of the X-libs. The
easiest solution would be to get the xview source and compile it yourself, or
grab the libc5 binary.

--
When your memory goes, forget it!

 
 
 

1. "can't find library 'libX11.so.6'"

Well, I seem to be having a problem with XWindows here.. For whatever reason,
the vast majority of programs I attempt to run under Xwindows give me an
error message of some sort; always it's because it can't find or load some
library file..

First off, I'll give a description of what I'm running (briefly):

kernel 2.0.21
Xfree86 3.1.2
fvwm95 2.0.42a

Now, whenever I try and run any program - "xterm", "color_xterm", "xedit",
"xv", etc.. (files which ARE there, btw), I get either:

xv: can't find library 'libX11.so.6'
xtetris: can't find library 'libXaw.so.6'
xterm: can't load library 'libtermcap.so.2'

Now, the problem here is that those library files actually ARE there, and
ldconfig seems to be able to find them - I've done ldconfig -v, and all of
those files come up in there..


check the newsgroups all that often...
--

                "A man talking sense to himself is no madder
                 than a man talking nonsense not to himself."

2. Samba-Ignorance is not bliss.

3. ??? about "can't find library 'libX11.so.6'"

4. Netscape Radio

5. I say "Hello" Linux says "Goodbye" ... aaarghhh

6. SUCCESSFUL INSTALL

7. 'insmod st' says "kernel_version needed, but can't be found" ???

8. shutdown

9. STARTX: "No Screens Found"/"Can't find Display"

10. "can't load library libX11.so.6"?

11. """"""""My SoundBlast 16 pnp isn't up yet""""""""""""

12. xinit: can't find "libX11.so.3"

13. GETSERVBYNAME()????????????????????"""""""""""""