Copy/paste between xterms from VI

Copy/paste between xterms from VI

Post by Ernie van der Me » Fri, 02 Jun 1995 04:00:00



Hello all,

I have noticed that it is not possible to use the normal copy/paste
scheme between two xterms from within VI. I want to select text in the
first window running VI and the paste it in the second window. I have
noticed that the mouse can be used to position the cursor when in
command mode in VI. Since I have no use for that I would like to ask
everyone here if there is a way to get rid of this 'feature'. Maybe
someone can point me in the right direction since I don't know if this
is caused by the xterm itself or by VI. I have checked man pages and
FAQs, but there seems to be nothing on this. I use XFREE 3.11 combined
with the 1.1.90 kernel and the Slackware 2.0 distribution.

Thanks for any help
--

Physics Laboratory, Utrecht University        tel. : (+31)-(0)30-534566
P.O. Box 80.000                               fax. : (+31)-(0)30-537555
3508 TA Utrecht, The Netherlands

 
 
 

Copy/paste between xterms from VI

Post by HADI SALIM JAM » Sat, 03 Jun 1995 04:00:00




Quote:>Hello all,

>I have noticed that it is not possible to use the normal copy/paste
>scheme between two xterms from within VI. I want to select text in the
>first window running VI and the paste it in the second window. I have
>noticed that the mouse can be used to position the cursor when in
>command mode in VI. Since I have no use for that I would like to ask
>everyone here if there is a way to get rid of this 'feature'. Maybe
>someone can point me in the right direction since I don't know if this
>is caused by the xterm itself or by VI. I have checked man pages and
>FAQs, but there seems to be nothing on this. I use XFREE 3.11 combined
>with the 1.1.90 kernel and the Slackware 2.0 distribution.

Try to hold the shift key when cutting.
Do the same when pasting to the other xterm.

Cheers
Jamal

--
?

 
 
 

1. copy+paste during vi session in an xterm

I recently moved to XFree86 3.1.2 (slackware 3.0), and found that
if I run vi (elvis) in an xterm I cannot copy and paste using mouse. But
copy and paste in shell is fine; copy and paste in vi and a normal
Linux console also works fine.

My last version of XFree86 was pretty old and did not have the problem.
I vaguely remember hearing this problem from others; a suggested solution
is to use vim. vim indeed works fine; but I just wonder why vi won't
work ...

Please advice. Thanks!


2. Printers Problem

3. Xterm+vi=no copy paste ?

4. multiple macros invocation in vi

5. Why cut + paste deoesn't work in vi + xterm

6. Nice job, RedHat!

7. cut/paste with mouse does not work in VI on Xterm ?!?

8. PPPoE: checking for duplication of effort

9. USING MOUSE IN IN vi IN XTERM TO CUT AND PASTE CODE

10. Block Copy & Paste in VI?

11. Xterm + paste into vi

12. elvis (vi) in an xterm session: cut and paste problems

13. vi in xterm cut/paste