"xterm" can't find libXaw.so.6 ?????????????????????

"xterm" can't find libXaw.so.6 ?????????????????????

Post by Rolf von Kuhlman » Fri, 14 Jul 2000 04:00:00



Hi,

I had a big, weird problem with all kinds of X-libraries: After
installing some new software
other programs couldn't find all their librarys. But logged in as root
everything is still fine.
AND: other programs >> can << find these same libraries ???

It's not the user permissions: /usr/X11R6/lib (where most libs are) is
readable and executable for all users.
I then added the most important library paths to my
LD_LIBRARY_PATH environment variable (which was unset before). Some
programs are working
now, but "xterm" still isn't (and it is the most important !!!!)

How can I tell xterm explicitly where e.g. libXaw.so.6 is ???

Thanks,

Rolf von Kuhlmann

 
 
 

"xterm" can't find libXaw.so.6 ?????????????????????

Post by kms.. » Fri, 14 Jul 2000 04:00:00



Quote:> Hi,
> I had a big, weird problem with all kinds of X-libraries: After
> installing some new software
> other programs couldn't find all their librarys. But logged in as root
> everything is still fine.
> AND: other programs >> can << find these same libraries ???
> It's not the user permissions: /usr/X11R6/lib (where most libs are) is
> readable and executable for all users.
> I then added the most important library paths to my
> LD_LIBRARY_PATH environment variable (which was unset before). Some
> programs are working
> now, but "xterm" still isn't (and it is the most important !!!!)
> How can I tell xterm explicitly where e.g. libXaw.so.6 is ???

man ldconfig

--

 Evangelist, Opensales, Inc.                    http://www.opensales.org
  What part of "Gestalt" don't you understand?   Debian GNU/Linux rocks!
   http://gestalt-system.sourceforge.net/    K5: http://www.kuro5hin.org
GPG fingerprint: F932 8B25 5FDD 2528 D595 DC61 3847 889F 55F2 B9B0

 
 
 

"xterm" can't find libXaw.so.6 ?????????????????????

Post by Rolf von Kuhlman » Sat, 15 Jul 2000 04:00:00




> > How can I tell xterm explicitly where e.g. libXaw.so.6 is ???

> man ldconfig

Thanks. I found it out with "ftrace -u username xterm":
The read permission for /etc/ld.so.cache were not set for group and user
...
Now it works!
 
 
 

1. Problem: "can't find library 'libXaw.so.6' ..

First of all, for reference sake, I'm running linux 2.0.21, with x3.1.2G ..

Now, my problem.. whenever I load up most *all* of the programs available in XWindows (xfm, color_xterm, etc), I get an error telling me that XWindows cannot find "libXaw.so.6", or "libX11.so.6" ..

Now, these files are in my /usr/X11/lib directory, and are found by ldconfig..


Thanks..

2. Benchmarks in Lynx

3. "fatal: libXaw.so.5: can't open file: errno=2"

4. IRC and identd

5. """"""""My SoundBlast 16 pnp isn't up yet""""""""""""

6. Trying to use minocom to config router

7. Running aXe 3.0.1 yields "can't find libXaw.a[shr.o]"

8. ADAPTEC-1520 and TOSHIBA CDROM PROBLEMS

9. STARTX: "No Screens Found"/"Can't find Display"

10. GETSERVBYNAME()????????????????????"""""""""""""

11. xterm gives "can't find usable termcap entry"

12. Error-> xterm: can't load library '//libXaw.so.3'

13. X windows: xterm gives "couldn't find per display info"