HighRes Console and X with a Matrox G550

HighRes Console and X with a Matrox G550

Post by Holger Fuessle » Fri, 20 Sep 2002 21:33:00



Hi all!

I'm using a Matrox G550 with a digitally connected TFT screen with
XFree 4.2.0 (Redhat 7.3). In addition to X - which works fine - I want
to use a high res console (boot param vga=0x31a). This also works, but
if X is started, switching back to the console only results in a black
screen. :-( Switching back to X again works fine.

Is there a solution for this problem? I found a framebuffer device in
my XF86config. Is this necessary?

Cheers

Holger

 
 
 

HighRes Console and X with a Matrox G550

Post by customer use » Sat, 21 Sep 2002 00:59:33



Quote:

> Hi all!

> I'm using a Matrox G550 with a digitally connected TFT screen with
> XFree 4.2.0 (Redhat 7.3). In addition to X - which works fine - I want
> to use a high res console (boot param vga=0x31a). This also works, but
> if X is started, switching back to the console only results in a black
> screen. :-( Switching back to X again works fine.

> Is there a solution for this problem? I found a framebuffer device in
> my XF86config. Is this necessary?

> Cheers

> Holger

Hope you didn't use the "F1" for getting into the console; the "F1" is
why the blank screen or a partial ".X.err" listing since it is your
X windows.  Using the "F2", "F3"....(but not "F7") will get a console
screen with a prompt, at least for "regular" rez.

 
 
 

1. console output/textmode with matrox g550 on dvi output

hello,

i'm just wondering if somebody already successfully used the dvi output
on a matrox g550 (or another matrox card) in textmode.
my system: amd xp 1900, asus a7v 266-e, kernel 2.4.15, matrox g550, lcd
connected on the dvi output.
in text mode (console, 80x50) the screen has a resolution of 640x480
(monitor info) and uses only the middle part of the lcd. there are two
black unused stripes on the top and the bottom of the display (something
like watching a 16:9 movie on a 4:3 tv). at least they should be black
(or blank). the problem appears when the 51st line of text is displayed.
the effect is like scrolling the image one line up and scrolling the
former 1st line on the bottom of the screen (the one that should be
blank) in. it looks like this

----------------------------
|   blank  top              |
|                           |
+---------------------------+
| line 1                    |
|                           |
| line 50                   |
+---------------------------+
|  blank bottom             |
|                           |
-----------------------------

and then like this
----------------------------
|   blank  top              |
|                           |
+---------------------------+
| line 2                    |
|                           |
| line 51                   |
+---------------------------+
|                           |
|  line 1                   |
-----------------------------

any idea how to fix this?

btw, the dvi seems to be activated by default. this is not the case in
X. but his is another story.

can anybody help?

thanx for your feedback,
christian

--
Posted via Mailgate.ORG Server - http://www.Mailgate.ORG

2. Compiling Apache 1.2.5 with FP98 - Help please

3. Matrox Mystique ands X.

4. Kernel Hack Guide ASCII, where?

5. NEC LCD1860 + Matrox G550

6. ROOT user screwed up: RPC Failure

7. installation problems: matrox g550 and redhat 7.1

8. Machine lockup during network bursts.

9. Matrox Millenium G550

10. finding and installing drivers for Matrox G550 dual output AGP video card

11. Help to install Matrox G550

12. Unable to run X with matrox G550

13. matrox g550 dualhead dvi and freebsd 4.7, server won't start