Configuring a ViewSonic VG800B

Configuring a ViewSonic VG800B

Post by EK » Sun, 15 Jun 2003 04:16:19



Hi There,

I'm trying to configure a ViewSonic VG800B for XFree86 4.2.0 for
24-bit 1280x1024 with NVIDIA's drivers on a RIVA TNT2 card with 32MB
VRAM.  The best I can get is 1024x768.  In my XFree86.0.log I see:

  (II) NVIDIA(0): Not using default mode "1280x1024" (hsync out of
range)

The HorizSync range that allows for 1024x768 is 31.5-48.5.  If I up it
to the range given to me by Xconfigurator (30 - 82) then I see the
message above and it falls back to 1024x768.

I'd really like to get the optimal resolution from this monitor.
Anyone been able to do this?

Thanks,
Ken

 
 
 

Configuring a ViewSonic VG800B

Post by I R A Darth Agg » Sun, 15 Jun 2003 13:43:51


On 13 Jun 2003 12:16:19 -0700,

+> I'm trying to configure a ViewSonic VG800B for XFree86 4.2.0 for

+> The HorizSync range that allows for 1024x768 is 31.5-48.5.  If I up it
+> to the range given to me by Xconfigurator (30 - 82) then I see the
+> message above and it falls back to 1024x768.

According to

http://www.viewsonic.com/products/lcd_vg800b.htm#specs

horizontal frequency: 30~82kHz
vertical   frequency: 50~75 Hz

In /etc/X11/XFree86Config-4 (or perhaps without the -4), make sure you
have a pair of entries that look like this:

    HorizSync   30-82
    VertRefresh 50-75

James
--
Consulting Minister for Consultants, DNRC
I can please only one person per day. Today is not your day. Tomorrow
isn't looking good, either.
I am BOFH. Resistance is futile. Your network will be assimilated.

 
 
 

Configuring a ViewSonic VG800B

Post by EK » Wed, 18 Jun 2003 03:49:53



> On 13 Jun 2003 12:16:19 -0700,


> +> I'm trying to configure a ViewSonic VG800B for XFree86 4.2.0 for

> +> The HorizSync range that allows for 1024x768 is 31.5-48.5.  If I up it
> +> to the range given to me by Xconfigurator (30 - 82) then I see the
> +> message above and it falls back to 1024x768.

> According to

> http://www.viewsonic.com/products/lcd_vg800b.htm#specs

> horizontal frequency: 30~82kHz
> vertical   frequency: 50~75 Hz

> In /etc/X11/XFree86Config-4 (or perhaps without the -4), make sure you
> have a pair of entries that look like this:

>     HorizSync   30-82
>     VertRefresh 50-75

> James

Thanks for your message.

We actually figured it out.  You are right about the HorizSync value -
that's what we were using.  But we found a typo in the XF86Config file
that fixed the problem.  We were lead astray by a strange error in the
XFree86.0.log file that did not point directly to our typo.

Anyhow, it works and we are happy.
Thanks,
Ken