Enabled XDCMP, but still not working.

Enabled XDCMP, but still not working.

Post by Hans Derag » Sat, 21 Jun 2003 03:08:31



Greetings.

  I am trying to setup my server to accept xdmcp.  I tried everything,
but nothing seams to be working.  I configured the following in
/etc/X11/gdm/gdm.conf (and yes, its gdm that is running on my server,
not xdm or another):

[xdmcp]
Enable=on
HonorIndirect=true
MaxPending=4
MaxPendingIndirect=4
MaxSessions=16
MaxWait=15
MaxWaitIndirect=15
DisplaysPerHost=1
Port=177
#Willing=/etc/X11/gdm/Xwilling

  I have also the following in /etc/hosts.allow

portmap: 142.133.0.0/255.255.0.0

  ...and except for comments, /etc/hosts.deny doesn't have anything
in.

  Still, I can't get connected. I do not have iptables installed, but
I assume that by default, all ports are opened on a RH 9.0 server.  As
for logs, I could not find anything.  Does gdm generates a log when a
connection is attempted?  I am using XWin.exe -query <hostname> from
cygwin to connect.  It too, does not complain, just shows an gray
desktop with the famous X cross as the cursor.

  I successfully got other servers to get XDMCP to work, but not this
one.  It eludes me.

Sincerely,
Hans Deragon

 
 
 

Enabled XDCMP, but still not working.

Post by Alle » Sat, 21 Jun 2003 03:55:56



> Greetings.

>   I am trying to setup my server to accept xdmcp.  I tried everything,
> but nothing seams to be working.  I configured the following in
> /etc/X11/gdm/gdm.conf (and yes, its gdm that is running on my server,
> not xdm or another):

> [xdmcp]
> Enable=on
> HonorIndirect=true
> MaxPending=4
> MaxPendingIndirect=4
> MaxSessions=16
> MaxWait=15
> MaxWaitIndirect=15
> DisplaysPerHost=1
> Port=177
> #Willing=/etc/X11/gdm/Xwilling

>   I have also the following in /etc/hosts.allow

> portmap: 142.133.0.0/255.255.0.0

>   ...and except for comments, /etc/hosts.deny doesn't have anything
> in.

I don't use gdm, but my setup for xdm has entries in these files in
/etc/X11/xdm:

1. Xaccess.
2. xdm-config has this commented out:
! DisplayManager.requestPort:   0
3. Xservers has entries for each allowed Xterminal, such as:
earth:0 foreign

- Show quoted text -

Quote:>   Still, I can't get connected. I do not have iptables installed, but
> I assume that by default, all ports are opened on a RH 9.0 server.  As
> for logs, I could not find anything.  Does gdm generates a log when a
> connection is attempted?  I am using XWin.exe -query <hostname> from
> cygwin to connect.  It too, does not complain, just shows an gray
> desktop with the famous X cross as the cursor.

>   I successfully got other servers to get XDMCP to work, but not this
> one.  It eludes me.

> Sincerely,
> Hans Deragon


 
 
 

Enabled XDCMP, but still not working.

Post by Steve Marti » Sat, 21 Jun 2003 20:46:16



>   I am trying to setup my server to accept xdmcp.

Here's a link that might be helpful:

http://www.linuxgazette.com/issue27/kaszeta.html

   I tried everything,

Quote:> but nothing seams to be working.  I configured the following in
> /etc/X11/gdm/gdm.conf (and yes, its gdm that is running on my server,
> not xdm or another):

I am not sure, but I don't think RH9 uses /etc/X11/gdm/gdm.conf,
as I have tried making changes there that never show up in the
GDM login screen. I could be wrong about this, if I am, I hope
someone in the NG will correct me, or else point out which
conf file is in fact being used.

--
Steve Martin, CPBE CBNT