Problems with SPEA Mirage P64 and 16bpp

Problems with SPEA Mirage P64 and 16bpp

Post by Marco Kaise » Tue, 12 May 1998 04:00:00



Hi,

probably this has been asked many times before, but...

here is my problem:

I am using a SPEA Mirage P64 video card with an S3 Trio64 chip (928). It
is
working fine with 8bpp at 1024x768 and 16bpp at 800x600, but when I try
to
set it to 16bpp at 1024x768 it fails, telling me that the clock is
limited
to 80MHz, but the mode would require 85MHz. When using 8bpp, it uses the

same modeline with 85MHz (i guess).
Under different operating systems, it works fine, (Windows NT, Window
95), I
am able to use 16bpp at 1024x768 pixels without problems.

In the config-file, there is no clockchip specified.

This is what X prints when starting in 8bpp:


(--) S3: chipset:   Trio64 rev. 20
(--) S3: chipset driver: mmio_928
(--) S3: card type: PCI
(--) S3: videoram:  2048k
(--) S3: SPEA Mirage P64 Trio64 detected.
(--) S3: Ramdac type: s3_trio64
(--) S3: Ramdac speed: 135 MHz
(--) S3: Using Trio32/64 programmable clock (MCLK 59.957 MHz)
(--) S3: Maximum allowed dot-clock: 135.000 MHz
(--) S3: There is no mode definition named "1280x1024"
(--) S3: Removing mode "1280x1024" from list of valid modes.
(--) S3: There is no mode definition named "1152x864"
(--) S3: Removing mode "1152x864" from list of valid modes.
(**) S3: Mode "1024x768": mode clock =  85.000
(**) S3: Mode "800x600": mode clock =  60.750
(**) S3: Mode "640x480": mode clock =  36.000
(**) S3: Mode "640x400": mode clock =  31.500
(**) S3: Mode "512x384": mode clock =  22.000
(**) S3: Mode "480x300": mode clock =  29.950
(**) S3: Mode "400x300": mode clock =  25.000
  (**) S3: Mode "320x240": mode clock =  15.750
(**) S3: Mode "320x200": mode clock =  12.590
(--) S3: Operating RAMDAC in pixel multiplex mode
(--) S3: Using 6 bits per RGB value
(--) S3: Virtual resolution set to 1024x768
(--) S3: Local bus LAW is 0xFB000000
(--) S3: Using a banksize of 2048k, line width of 1024
(--) S3: Using a single 64x64 area at (960,769) for expanding pixmaps
(--) S3: Using 8 planes of 1024x1215 at (0,833) aligned 8 as font cache

Can anyone tell me, if it is possible to use 16bpp at 1024x768 pixels
with
this card? If I remember right, it once worked (on a former linux
installation using Kernel 1.2.13 and X 3.1.2. This is X 3.3.2)

Thanks in advance,

-Marco

 
 
 

1. Problems with SPEA Mirage P64 and MAG PA17S

Does anyone have the following hardware running XFree86 3.1 or XFree3.1.1:

    MAG PA17S (of DX17F) monitor
    SPEA Mirage P-64 videocard

If so, I would be very interested in your XFConfig, because I can seem to
get my setup in good working order.

Here is what I have done so far: I have installed XFree86 3.1 through
Slackware Pro 2.1 (setup). Then I went to work on my XFConfig. I
encountered three problems:
  1. There was no preconfigured MAG PA17S (or MAG DX17F), so I had to
     improvise a bit on the Modelines in my XFConfig. I managed to

     recognized as such by my monitor.
        Q: does anyone have any more Modelines (that leave my screen in
           one piece)?
  2. There seems to be a problem when I enter 'startx', because the
     startup video mode is not the one I specified. After hitting
     [Ctrl][Alt][+] a couple of times the video mode the right one.
     Apperently this has something to do with the ICS2595 Clockchip
     and this bug is documented in the S3-docs.
        Q: Has this problem been fixed in XFree86 3.1.1?
  3. When I typed 'startx -bpp 16' my monitor suddenly displayed a very
     unhealthy looking screen that clearly indicated a refresh rate
     that was to high.
        Q: How is this possible and how do I solve it?
So if anyone has the answers to these questions or is running XFree86
3.1/3.1.1 on my configuration, please follow-up or send me a mail.

  Thanks in advance, Bas Kleijn

My setup:
- MAG PA17S screen and SPEA Mirage P-64 card.
- Pentium 90MHz on Intel-PLATO PCI motherboard with 8Mb RAM with
  EIDE controller, ATAPI CDROM, IDE HD and various other irrelevant facts...
- Linux kernel 1.2.5 and XFree86 3.1

2. Configuring Modem at com2

3. Problem with SPEA Mirage P64 VL

4. Xwindow: Unable to open display

5. Q: SPEA Mirage P64 PCI: Clockchip problem

6. Slack 3.6 and aic7xxx

7. Problems with Spea Mirage P64

8. Jumpstarting from a second ethernet card on sbus

9. Problems with Adaptec 1542CF/Spea Mirage P64

10. SPEA Mirage P64 (PCI)?

11. XConfig for SPEA Mirage-P64 S3-Trio

12. XF86Config for Spea Mirage P64 needed

13. REQ:X-Config for SPEA Mirage P64 PCI