XFree86 4.1 upgrade: left ALT key no longer META1???

XFree86 4.1 upgrade: left ALT key no longer META1???

Post by Jan » Wed, 18 Jul 2001 11:58:01



I recently upgraded from 4.0.1 (in Mandrake 8.0) to 4.1.  The upgrade
was smooth, with no errors or warnings.  The new configuration works
great with one exception: for some reason, the mapping for the left
ALT key was changed and as a result the left ALT key is no longer
recognized in any META1+whatever combinations (the right ALT key works
fine - and I have checked this with multiple keyboards).

Here is my InputDevice section of the XF86Config:
===
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "Autorepeat" "250 5"
        Option      "XkbRules"    "xfree86"
        Option      "XkbModel"    "microsoft"
        Option      "XkbLayout"   "us"
EndSection
===

BTW. attempts to use CustomKeycodes breaks most of the special keys...

Can anyone shed some light on how to fix this?  Many thanks!

Jan

 
 
 

1. Netscape and ALT+Left,ALT+Right keys

        I am using Netscape 1.0 with XFree86 3.1 on Linux 1.1.59. For some
reason the ALT+Left and ALT+Right keys do nothing instead of executing the
Back and Forward functions. Anyone have any ideas how to fix this ?

Cheers,
Neil

--
Neil Lovely                             |

South East Queensland Electricity Board | Phone  : +61 7 223 4256
GPO Box 1461  Brisbane Q 4001 Australia | Fax    : +61 7 221 7556

2. Mail queue problem!

3. XFree86 4.1 upgrade killed my BackSpace key.

4. sparc 4 bootable cdrom created on a PC - possible?

5. Left vs. Ctl-Left vs. Alt-Left

6. PCI Hotplug changes for 2.4.20

7. want to upgrade XFree86 3.3.6 to XFree86 4.1.x

8. Console misconfigured; how to reset ?

9. Alt key no longer working in xterm / aixterm / dtterm

10. problems with left alt key

11. Getting Left-Alt key to work in Emacs

12. Only left alt key working in bash

13. Left ALT key only- Why ?