ATI Rage Mobility P at 1400x1050 works with Mandrake 8.1

ATI Rage Mobility P at 1400x1050 works with Mandrake 8.1

Post by Joh » Sat, 03 Nov 2001 06:02:29



Right out of the box.  I've been struggling to get it working
correctly and pouring over newgroups and updates.

My machine is a Dell Inspiron 7500, but I imagine all the notebooks
with this card are gonna be in the chips.

My hat's off to the XFree86 folks for making this happen.  My notebook
looks SO SWEET.  Now I can migrate away from W2K completely :)

John

 
 
 

1. atyfb not working with ATI Rage Mobility P/M

Hi,

I tried to get the atyfb framebuffer working with my card without
success.

My card is:
01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility
P/M AGP 2x (rev 64)
(output by lspci)

Here is my kernel framebuffer config, but I don't think the problem is there:

--- begin ---
#
# Frame-buffer support
#
CONFIG_FB=y
CONFIG_DUMMY_CONSOLE=y
# CONFIG_FB_RIVA is not set
# CONFIG_FB_CLGEN is not set
# CONFIG_FB_PM2 is not set
# CONFIG_FB_PM3 is not set
# CONFIG_FB_CYBER2000 is not set
# CONFIG_FB_VESA is not set
# CONFIG_FB_VGA16 is not set
# CONFIG_FB_HGA is not set
CONFIG_VIDEO_SELECT=y
# CONFIG_FB_MATROX is not set
CONFIG_FB_ATY=y
# CONFIG_FB_ATY_GX is not set
CONFIG_FB_ATY_CT=y
# CONFIG_FB_RADEON is not set
# CONFIG_FB_ATY128 is not set
# CONFIG_FB_SIS is not set
# CONFIG_FB_NEOMAGIC is not set
# CONFIG_FB_3DFX is not set
# CONFIG_FB_VOODOO1 is not set
# CONFIG_FB_TRIDENT is not set
# CONFIG_FB_VIRTUAL is not set
# CONFIG_FBCON_ADVANCED is not set
CONFIG_FBCON_CFB8=y
CONFIG_FBCON_CFB16=y
CONFIG_FBCON_CFB24=y
CONFIG_FBCON_CFB32=y
# CONFIG_FBCON_FONTWIDTH8_ONLY is not set
# CONFIG_FBCON_FONTS is not set
CONFIG_FONT_8x8=y
CONFIG_FONT_8x16=y
--- end ---

I'm successfully running atyfb on another laptop with a different Rage
Mobility, but this one doesn't seem to be supported at all.
If I compile atyfb as a module, when I load it, the screen is black, but
everything else is running fine when I look at the system through ssh.

I'd be glad to help giving some specs if anyone would like to
implement it in the atyfb source code =)

Or maybe anybody did a patch already ?

Thanks for helping because this card just sux =(
- no accelerated framebuffer
- no DRI
- no Xv (unless using the unstable GATOS X binary)


2. Network Slowness

3. Sony VAIO Z505LE - ATI Rage Mobility not working

4. fork processes

5. X86Config not working on Dell CPxH 500 (ATI RAGE MOBILITY) :o(

6. Quick question on Software RAID support.

7. ATI Rage Mobility works with XFree86 4.0

8. How to upgrade my kernel...

9. ATi rage 128 on portable with 1400x1050 screen.

10. ati radeon ve and mandrake 8.1

11. ATI Rage Mobility w/ External Monitor

12. ATI Rage Mobility and Red Hat 6.1

13. ATI Rage Mobility M on a thinkpad 1480