Help! Debian X screen artifacts on S3

Help! Debian X screen artifacts on S3

Post by Pma » Thu, 14 Nov 2002 04:50:07



I've done a net install of Debian 3.0

I'm on it now but the time is being displayed radomly all over the
place. There is a bar on top of the screen so it's not drawing
properly I guess.

I've run "dpkg-reconfigure xserver-xfree86" so many times my finger
are falling off.

Here's my guess:

I have an old Packard Bell 200Mhz with built in 1MB "S3 trio64V+PCI"
and I have a Sony Multiscan 100sf (CPD-100SF). On Win98 I run 800x600
85hz 16bpp. I tried the "VGA" setting for S3 trio64V+PCI. It didn't
work. So I set it to the installed VESA setting and now I can run
things but it's as described.

H E L P !

I've really tried hard.

 
 
 

Help! Debian X screen artifacts on S3

Post by Pma » Thu, 14 Nov 2002 16:13:20


OK, I think the 4.1.0 version of X I have on Woody does "Virge S3" but
not my S3 Trio64V+PCI. Whereas the old "3.somthing" release of X has a
driver AND the newest versions (above 4.1.0) support mine if I have
the right chipsets. This according to the XFree86 web site.

So will I trash woody stability if I go forward with an X update? Will
I trash compatibility if I go back to an older release for stabilities
sake?

Will you point me in the right direction as to how to update (if
advised). Can I use APT or dselect or tasksel?

Should I just get the latest X for woody or hang back a bit for
stability?

HELP!


> I've done a net install of Debian 3.0

> I'm on it now but the time is being displayed radomly all over the
> place. There is a bar on top of the screen so it's not drawing
> properly I guess.

> I've run "dpkg-reconfigure xserver-xfree86" so many times my finger
> are falling off.

> Here's my guess:

> I have an old Packard Bell 200Mhz with built in 1MB "S3 trio64V+PCI"
> and I have a Sony Multiscan 100sf (CPD-100SF). On Win98 I run 800x600
> 85hz 16bpp. I tried the "VGA" setting for S3 trio64V+PCI. It didn't
> work. So I set it to the installed VESA setting and now I can run
> things but it's as described.

> H E L P !

> I've really tried hard.


 
 
 

Help! Debian X screen artifacts on S3

Post by user » Fri, 15 Nov 2002 04:13:54



> OK, I think the 4.1.0 version of X I have on Woody does "Virge S3" but
> not my S3 Trio64V+PCI. Whereas the old "3.somthing" release of X has a
> driver AND the newest versions (above 4.1.0) support mine if I have
> the right chipsets. This according to the XFree86 web site.

> So will I trash woody stability if I go forward with an X update? Will
> I trash compatibility if I go back to an older release for stabilities
> sake?

> Will you point me in the right direction as to how to update (if
> advised). Can I use APT or dselect or tasksel?

> Should I just get the latest X for woody or hang back a bit for
> stability?

Try using "xserver-xfree86_4.2.1-3_i386.deb" from
http://packages.debian.org/testing/x11/xserver-xfree86.html
Maybe the vesa driver in that version will also work.

You can use dselect to install version 3 without uninstalling
version 4.

 
 
 

Help! Debian X screen artifacts on S3

Post by Pma » Sun, 17 Nov 2002 06:37:08


Thank you.

apt-get install xserver-s3

did the trick