XF86-4 fails to restore text mode at exit

XF86-4 fails to restore text mode at exit

Post by Michal Szymans » Sun, 17 Feb 2002 16:36:52



Hi,

I'm maintaining several RH7.2 machines equipped with different video cards,
using XFree86-4.1.0-3. On some of these machines, using:

 NVidia Riva Ultra 64
 NVidia/SGS-Thomson Riva128

it happens from time to time that after exiting X, the console stays in
some strange mode. It looks like graphic mode with "pixel" color
patterns changing randomly as the user types. One can start X again,
logout, login blindly but it does not fix the problem. Restarted X work
fine but on exit, it happens again. Only reboot helps.

In older versions there used to be "restoretextmode" program but now it
is gone. Is there any way to reset the video hardware to default text
mode? This way (I mean graphic --> text) this should be pretty
"standard" operation.

regards, Michal.

--

  Warsaw University Observatory, Warszawa, POLAND

 
 
 

XF86-4 fails to restore text mode at exit

Post by gavro » Sun, 17 Feb 2002 17:35:10



> Hi,

> I'm maintaining several RH7.2 machines equipped with different video cards,
> using XFree86-4.1.0-3. On some of these machines, using:

>  NVidia Riva Ultra 64
>  NVidia/SGS-Thomson Riva128

> it happens from time to time that after exiting X, the console stays in
> some strange mode. It looks like graphic mode with "pixel" color
> patterns changing randomly as the user types. One can start X again,
> logout, login blindly but it does not fix the problem. Restarted X work
> fine but on exit, it happens again. Only reboot helps.

> In older versions there used to be "restoretextmode" program but now it
> is gone. Is there any way to reset the video hardware to default text
> mode? This way (I mean graphic --> text) this should be pretty
> "standard" operation.

> regards, Michal.

'man reset'...?

 
 
 

1. XF86-4 fails to restore text mode

XF86-4 fails to restore text mode at exit with Mandrake 8.1.
I instaled the drivers from www.nvidia.com and I modify the XF86Config-4
file changin "nv" to "nvidia" and adding "Load "glx" in modules section.
XFree run fine and a games like tuxraccer too.
But, when i restore the text mode ( changin to a console with Ctrl+alt+Fx ),
I get a blank screen.

Any ideas?
Thanks for the help in advance.
Antonio

2. SMB client networking

3. XF86 2.0 Mono/Hercules does not restore text mode on exit

4. appletalk networking with linux

5. Text mode doesn't restore properly when exiting X.

6. recomended patch level for 2.6

7. How to restore text mode after exiting X??

8. client connections while XDM is running

9. --- text mode restore on X windows exit ??? ---

10. Hercules text mode not restored exiting from X11

11. XFree86-1.3 (Hercules): text mode not restored after exit???

12. Help, X386 fails to restore text mode

13. Text screen is not restored after exiting from X-windows