XFree86 3.1.2E: libXt.so.6 problem?

XFree86 3.1.2E: libXt.so.6 problem?

Post by Doan Anh Tu » Fri, 24 May 1996 04:00:00



Hi all,

I've just installed XF86 3.1.2E on my laptop.
It works fine but I could not get ghostview
work. When I run ghostview, it says:

     #ghostview
     ghostview: '/usr/X11R6/lib/libXt.so.6' is not an ELF file
     ghostview: can't load library 'libXtso.6'
     #

I checked the lib file and below is the result:

     #file /usr/X11R6/lib/libXt.so.6
     /usr/X11R6/lib/libXt.so.6: symbolic link to libXt.so.6.0
     #file /usr/X11R6/lib/libXt.so.6.0
     libXt.so.6.0: Linux/i386 demand-paged executable (QMAGIC)

Did I do something wrong while installing XF86 3.1.2E?
Could anybody tell me what to do?

Thank you very much in advance.

Doan Anh Tuan
UNU/IIST

 
 
 

XFree86 3.1.2E: libXt.so.6 problem?

Post by Doan Anh Tu » Fri, 24 May 1996 04:00:00


Quote:>I've just installed XF86 3.1.2E on my laptop.
>It works fine but I could not get ghostview
>work. When I run ghostview, it says:
>     #ghostview
>     ghostview: '/usr/X11R6/lib/libXt.so.6' is not an ELF file
>     ghostview: can't load library 'libXtso.6'
>     #

Not only ghostview, but also xfilemanager has the
same problem.

Doan Anh Tuan

 
 
 

XFree86 3.1.2E: libXt.so.6 problem?

Post by Suzanne Archiba » Tue, 28 May 1996 04:00:00



:
: Hi all,
:
: I've just installed XF86 3.1.2E on my laptop.
: It works fine but I could not get ghostview
: work. When I run ghostview, it says:
:
:      #ghostview
:      ghostview: '/usr/X11R6/lib/libXt.so.6' is not an ELF file
:      ghostview: can't load library 'libXtso.6'
:      #
:
: I checked the lib file and below is the result:
:
:      #file /usr/X11R6/lib/libXt.so.6
:      /usr/X11R6/lib/libXt.so.6: symbolic link to libXt.so.6.0
:      #file /usr/X11R6/lib/libXt.so.6.0
:      libXt.so.6.0: Linux/i386 demand-paged executable (QMAGIC)

Yes, you got the a.out version somehow.

--

 
 
 

XFree86 3.1.2E: libXt.so.6 problem?

Post by morelli mich » Wed, 05 Jun 1996 04:00:00



: >I've just installed XF86 3.1.2E on my laptop.
: >It works fine but I could not get ghostview
: >work. When I run ghostview, it says:

: >     #ghostview
: >     ghostview: '/usr/X11R6/lib/libXt.so.6' is not an ELF file
: >     ghostview: can't load library 'libXtso.6'
: >     #

: Not only ghostview, but also xfilemanager has the
: same problem.

: Doan Anh Tuan

This is my opnion : XF86 3.1.2E have a wrong QMAGIC...
In italy some persons says me that other libraries and programs get the same
problems... Any one have linux Motif 2.0 for a.out and 3.1.2E XServer???
If YES, try to compil a program... In a P166 of my office GCC says me that
do not found the functions of libraries (XmAnyCallbackStruct for example)

bye bye
--
Zio Budda "always searching for new account..."


                http://dau.ing.univaq.it/~ziobudda/home.html
Ask me for questions about LINUX and Games for PC, and see my home page
I'm a programmer and a consultant...
And I'm the Coordinator of Milan's Pluto Linux User Group

Phone +39-2-2139959 ... Ask for  Davide Michel

 
 
 

XFree86 3.1.2E: libXt.so.6 problem?

Post by Steve June » Wed, 05 Jun 1996 04:00:00



: : >I've just installed XF86 3.1.2E on my laptop.
: : >It works fine but I could not get ghostview
: : >work. When I run ghostview, it says:

: : >     #ghostview
: : >     ghostview: '/usr/X11R6/lib/libXt.so.6' is not an ELF file
: : >     ghostview: can't load library 'libXtso.6'
: : >     #

: : Not only ghostview, but also xfilemanager has the
: : same problem.

: : Doan Anh Tuan

Get the ELF version of libXt.so.6 from the same location you took
your other files.  Move the current version into something like
/us/X11R6/lib/linux-aout/ (verify your /etc/ld.so.conf), install it in
/usr/X11R6/lib, rerun ldconfig.

In short, you have the a.out version of the library but your ghostview
expect the ELF version.

: This is my opnion : XF86 3.1.2E have a wrong QMAGIC...
: In italy some persons says me that other libraries and programs get the same
: problems... Any one have linux Motif 2.0 for a.out and 3.1.2E XServer???
: If YES, try to compil a program... In a P166 of my office GCC says me that
: do not found the functions of libraries (XmAnyCallbackStruct for example)

: bye bye
: --
: Zio Budda "always searching for new account..."


:               http://dau.ing.univaq.it/~ziobudda/home.html
: Ask me for questions about LINUX and Games for PC, and see my home page
: I'm a programmer and a consultant...
: And I'm the Coordinator of Milan's Pluto Linux User Group

: Phone +39-2-2139959 ... Ask for  Davide Michel

--
--
Steeve Juneau

http://www.rvo.qc.ca/~steevej

 
 
 

1. XFree86 3.1.2E expiring date problems

I've just installed the XFree86 3.1.2E update to the 3.1.2D beta
that expired a couple of days ago. I downloaded the ELF files
from ftp.xfree86.org and followed the upgrade procedure descriped
in RELNOTES. But running "startx" it still complains about expiration
of 3.1.2D!!?!

Can somebody help me out here? Thanks in advance.

Ivan Tving
--

2. Programming for Internationalization FAQ

3. Modem problem with XFree86 3.1.2E

4. A good editor in X

5. Selective key repeat in XFree86 3.1.2E

6. hmmm. 4.7-pre.. doesn't understand && in shells :-(

7. XFree86 3.1.2E ??

8. liquid

9. XFree86 3.1.2E on a TI Extensa 570CDT

10. XFree86 3.1.2E + Mach64 CT Atlantis

11. Diamond Stealth 3400, S3 968, XFree86 3.1.2E, Linux Slackware 1.2.13

12. W32, ICD2061A and XFree86 3.1.2E.

13. Announcing XFree86 beta release 3.1.2E