netscape under XFree 3.1.2E: libXpm.so.4 => not found

netscape under XFree 3.1.2E: libXpm.so.4 => not found

Post by Yin B » Fri, 11 Oct 1996 04:00:00



Just dowloanded Navigator 3.0 and got this:

netscape: can't load library 'libXpm.so.4'

then:

ldd netscape
        libXt.so.6 => /usr/X11R6/lib/libXt.so.6.0
        libSM.so.6 => /usr/X11R6/lib/libSM.so.6.0
        libICE.so.6 => /usr/X11R6/lib/libICE.so.6.0
        libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6.0
        libXpm.so.4 => not found
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6.1
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6.1
        libdl.so.1 => /lib/libdl.so.1.7.3
        libc.so.5 => /lib/libc.so.5.0.9

What happened? My X has been working ok with small apps. Thanks a lot.

Yin
--
        //////////////////////////////////////////////////////////

      ////          ///   http://www.eecis.udel.edu/~bao    ////
     //////////////////////////////////////////////////////////

 
 
 

netscape under XFree 3.1.2E: libXpm.so.4 => not found

Post by Graham Tod » Wed, 16 Oct 1996 04:00:00


Sounds like Xpm.so.4 either isn't on your system (unlikely) or the link
from libXpm.so.4.# to libXpm.so.4 isn't there.

(mine is libXpm.so.4 => /usr/X11R6/lib/libXpm.so.4.6)

Check /usr/X11R6/lib/ for the Xpm libraries.  If libXpm.so.4.6 (or 4.7
or whatever) is there make a link to libXpm.so.4.6 like this:

$: cd /usr/X11R6/lib
$: ln -s libXpm.so.4.6 libXpm.so.4
$: ls -al libXpm.so.4      <---- this will now show the link

Then run ldconfig again to be sure the lib gets picked up.

If yu don't have libXpm.so.4.# check your CD maybe it wasn't intalled
for some reason.  You can get it from sunsite, ftp.x.org, etc.


> Just dowloanded Navigator 3.0 and got this:

> netscape: can't load library 'libXpm.so.4'

> then:

> ldd netscape
>         libXt.so.6 => /usr/X11R6/lib/libXt.so.6.0
>         libSM.so.6 => /usr/X11R6/lib/libSM.so.6.0
>         libICE.so.6 => /usr/X11R6/lib/libICE.so.6.0
>         libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6.0
>         libXpm.so.4 => not found
>         libXext.so.6 => /usr/X11R6/lib/libXext.so.6.1
>         libX11.so.6 => /usr/X11R6/lib/libX11.so.6.1
>         libdl.so.1 => /lib/libdl.so.1.7.3
>         libc.so.5 => /lib/libc.so.5.0.9


 
 
 

netscape under XFree 3.1.2E: libXpm.so.4 => not found

Post by Justin B. Alco » Sat, 19 Oct 1996 04:00:00


: Just dowloanded Navigator 3.0 and got this:

: netscape: can't load library 'libXpm.so.4'

: What happened? My X has been working ok with small apps. Thanks a lot.

Netscape isn't ELF - You need to install a.out support on your Linux.

Justin