Middle button on Logitech 3 button mouse

Middle button on Logitech 3 button mouse

Post by Paul Smi » Tue, 11 Apr 1995 04:00:00



This is what I use for my Logitech Mouseman 3 button serial mouse (in
DOS it uses the Logitech driver version 6.30) under XFree86 3.1.1: I
have absolutely no trouble with it (fyi it's on COM2; /dev/mouse is just
a symbolic link to it):

Section "Pointer"
    Protocol    "Microsoft"
    Device      "/dev/mouse"
    ChordMiddle
EndSection

I don't use baud or samplerate at all.

--
-------------------------------------------------------------------------------

 Senior Software Engineer                                   Bay Networks, Inc.
-----------------------------------------------==<http://www.baynetworks.com/>-
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
     These are my opinions--Bay Networks takes no responsibility for them.

 
 
 

Middle button on Logitech 3 button mouse

Post by Randy Han » Tue, 11 Apr 1995 04:00:00


You must change the protocol from Microsoft to MouseMan.

 
 
 

Middle button on Logitech 3 button mouse

Post by Russ Woodroo » Tue, 11 Apr 1995 04:00:00


        I recently picked up a Logitech 3 button mouse, hoping to get it to
work with X, as the 3 button emulation was getting quite annoying with my
Microsoft mouse.  I got it home, plugged it in, went into linux, edited my
XF86Config file to disable Emulate3Buttons and enable ChordMiddle.  I then
started X and tried it out.  It works--sort of.  What seems to happen, is that
it gets the middle button mouse click, but whenever I move the mouse, it gets
continual mouse clicks.  This isn't really useful for pulling down root menus
which are bound to the middle button, unfortunately :).
        I tried enabling the Baud and SampleRate lines put in by the
configuration program, hoping that these might help.  (After all, it is a
Logitech mouse, and the comments indicated that the lines were applicable to
Logitech mice).  This didn't help much, in fact, when this was enabled,
the mouse refused to work at all.
        I'm running Linux kernel rev 1.2.1, and XFree86 3.1.1 (I believe those
versions are both right--in any case, it's what came with Slackware 2.20).
I'm typing this message from a Windows session, so I can't excerpt the exact
text of my config file, but it's using ChordMiddle as discussed above, with
of course protocol microsoft, device /dev/mouse.
        I realize that the support for mouse systems mice has traditionally
been better, but it was my understanding that the support for Microsoft pr
protocol 3 button mice had improved.  In any case, most of the mouse systems
mice seem to be rather cheap, and quite unpleasant to use for long periods of
time.  As I use my mouse a lot, and not only under linux, I want a mouse which
is fairly nice, which this one seems to be.
        Does anyone have any suggestions?  Is there a way to get this working
under the current version of XFree86?
        Thank you for any information...

                                                Russ Woodroofe

 
 
 

Middle button on Logitech 3 button mouse

Post by Volker Ossenko » Wed, 12 Apr 1995 04:00:00


:       I recently picked up a Logitech 3 button mouse, hoping to get it to
: work with X, as the 3 button emulation was getting quite annoying with my
: Microsoft mouse.  I got it home, plugged it in, went into linux, edited my
: XF86Config file to disable Emulate3Buttons and enable ChordMiddle.  I then
: started X and tried it out.  It works--sort of.  What seems to happen, is that
: it gets the middle button mouse click, but whenever I move the mouse, it gets
: continual mouse clicks.  This isn't really useful for pulling down root menus
: which are bound to the middle button, unfortunately :).

My XF86Config works fine with the Logitech mouse (at least here):

Section "Pointer"

Protocol    "MouseMan"
Device      "/dev/ttyS0"
# Baudrate and SampleRate are only for some Logitech mice
    BaudRate    1200
#    SampleRate 150

# Emulate3Buttons is an option for 2-button Microsoft mice
#    Emulate3Buttons
# ChordMiddle is an option for some 3-button Logitech mice
#    ChordMiddle

EndSection

i.e. I use the MouseMan protocol and ChordMiddle is disabled!

Hope this helps.

--------------------------------------------------------------------

  Astrophysikalisches Institut und    \\///
   Universitaets-Sternwarte Jena     ( . . )     Tel.: 03641/630324
----------------------------------oOo--(_)--oOo---------------------

 
 
 

Middle button on Logitech 3 button mouse

Post by Randy Han » Wed, 12 Apr 1995 04:00:00





>:   I recently picked up a Logitech 3 button mouse, hoping to get it to
>: work with X, as the 3 button emulation was getting quite annoying with my
>: Microsoft mouse.  I got it home, plugged it in, went into linux, edited my
>: XF86Config file to disable Emulate3Buttons and enable ChordMiddle.  I then
>: started X and tried it out.  It works--sort of.  What seems to happen, is that
>: it gets the middle button mouse click, but whenever I move the mouse, it gets
>: continual mouse clicks.  This isn't really useful for pulling down root menus
>: which are bound to the middle button, unfortunately :).

>My XF86Config works fine with the Logitech mouse (at least here):

>Section "Pointer"

>Protocol    "MouseMan"
>Device      "/dev/ttyS0"
># Baudrate and SampleRate are only for some Logitech mice
>    BaudRate    1200
>#    SampleRate 150

># Emulate3Buttons is an option for 2-button Microsoft mice
>#    Emulate3Buttons
># ChordMiddle is an option for some 3-button Logitech mice
>#    ChordMiddle

>EndSection

>i.e. I use the MouseMan protocol and ChordMiddle is disabled!

>Hope this helps.

>--------------------------------------------------------------------

>  Astrophysikalisches Institut und    \\///
>   Universitaets-Sternwarte Jena     ( . . )     Tel.: 03641/630324
>----------------------------------oOo--(_)--oOo---------------------

I also have a Logitech 3 button mouse for the same reasons and here is my
Pointer Section from XF86Config:

Section "Pointer"
        Protocol "MouseMan"
        Device "/dev/mouse"
        Baudrate 1200
EndSection

No ChordMiddle either and it has worked flawlessly.

Randy Hands


 
 
 

Middle button on Logitech 3 button mouse

Post by ch.. » Thu, 13 Apr 1995 04:00:00


I've found that you don't even need BaudRate set for the LogicTech.  All I
have set are:

        Protocol "MouseMan"
        Device "/dev/mouse"



> :  I recently picked up a Logitech 3 button mouse, hoping to get it to
> : work with X, as the 3 button emulation was getting quite annoying with my
> : Microsoft mouse.  I got it home, plugged it in, went into linux, edited my
> : XF86Config file to disable Emulate3Buttons and enable ChordMiddle.  I then
> : started X and tried it out.  It works--sort of.  What seems to happen, is that
> : it gets the middle button mouse click, but whenever I move the mouse, it gets
> : continual mouse clicks.  This isn't really useful for pulling down root menus
> : which are bound to the middle button, unfortunately :).

> My XF86Config works fine with the Logitech mouse (at least here):

> Section "Pointer"

> Protocol    "MouseMan"
> Device      "/dev/ttyS0"
> # Baudrate and SampleRate are only for some Logitech mice
>     BaudRate    1200
> #    SampleRate 150

> # Emulate3Buttons is an option for 2-button Microsoft mice
> #    Emulate3Buttons
> # ChordMiddle is an option for some 3-button Logitech mice
> #    ChordMiddle

> EndSection

> i.e. I use the MouseMan protocol and ChordMiddle is disabled!

> Hope this helps.

> --------------------------------------------------------------------

>   Astrophysikalisches Institut und    \\///
>    Universitaets-Sternwarte Jena     ( . . )     Tel.: 03641/630324
> ----------------------------------oOo--(_)--oOo---------------------

 
 
 

1. Using Logitech 3 button mouse, as a Logitech 3 button mouse.

Subject says it all,  after weeks of pain, grief, frustration, hating
everybody who kept telling me that Logitech mice work fine with 0.96bp2.
I finally got my Logitech Mouseman (3 buttons) to work.  Simply by
uncommenting the line in Xconfig for a Microsoft mouse. (Thank you whoever
posted this little snippet of advice, if only I had known).  However, I have
a 3 BUTTON mouse and would really like to use it as such.  Does anybody have
  ^^^^^^^^
a Mouseman working with 3 buttons.  Please, please tell me if you do.

Thanks (I hope) in advance,

Scott.

2. CVS Info needed

3. middle mouse button on three button mice

4. Problems installing libc.so.5.2.18

5. middle mouse button + Logitech pilot mouse

6. Permission Woes - can't add write permission

7. Middle mouse button acts wierd! Using Logitech mouse

8. Using middle button on 2-button mouse

9. Middle button on 3-button mouse not registering

10. How to make the middle button work in a 3 button mouse?

11. Setting up 3-button mouse with the middle button as wheel?

12. Middle mouse button sometimes generates button 1 and 3 events