nvidia riva tnt2 x server crash

nvidia riva tnt2 x server crash

Post by hkt.. » Tue, 27 Mar 2001 10:09:56



Hi all,

    I can't get my nVidia Riva TNT2 card working.  I am running linux kernel
2.4.2 and XFree86 4.0.2.  It works with the XFree86 "nv" driver but not
with
nVidia's own driver, which I installed from

NVIDIA_GLX-0.9-769.tar.gz
NVIDIA_kernel-0.9-769.tar.gz

and using debian packages

nvidia-glx-src
nvidia-kernel-src

    If I do an lsmod, I get
NVdriver              629280   0 (autoclean)

    When I startx, I get
==========================
..
(--) NVIDIA(0): MMIO registers at 0xF6000000
(==) NVIDIA(0): Write-combining range (0xfc000000,0x400000)
NV: could not open device /dev/nvidia0 (Unknown error 1024)
(EE) NVIDIA(0): Failure allocating device.  The NVIDIA kernel module
(EE) NVIDIA(0): may not be installed correctly!  Please refer to the FAQ for
(EE) NVIDIA(0): installation instructions.

Fatal server error:
Caught signal 11.  Server aborting
==========================

    I have tried various options for NvAgp in my XF86Config-4 file but to no
avail.
I even toyed with NVreg_VideoMemoryTypeOverride and NVreg_SkipBiosPost in
os-registry.c.  I am quite sure that the old Mesa stuff are no longer on my
system (debian's installation scripts should have taken care of that).

    Maybe it is something really simple that I overlooked, but I don't know
what else to try.  Below, I attach part of my XF86Config-4 and
/var/log/XFree86.0.log.  Please help!

Best,
Hsiu-Khuern Tang.
============ XF86Config-4 =============
Section "Module"
        Load    "dbe"
        Load    "fb"
        Load    "xaa"
        SubSection "extmod"
          Option    "omit xfree86-dga"   # don't initialise the DGA
extension
        EndSubSection
        Load    "glx"
        Load    "freetype"
        Load    "speedo"
        Load    "type1"
EndSection

Section "Device"
        Identifier      "Nvidia Riva TNT2"
#       Driver          "nv"
        Driver          "nvidia"
        Option          "sw_cursor"
#       BusID   "PCI:1:0:0"
EndSection

============= XFree86.0.log ==============
    XFree86 Version 4.0.2 / X Window System
(protocol Version 11, revision 0, vendor release 6400)
Release Date: 18 December 2000
        If the server is older than 6-12 months, or if your card is
        newer than the above date, look for a newer version before
        reporting problems.  (See http://www.XFree86.Org/FAQ)
Operating System: Linux 2.2.18 i686 [ELF]
Module Loader present
(==) Log file: "/var/log/XFree86.1.log", Time: Sun Mar 25 16:17:19 2001
(==) Using config file: "/etc/X11/XF86Config-4"
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (??) unknown.
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) |   |-->Monitor "HP v70"
(**) |   |-->Device "Nvidia Riva TNT2"
(**) |-->Input Device "Generic Keyboard"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc104"
(**) XKB: model: "pc104"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(**) |-->Input Device "HP Mouse"
(**) FontPath set to
"/usr/lib/X11/fonts/misc:unscaled,/usr/lib/X11/fonts/100dpi:unscaled,/usr/lib

/X11/fonts/75dpi:unscaled,/usr/lib/X11/fonts/Type1,/usr/lib/X11/fonts/Speedo,
/usr/lib/X11/fonts/misc,/usr/lib/X11/fonts/100dpi,/usr/lib/X11/fonts/75dpi"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(**) Option "BlankTime" "5"
(--) using VT number 8

(WW) Cannot open APM
(II) Module ABI versions:
        XFree86 ANSI C Emulation: 0.1
        XFree86 Video Driver: 0.3
        XFree86 XInput driver : 0.1
        XFree86 Server Extension : 0.1
        XFree86 Font Renderer : 0.2
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
        compiled for 4.0.2, module version = 1.0.0
        Module class: XFree86 Font Renderer
        ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
        compiled for 4.0.2, module version = 0.1.0
        ABI class: XFree86 Video Driver, version 0.3
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
..
(II) PCI: 01:00:0: chip 10de,0028 card 1043,0201 rev 15 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) LoadModule: "scanpci"
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
        compiled for 4.0.2, module version = 0.1.0
        ABI class: XFree86 Video Driver, version 0.3
(II) UnloadModule: "scanpci"
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(II) Host-to-PCI bridge:
(II) PCI-to-ISA bridge:
(II) PCI-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (-1,0,0), BCTRL: 0x00 (VGA_EN is cleared)
(II) Bus 0 I/O range:
        [0] -1  0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
        [0] -1  0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
        [0] -1  0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x0c (VGA_EN is set)
(II) Bus 1 I/O range:
(II) Bus 1 non-prefetchable memory range:
        [0] -1  0xf6000000 - 0xf7ffffff (0x2000000) MX[B]
(II) Bus 1 prefetchable memory range:
        [0] -1  0xfc000000 - 0xfdffffff (0x2000000) MX[B]
(II) Bus -1: bridge is at (0:7:0), (0,-1,0), BCTRL: 0x00 (VGA_EN is cleared)
(II) Bus -1 I/O range:
(II) Bus -1 non-prefetchable memory range:
(II) Bus -1 prefetchable memory range:
(--) PCI:*(1:0:0) NVidia Riva TNT2 rev 21, Mem @ 0xf6000000/24, 0xfc000000/0
(II) Addressable bus resource ranges are
        [0] -1  0x00000000 - 0xffffffff (0x0) MX[B]
..
        [17] -1 0x00001c80 - 0x00001c8f (0x10) IX[B]
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
        compiled for 4.0.2, module version = 1.0.0
        Module class: XFree86 Server Extension
        ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
        compiled for 4.0.2, module version = 1.0.0
        ABI class: XFree86 ANSI C Emulation, version 0.1
(II) LoadModule: "xaa"
(II) Loading /usr/X11R6/lib/modules/libxaa.a
(II) Module xaa: vendor="The XFree86 Project"
        compiled for 4.0.2, module version = 1.0.0
        ABI class: XFree86 Video Driver, version 0.3
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
        compiled for 4.0.2, module version = 1.0.0
        Module class: XFree86 Server Extension
        ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
        compiled for 4.0.2, module version = 1.0.769
        Module class: XFree86 Server Extension
        ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
        compiled for 4.0.2, module version = 1.1.8
        Module class: XFree86 Font Renderer
        ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font FreeType
(II) LoadModule: "speedo"
(II) Loading /usr/X11R6/lib/modules/fonts/libspeedo.a
(II) Module speedo: vendor="The XFree86 Project"
        compiled for 4.0.2, module version = 1.0.0
        Module class: XFree86 Font Renderer
        ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Speedo
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
        compiled for 4.0.2, module version = 1.0.0
        Module class: XFree86 Font Renderer
        ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
        compiled for 4.0.2, module version = 1.0.769
        Module class: XFree86 Video Driver
        ABI class: XFree86 Video Driver, version 0.3
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
        compiled for 4.0.2, module version = 1.0.0
        Module class: XFree86 XInput Driver
        ABI class: XFree86 XInput driver, version 0.1
(II) NVIDIA: NVIDIA driver for: RIVA TNT, RIVA TNT2, RIVA TNT2 (Ultra),
        RIVA TNT2 (Vanta), RIVA TNT2 (M64), RIVA TNT2 (??), RIVA TNT2 (??),
        RIVA TNT2 (Integrated), GeForce 256, GeForce DDR, Quadro,
        GeForce2 MX, GeForce2 MX DDR, GeForce2 Go, GeForce2 MXR,
        GeForce2 GTS, GeForce2 GTS, GeForce2 Ultra, Quadro2 Pro, GeForce3,
        GeForce3, GeForce3, GeForce3
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset RIVA TNT2 found
(II) resource ranges after xf86ClaimFixedResources() call:
        [0] -1  0xffe00000 - 0xffffffff (0x200000) MX[B](B)
..
        [22] 0  0x000003c0 - 0x000003df (0x20) IS[B]
(II) Setting vga ...

read more »

 
 
 

nvidia riva tnt2 x server crash

Post by Istvan Zsolt Kovac » Wed, 28 Mar 2001 21:43:02


Hi all!

I got almost the same problem with my nVidia Riva TNT2, RH6 kernel 2.2.17
and Xfree86 4.0.2. The difference is that I get a system crash/hang
instead of the the X server abort!
Installation and compilation of the nvidia 0.9-769 drivers it din't help
either. AGP support set to off (0) gives no different result.
Same result when changing NVreg_VideoMemoryTypeOverride and
NVreg_SkipBiosPost in os-registers.c

It looks like some help in this direction would very much appreciated on
this list!
There were a couple of times similar questions on the Xfree86 news group
but without any problem solving answers.
If more people with Riva TNT2 card experience this problem maybe is
the case to write directly to NVidia.

Best,
Istvan


Quote:> Hi all,

>     I can't get my nVidia Riva TNT2 card working.  I am running linux kernel
> 2.4.2 and XFree86 4.0.2.  It works with the XFree86 "nv" driver but not
> with
> nVidia's own driver, which I installed from

> NVIDIA_GLX-0.9-769.tar.gz
> NVIDIA_kernel-0.9-769.tar.gz


 
 
 

nvidia riva tnt2 x server crash

Post by Franck Guillau » Wed, 28 Mar 2001 22:25:17



> Hi all!

> I got almost the same problem with my nVidia Riva TNT2, RH6 kernel 2.2.17
> and Xfree86 4.0.2. The difference is that I get a system crash/hang
> instead of the the X server abort!
> Installation and compilation of the nvidia 0.9-769 drivers it din't help
> either. AGP support set to off (0) gives no different result.
> Same result when changing NVreg_VideoMemoryTypeOverride and
> NVreg_SkipBiosPost in os-registers.c

> It looks like some help in this direction would very much appreciated on
> this list!
> There were a couple of times similar questions on the Xfree86 news group
> but without any problem solving answers.
> If more people with Riva TNT2 card experience this problem maybe is
> the case to write directly to NVidia.

 what happends if you add

Option      "ShadowFB"

   in the Device Section ?

            Franck.

> Best,
> Istvan


> > Hi all,

> >     I can't get my nVidia Riva TNT2 card working.  I am running linux kernel
> > 2.4.2 and XFree86 4.0.2.  It works with the XFree86 "nv" driver but not
> > with
> > nVidia's own driver, which I installed from

> > NVIDIA_GLX-0.9-769.tar.gz
> > NVIDIA_kernel-0.9-769.tar.gz

--
---------------------------------------------

http://www.lezamis.net
---------------------------------------------
 
 
 

nvidia riva tnt2 x server crash

Post by Istvan Zsolt Kovac » Thu, 29 Mar 2001 05:55:52


Hi!


>  what happends if you add

> Option      "ShadowFB"

>    in the Device Section ?

Thanks, but, unfortunately it doesn't change the crashing behaviour:(
Did you Franck had similar problem(s) with any Nvidia cards+drivers?

It must be something more 'deep' or something so obvious we all (with the
same problem) miss here! Given this crash/hang the log
file does not get updated so I don't even have that as starting point for
debuging. I could check some other log files though ...

I don't have too much experience with this kind of things but I'll try to
run X from within the GDB if possible, maybe I get more info.

Best,
Istvan


> > >     I can't get my nVidia Riva TNT2 card working.  I am running linux kernel
> > > 2.4.2 and XFree86 4.0.2.  It works with the XFree86 "nv" driver but not
> > > with
> > > nVidia's own driver, which I installed from

 
 
 

nvidia riva tnt2 x server crash

Post by hkt.. » Thu, 29 Mar 2001 12:06:51


Hi,

      I was hopeful, but putting Option "ShadowFB" didn't help.

     Thanks for your suggestion.

Hsiu-Khuern.

Quote:> what happends if you add

>Option      "ShadowFB"

>   in the Device Section ?

>            Franck.

 -----  Posted via NewsOne.Net: Free (anonymous) Usenet News via the Web  -----
  http://newsone.net/ -- Free reading and anonymous posting to 60,000+ groups
   NewsOne.Net prohibits users from posting spam.  If this or other posts

 
 
 

nvidia riva tnt2 x server crash

Post by Franck Guillau » Thu, 29 Mar 2001 15:05:22



> Hi!


> >  what happends if you add

> > Option      "ShadowFB"

> >    in the Device Section ?

> Thanks, but, unfortunately it doesn't change the crashing behaviour:(
> Did you Franck had similar problem(s) with any Nvidia cards+drivers?

 Yes, I had similar problems with the previous drivers, and this option
solved the problem.

 But all is OK now with the lastest drivers.

        Franck.

 
 
 

nvidia riva tnt2 x server crash

Post by Franck Guillau » Thu, 29 Mar 2001 17:16:26



> Hi,

>       I was hopeful, but putting Option "ShadowFB" didn't help.

>      Thanks for your suggestion.

 What is your version of Xfree 4.0.x ?

           Franck.

 
 
 

nvidia riva tnt2 x server crash

Post by hkt.. » Fri, 30 Mar 2001 02:45:57


Hi,

       I'm running XFree 4.0.2, linux kernel 2.4.2.

Hsiu Khuern.


writes:


>> Hi,

>>       I was hopeful, but putting Option "ShadowFB" didn't help.

>>      Thanks for your suggestion.

> What is your version of Xfree 4.0.x ?

>           Franck.

 -----  Posted via NewsOne.Net: Free (anonymous) Usenet News via the Web  -----
  http://newsone.net/ -- Free reading and anonymous posting to 60,000+ groups
   NewsOne.Net prohibits users from posting spam.  If this or other posts