launching x0rfbserver with xinetd

launching x0rfbserver with xinetd

Post by Mike Pari » Mon, 18 Jun 2001 01:33:59



Hi,

I've tried to configure x0rfbserver to launch via xinetd.  However when
it starts I get the following error appear in the messages log:

xinetd[206]: execv( /usr/sbin/x0rfbserver ) failed: Exec format error
(errno = 8)

I can however run /usr/sbin/x0rfbserver quite happily from the command
line.

Presumably this error is because x0rfbserver has not been programmed to
run under xinetd.  Is this correct?  If so would it be very difficult to
modify it such that it can run under xinetd?

Regards,
Mike Parin.

 
 
 

1. KNode won't launch from kicker panel (but launches fine from CL)

Hmmm... little thing I seem to have after upgrading to KDE 3.0.1 this
morning.

FOr some reason, KNode won't luanch fro its button on the Panel. Can launch
it via the command line fine (thus this message), but can't figure out why
it starts then dies if launched from the panel all of a sudden (though in
the new RH 7.3 they had changed the location of it so it couldn't find it
at first).

Removed the button from the panel and put the new one in, but still nothing.

Anyone got an idea? Leftover temp file lock or something somewhere killing
it? Kind of stumped and can't track what it does in a terminal window as it
launches fine from the terminal... =}

ciao!
Daryl.

2. system calls

3. Compiling x0rfbserver for Solaris

4. Latest versions of Ghostview, HTTP server, Mosaic, Netscape for Linux

5. x0rfbserver help

6. term problem with bocamodem14.4

7. xinetd: no services are started by xinetd, telnet and ftp are not working. Redhat 8.0

8. XF86_XFCom_Rendition

9. xinetd question with linuxconf

10. xinetd & Lack of file descriptors?

11. Help - xinetd for Solaris

12. xinetd (telnet) problems with RHL7

13. oidentd & xinetd.conf configuration