Why is cursor big clumsy rectangle?

Why is cursor big clumsy rectangle?

Post by Quaker S. T. Ruptu » Mon, 08 May 1995 04:00:00



Title says it.  The fvwm manual makes reference to a file named
cursorfont.h, which exists nowhere on my system.  Is
that the problem?  The man page on this is a bit unclear.

When I exit, I can see that when X started, it reported:
(--) Mach32: using hardware cursor

Do I need to explicitly specify the cursor, and if so, in what init or
scriptfile?

(BTW I sure wish the Slackware I have came with more of a roadmap; I'm
having a rough time locating docs for all this stuff...)
--
--Quaker State Tapioca Rupture, Noted Expert

 
 
 

Why is cursor big clumsy rectangle?

Post by Scott R. Eve » Fri, 12 May 1995 04:00:00




> Title says it.  The fvwm manual makes reference to a file named
> cursorfont.h, which exists nowhere on my system.  Is
> that the problem?  The man page on this is a bit unclear.

> When I exit, I can see that when X started, it reported:
> (--) Mach32: using hardware cursor

> Do I need to explicitly specify the cursor, and if so, in what init or
> scriptfile?

> (BTW I sure wish the Slackware I have came with more of a roadmap; I'm
> having a rough time locating docs for all this stuff...)
> --
> --Quaker State Tapioca Rupture, Noted Expert


I had this problem once, and it seemed to be related to your VRAM
setting in the XF86Config file.  It seems the hardware cursor does
not work correctly(behavior like that noted above) if the Video RAM
is set wrong.  Try checking your VRAM setting to make sure it is
set to what the card actually has.

scott

--------------------------------------------------------------------
Scott R. Every                     _/_/_/_/  _/_/    _/_/ _/_/_/_/_/
EMJ America, Inc.                 _/        _/ _/  _/ _/       _/
Technical Support                _/_/_/    _/  _/_/  _/       _/
1-800-548-2319                  _/        _/   _/   _/   _/  _/

Use finger for more info.       America, Inc.

 
 
 

1. Mouse Cursor is white rectangle

A few days ago, without any changes to configuration, my
mouse cursor became a white rectangle.  While useable, it
is annoying. It's this way all the time regardless of what's
running.

Attached is the output from my X server as it starts. I
appreciate any clues as to what might be wrong.

Thanks
Jim Pike

[ log 2K ]

XFree86 Version 3.2 / X Window System
(protocol Version 11, revision 0, vendor release 6100)
Release Date: Oct 26 1996
        If the server is older than 6-12 months, or if your card is newer
        than the above date, look for a newer version before reporting
        problems.  (see http://www.XFree86.Org/FAQ)
Operating System: Linux [ELF]
Configured drivers:
  Mach32: accelerated server for ATI Mach32 graphics adaptors (Patchlevel 0)
(using VT number 7)

XF86Config: /etc/XF86Config
(**) stands for supplied, (--) stands for probed/default values
(**) Mouse: type: PS/2, device: /dev/mouse, baudrate: 1200,
       3 button emulation (timeout: 50ms)
(**) Mach32: Graphics device ID: "ATI"
(**) Mach32: Monitor ID: "crystal"
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/"
(--) Mach32: card type: localbus (486)
(**) Mach32: Number of Clocks: 32
(**) Mach32: clocks: 100.37 126.13  92.46  36.11  50.47  56.74   0.00  44.90
(**) Mach32: clocks: 135.16  32.01 109.92  80.09  39.93  44.92  75.11  64.98
(**) Mach32: clocks:  50.19  63.06  46.23  18.05  25.23  28.37   0.00  22.45
(**) Mach32: clocks:  67.58  16.00  54.96  40.05  19.96  22.46  37.55  32.49
(--) Mach32: Maximum allowed dot-clock: 135.000 MHz
(**) Mach32: Mode "1024x768": mode clock =  75.000, clock used =  75.110
(**) Mach32: Mode "640x480": mode clock =  31.500, clock used =  32.010
(**) Mach32: Mode "800x600": mode clock =  50.000, clock used =  50.190
(**) Mach32: Virtual resolution: 1024x768
(--) Mach32: Display width: 1024
(--) Mach32: videoram: 2048k
(--) Mach32: Using hardware cursor
(--) Mach32: Using 4 MB aperture
(--) Mach32: Ramdac is ATI68875/TLC34075/Bt885
(**) Mach32: Using 6 bits per RGB value
(--) Mach32: Aperture mapped to 0x7f00000 + 0x0
(--) Mach32: Using a single 64x64 area for expanding pixmaps
(--) Mach32: Using 8 planes of 960x768 at (0,768) aligned 8 as font cache
PEX extension module not loaded
XIE extension module not loaded

2. Hi - A basic Question

3. XF_Mach32 harware cursor -> white rectangle

4. X question

5. Big Rectangle mouse!!???

6. trying to configure Dell Ultrascan 17FS-N & TVGA8900B

7. Cursor is a big white block; cannot see any text in any window

8. A mail problem

9. Big BLOCK Cursor on Console Info here!

10. big cursor

11. Big BLOCK Cursor on Console Info here!

12. big cursor

13. BIG pointers, cursors needed !