Couldn't load XKB keymap??? Please help--

Couldn't load XKB keymap??? Please help--

Post by Frank Mil » Tue, 04 Feb 1997 04:00:00



Running startx (or xinit), the following errors are reported to
stdout/stderr:
        parse error: line 1 of stdin
        Errors encountered in stdin; not compiled
        Couldn't load XKB keymap, falling back to pre-XKB keymap

X starts "properly", except that the keyboard isn't properly set up,
at least not the way I'd like it.  I'm trying to get that straightened out.
The only direct modifications to the startup scripts has been to fix the
PEX/XIE not loaded problem; otherwise it's straight out of the box, with
just the usual alterations for video card and monitor [#9GXE64-Pro,
Sony 15" Trinitron].

This is on a RH4.0 system with XFree 3.2.2, from rpm's (though some
heavy handedness had to be used to overcome the initial XFree version).

I'd appreciate any help (including pointers to documentation that I've
overlooked).

        -frank

 
 
 

1. Couldn't load XKB Keymap

I get the following message when I shut down X while logged in as root:

keyboard description

I do not get this same message if I am logged on as a regular user.

Can anybody tell me what the problem is and how would I go about fixing it?

Thanks, Ralph

2. IPC and Daemon help requested

3. Couldn't load XKB keymap

4. characters not allowed in filenames

5. SmartUPS1000, WinNT & Linux

6. Please Help! Can't load XKB Keymap!

7. 32 bit Cardbus / PCI bridge

8. Can't load XKB keymap?

9. No Xwindows - couldn't load keymap