3.9.17 won't start on TNT card...

3.9.17 won't start on TNT card...

Post by Graham TerMarsc » Wed, 12 Jan 2000 04:00:00



Managed to get 3.9.17 to compile properly on my machine here, but for
the life of me haven't been able to get it to start up at all.  I've
tried using both the "nv" driver and the generic "vga" driver, and both
choked and died on the same message.  Tried a rebuild of the snapshot
using the 2.2.11 kernel, got the same message.  Went back to my 2.3.38
kernel, rebuilt the snapshot from scratch again, got the same message.
Any ideas what's going on?

Running this on a machine with:
- Creative Labs Graphics Blaster TNT
- AMD K6-III 400Mhz
- Asus P5A-B motherboard (Bios 1.007) (ALI-V chipset)
- Mandrake 6.1

XFree86 compiled with opts of "-O2"; nothing fancy.

--
Graham TerMarsch

// -----------------------------------------------------------------
// I have more hit points that you can possible imagine.  
// -----------------------------------------------------------------

[ XFree86.0.log 7K ]

XFree86 Version 3.9.17  / X Window System
(protocol Version 11, revision 0, vendor release 6400)
Release Date: 31 December 1999
        If the server is older than 6-12 months, or if your card is newer
        than the above date, look for a newer version before reporting
        problems.  (see http://www.XFree86.Org/FAQ)
Operating System: Linux 2.2.11-2mdk i586 [ELF]
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Mon Jan  3 00:18:19 2000
(==) Using config file: "/etc/X11/XF86Config"
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (??) unknown.
(==) ServerLayout "Simple Layout"
(**) |-->Screen "Screen 1" (0)
(**) |   |-->Monitor "My Monitor"
(**) |   |-->Device "My Gfx Card"
Layout "Simple Layout"
Screen: "Screen 1" (0):
        0 0
(**) |-->Input Device "Mouse1"
(**) |-->Input Device "Keyboard1"
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc101"
(**) XKB: model: "pc101"
(**) Option "XkbLayout" "ca"
(**) XKB: layout: "ca"
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/:unscaled,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/75dpi/"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/local/tmp/X11R6/lib/modules"
(--) using VT number 3

(II) Module ABI versions:
        XFree86 ANSI C Emulation: 0.1
        XFree86 Video Driver: 0.1
        XFree86 XInput driver : 0.0
        XFree86 Server Extension : 0.0
        XFree86 Font Renderer : 0.0
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/local/tmp/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
        compiled for 3.9.17, module version = 1.0.0
        Module class: XFree86 Font Renderer
        ABI class: XFree86 Font Renderer, version 0.0
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/local/tmp/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
        compiled for 3.9.17, module version = 0.1.0
        ABI class: XFree86 Video Driver, version 0.1
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 10b9,1541 card 10b9,1541 rev 04 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 10b9,5243 card 0000,0000 rev 04 class 06,04,00 hdr 01
(II) PCI: 00:03:0: chip 10b9,7101 card 10b9,7101 rev 00 class 06,80,00 hdr 00
(II) PCI: 00:07:0: chip 10b9,1533 card 0000,0000 rev c3 class 06,01,00 hdr 00
(II) PCI: 00:09:0: chip 1011,0014 card 0000,0000 rev 21 class 02,00,00 hdr 00
(II) PCI: 00:0f:0: chip 10b9,5229 card 0000,0000 rev c1 class 01,01,fa hdr 00
(II) PCI: 01:00:0: chip 10de,0020 card 1102,1015 rev 04 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x08 (VGA_EN is set)
(II) Bus 1 I/O range:
(II) Bus 1 non-prefetchable memory range:
        [0] -1  0xdf000000 - 0xdfffffff (0x1000000) MXB
(II) Bus 1 prefetchable memory range:
        [0] -1  0xe6f00000 - 0xe7ffffff (0x1100000) MXB
(--) PCI: (1:0:0) NVidia Riva TNT rev 4, Mem @ 0xdf000000/24, 0xe7000000/24
(II) Addressable resource ranges are
        [0] -1  0x00000000 - 0xffffffff (0x0) MXB
        [1] -1  0x00000000 - 0x0000ffff (0x10000) IXB
(II) OS-reported resource ranges:
        [0] -1  0xffe00000 - 0xffffffff (0x200000) MXB(B)
        [1] -1  0xfee00000 - 0xfeefffff (0x100000) MXB(B)
        [2] -1  0xfec00000 - 0xfecfffff (0x100000) MXB(B)
        [3] -1  0x00100000 - 0x3fffffff (0x3ff00000) MXBE(B)
        [4] -1  0x000f0000 - 0x000fffff (0x10000) MXB
        [5] -1  0x000c0000 - 0x000effff (0x30000) MXB
        [6] -1  0x00000000 - 0x0009ffff (0xa0000) MXB
        [7] -1  0x00000000 - 0x000001ff (0x200) IXBE
(II) Active PCI resource ranges:
        [0] -1  0xde000000 - 0xdeffffff (0x1000000) MXBE
        [1] -1  0xe0000000 - 0xe3ffffff (0x4000000) MXBE
        [2] -1  0xe6ff0000 - 0xe6ffffff (0x10000) MXB(B)
        [3] -1  0xe7000000 - 0xe7ffffff (0x1000000) MXB(B)
        [4] -1  0xdf000000 - 0xdfffffff (0x1000000) MXB(B)
        [5] -1  0x0000d400 - 0x0000d4ff (0x100) IXBE
        [6] -1  0x0000d800 - 0x0000d8ff (0x100) IXBE
(II) Active PCI resource ranges after removing overlaps:
        [0] -1  0xde000000 - 0xdeffffff (0x1000000) MXBE
        [1] -1  0xe0000000 - 0xe3ffffff (0x4000000) MXBE
        [2] -1  0xe6ff0000 - 0xe6ffffff (0x10000) MXB(B)
        [3] -1  0xe7000000 - 0xe7ffffff (0x1000000) MXB(B)
        [4] -1  0xdf000000 - 0xdfffffff (0x1000000) MXB(B)
        [5] -1  0x0000d400 - 0x0000d4ff (0x100) IXBE
        [6] -1  0x0000d800 - 0x0000d8ff (0x100) IXBE
(II) OS-reported resource ranges after removing overlaps with PCI:
        [0] -1  0xffe00000 - 0xffffffff (0x200000) MXB(B)
        [1] -1  0xfee00000 - 0xfeefffff (0x100000) MXB(B)
        [2] -1  0xfec00000 - 0xfecfffff (0x100000) MXB(B)
        [3] -1  0x00100000 - 0x3fffffff (0x3ff00000) MXBE(B)
        [4] -1  0x000f0000 - 0x000fffff (0x10000) MXB
        [5] -1  0x000c0000 - 0x000effff (0x30000) MXB
        [6] -1  0x00000000 - 0x0009ffff (0xa0000) MXB
        [7] -1  0x00000000 - 0x000001ff (0x200) IXBE
(II) All system resource ranges:
        [0] -1  0xffe00000 - 0xffffffff (0x200000) MXB(B)
        [1] -1  0xfee00000 - 0xfeefffff (0x100000) MXB(B)
        [2] -1  0xfec00000 - 0xfecfffff (0x100000) MXB(B)
        [3] -1  0x00100000 - 0x3fffffff (0x3ff00000) MXBE(B)
        [4] -1  0x000f0000 - 0x000fffff (0x10000) MXB
        [5] -1  0x000c0000 - 0x000effff (0x30000) MXB
        [6] -1  0x00000000 - 0x0009ffff (0xa0000) MXB
        [7] -1  0xde000000 - 0xdeffffff (0x1000000) MXBE
        [8] -1  0xe0000000 - 0xe3ffffff (0x4000000) MXBE
        [9] -1  0xe6ff0000 - 0xe6ffffff (0x10000) MXB(B)
        [10] -1 0xe7000000 - 0xe7ffffff (0x1000000) MXB(B)
        [11] -1 0xdf000000 - 0xdfffffff (0x1000000) MXB(B)
        [12] -1 0x00000000 - 0x000001ff (0x200) IXBE
        [13] -1 0x0000d400 - 0x0000d4ff (0x100) IXBE
        [14] -1 0x0000d800 - 0x0000d8ff (0x100) IXBE
(II) LoadModule: "dbe"
(II) Loading /usr/local/tmp/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
        compiled for 3.9.17, module version = 1.0.0
        Module class: XFree86 Server Extension
        ABI class: XFree86 Server Extension, version 0.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/local/tmp/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
        compiled for 3.9.17, module version = 1.0.0
        Module class: XFree86 Server Extension
        ABI class: XFree86 Server Extension, version 0.0
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) LoadModule: "type1"
(II) Loading /usr/local/tmp/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
        compiled for 3.9.17, module version = 1.0.0
        Module class: XFree86 Font Renderer
        ABI class: XFree86 Font Renderer, version 0.0
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "freetype"
(II) Loading /usr/local/tmp/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
        compiled for 3.9.17, module version = 1.1.7
        Module class: XFree86 Font Renderer
        ABI class: XFree86 Font Renderer, version 0.0
(II) Loading font FreeType
(II) LoadModule: "nv"
(II) Loading /usr/local/tmp/X11R6/lib/modules/drivers/nv_drv.o
(II) Module nv: vendor="The XFree86 Project"
        compiled for 3.9.17, module version = 1.0.0
        Module class: XFree86 Video Driver
        ABI class: XFree86 Video Driver, version 0.1
(II) NV: driver for NVIDIA chipsets: RIVA128, RIVATNT, RIVATNT2,
        RIVATNT2 (Ultra), RIVATNT2 (Vanta), RIVATNT2 M64,
        RIVATNT2 (Integrated), GeForce 256, GeForce DDR, Quadro
setting up HOST: 0
setting up PCI: 1

Fatal server error:
pciReadWord: Alignment error: Cannot read 16 bits at offset 28

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".

 
 
 

3.9.17 won't start on TNT card...

Post by Christian Mayrhube » Mon, 17 Jan 2000 04:00:00



> Managed to get 3.9.17 to compile properly on my machine here, but for
> the life of me haven't been able to get it to start up at all.  I've
> tried using both the "nv" driver and the generic "vga" driver, and both
> choked and died on the same message.  Tried a rebuild of the snapshot
> using the 2.2.11 kernel, got the same message.  Went back to my 2.3.38
> kernel, rebuilt the snapshot from scratch again, got the same message.
> Any ideas what's going on?

> Running this on a machine with:
> - Creative Labs Graphics Blaster TNT
> - AMD K6-III 400Mhz
> - Asus P5A-B motherboard (Bios 1.007) (ALI-V chipset)
> - Mandrake 6.1

> XFree86 compiled with opts of "-O2"; nothing fancy.

> --
> Graham TerMarsch

Try the binary glibc-2.1 snapshot of XF4.
I only use the XFree (X Server) + XMod (Modules for the XServer)
but leaved the libraries from XFree-3.3.5 where they were.
XF4 runs very stable on my system, which is the same like
yours except of a K6-2 350 and the distro, SuSE-6.3.
There is one caveat: Hardware OpenGL doesn't work anymore.

All you have to do is:
1) Download XFree and XMod binary packages
2) Make a backup copy of your old /etc/X11/XF86Config
3) Move /usr/X11R6/lib/modules to /usr/X11R6/lib/modules.XF3
4) Install the downloaded tar.gz files into /usr/X11R6
5) Set the link /usr/X11R6/bin/X to XFree
6) Edit the XF86Config file to match the XF4 format

Hope, this helps.
--
MfG,
Chris

 
 
 

3.9.17 won't start on TNT card...

Post by Stefan Voge » Sun, 23 Jan 2000 04:00:00


which compiler do you use
i had the same problem and compilde with -O0 and int worked
then i updated the gcc compiler and everything worked

Stefan (sorry for my bad english)



> > Managed to get 3.9.17 to compile properly on my machine here, but for
> > the life of me haven't been able to get it to start up at all.  I've
> > tried using both the "nv" driver and the generic "vga" driver, and both
> > choked and died on the same message.  Tried a rebuild of the snapshot
> > using the 2.2.11 kernel, got the same message.  Went back to my 2.3.38
> > kernel, rebuilt the snapshot from scratch again, got the same message.
> > Any ideas what's going on?

> > Running this on a machine with:
> > - Creative Labs Graphics Blaster TNT
> > - AMD K6-III 400Mhz
> > - Asus P5A-B motherboard (Bios 1.007) (ALI-V chipset)
> > - Mandrake 6.1

> > XFree86 compiled with opts of "-O2"; nothing fancy.

> > --
> > Graham TerMarsch

> Try the binary glibc-2.1 snapshot of XF4.
> I only use the XFree (X Server) + XMod (Modules for the XServer)
> but leaved the libraries from XFree-3.3.5 where they were.
> XF4 runs very stable on my system, which is the same like
> yours except of a K6-2 350 and the distro, SuSE-6.3.
> There is one caveat: Hardware OpenGL doesn't work anymore.

> All you have to do is:
> 1) Download XFree and XMod binary packages
> 2) Make a backup copy of your old /etc/X11/XF86Config
> 3) Move /usr/X11R6/lib/modules to /usr/X11R6/lib/modules.XF3
> 4) Install the downloaded tar.gz files into /usr/X11R6
> 5) Set the link /usr/X11R6/bin/X to XFree
> 6) Edit the XF86Config file to match the XF4 format

> Hope, this helps.
> --
> MfG,
> Chris

 
 
 

1. XFree86 3.9.17 and a Diamond Fire GL1 card

Greetings, radical superhackers,

I was just wondering if anyone out in Linuxland has had the opportunity to
get the above configuration to work properly.  I'm pretty sure that I have
all of the required materials, as I recently upgraded half of my OS (gcc ->
2.8, libc -> 2.1, kernel -> 2.2.14, and X -> 3.9.17).

I downloaded the Fire GL X driver for the generic XFree86 server from
Diamond' website, corrected the foolish mistake of having my X symlink
pointing to an old binary, and yet I still cannot get my GUI on.  I'm pretty
sure my XF86Config file is in good shape, but the server keeps crapping out
on startup with signal 11's.  The only clue I have to the behavior is that I
get a few "pciomem" errors before it crashes (sorry I don't have the exact
output file, uber-dudes).

I would appreciate any insight.  I don't get on Usenet often, so feel free
to email if you think you can help.

joshua9000

2. Telnetd -a in inetd.conf????

3. XFree86 3.9.17 and two gfx cards

4. Q: Support for Alliance PRoMotion AT3D in sight?

5. Upgrading to XFree 3.9.17 (for a geforce card)

6. HACMP NFS cluster and stale NFS mounts

7. Voodoo card + vesafb + XFree 3.9.17 = blank screen

8. Xmms Installation - lbxml.so.1 missing file

9. xf86 3.9.17 & matrox initialization

10. Xfree86 3.9.17 and Matrox g400

11. XFree86 3.9.17 XF86Config for G400 MAX

12. 3.9.17 and glint server

13. nVidia 3D support with XFree86 3.9.17?